Wii Shop and IOS51 Installer v2

Discussion in 'GBAtemp & Scene News' started by Another World, Oct 25, 2008.

  1. Another World
    OP

    Another World Emulate the Planet!

    Former Staff
    10,505
    1,699
    Jan 3, 2008
    Colombia
    From Where???
    [​IMG] Wii Shop and IOS51 Installer v2
    Update
    [​IMG]

    Muzer has released an updated version of the Wii Shop and IOS51 installer.

    [​IMG] Off-site Download
    [​IMG] Installation Instructions
    [​IMG] Source
    [​IMG] Discuss
     
  2. Screemer

    Screemer GBAtemp Maniac

    Member
    1,248
    1
    Sep 21, 2008
    Gambia, The
  3. djtaz

    djtaz PM's Full - Wadder Me

    Member
    2,997
    2
    Sep 21, 2008
    Doesnt that make it easier to brick your wii ?
     
  4. Screemer

    Screemer GBAtemp Maniac

    Member
    1,248
    1
    Sep 21, 2008
    Gambia, The
    why should that be? toonas aps are very reliable. never heard about probs with his aps. in my opinion it doesn't matter if you install the regular ios51 or the patched one. nothing except of the shopchannel makes use of it (as far as i know). not even sure if sc uses it.
     
  5. djtaz

    djtaz PM's Full - Wadder Me

    Member
    2,997
    2
    Sep 21, 2008
    I just thought that if the sig check was disabled and 2 apps used the same sig it could cause a lot of issues - i could be wrong about that.
    Its not his app as such , its other apps installed using it if the sig check is disabled.
     
  6. Screemer

    Screemer GBAtemp Maniac

    Member
    1,248
    1
    Sep 21, 2008
    Gambia, The
    i think you mixed that up with the "titels". patched signature check just means that it's possible to install fake signed wads using ios51. to say it in an other way, toona patched ios51 to have the trucha-bug as all older ioss' before the last update. at least that how i understand it.

    €dit: the signature of a valid wad is only check on installation and it's check by the ios the installer uses. so it's like it was always. installing bad wads is still bad [​IMG]
     
  7. djtaz

    djtaz PM's Full - Wadder Me

    Member
    2,997
    2
    Sep 21, 2008
    Thanks for clearing that up for me screemer - Ill change the dol in my sig to toonas i think - seems easier to install.
     
  8. ViRGE

    ViRGE GBAtemp Fan

    Member
    370
    15
    Dec 4, 2004
    What should we do if we're still on 3.2?
     
  9. dmonkey21

    dmonkey21 GBAtemp Fan

    Member
    370
    1
    Jul 10, 2007
    United States
    I think this would work on any firmware, 3.3 or 3.2, because it is essentially updating part of the firmware to the new version 3.3, but not all of it, so I think it should be good no matter what.

    Just to let you guys know the Wii Shop Channel takes much longer than the IOS51. It took like 10 minutes while the IOS took like 1 minute.
     
  10. Maikel Steneker

    Maikel Steneker M3 Fanboy

    Member
    3,396
    34
    May 16, 2007
    Netherlands
    I'm updating it using Tuna's installer now, without patching IOS51 (I figured there's no need, as all homebrew applications use IOS37 or lower).

    A few questions:
    - Can I always delete this and install it using Nintendo's updater or patch it?
    - What if I update using Nintendo's updater now? Will it still patch older IOSes, or will it say it's already the latest version?
     
  11. Screemer

    Screemer GBAtemp Maniac

    Member
    1,248
    1
    Sep 21, 2008
    Gambia, The
    if you use webupdate it will patch installed ioses. doesn't matter if 51 is already installed.
     
  12. SpaceJump

    SpaceJump Where's my new 2D-Metroid?

    Member
    3,673
    215
    Aug 18, 2005
    Gambia, The
    Zebes
    I have a 3.2E PAL Wii and never installed any cIOS. Can I install this fix to get again into the shop channel or do I have to install a cIOS before?
     
  13. djtaz

    djtaz PM's Full - Wadder Me

    Member
    2,997
    2
    Sep 21, 2008
    You will need to install the cIOS if you dont want to use the official nintendo update.
    Using their update will disable your ability to use most things coming in the future.

    Have you modded your wii in any way or do you plan to in the future ?
    If you do - dont do the nintendo update and use this way instead.

    I have all the files you need in my zip, but its aimed at people who want the backuploader and channel, though it still does what you want.
     
  14. SpaceJump

    SpaceJump Where's my new 2D-Metroid?

    Member
    3,673
    215
    Aug 18, 2005
    Gambia, The
    Zebes
    Yes, my Wii is modded with a Wiikey and I have the HBC and some other wads installed. I think you misunderstood my post. I don't want to do the official update, but I want to get into the shop channel again. My question is, can I install Muzer's version or do I have to install something before (e.g. a cIOS or PatchMii)? Thanks [​IMG]
     
  15. djtaz

    djtaz PM's Full - Wadder Me

    Member
    2,997
    2
    Sep 21, 2008
    You need a cIOS as well - Muzer has that in his files - do that first and then the shop channel - i tried it the other way and it didnt work.
    Toma has a release out that has the lot in one dol file and its the same thing but easier to install - might be worth getting his one .


    Releases by tona
    This version will install both IOS51 and the Shop Channel in the same installer and will also patch the signature hash check out of IOS51 for you (fakesign bug).
    http://junks.tonatonari.info/wiiapps/InstallShopIOS51.zip
     
  16. Zenith94

    Zenith94 1337 h4x0r f0r t3h w1nz

    Member
    825
    0
    Jul 22, 2008
    United States
    If I have 3.3 NTSC will it work?
     
  17. SpaceJump

    SpaceJump Where's my new 2D-Metroid?

    Member
    3,673
    215
    Aug 18, 2005
    Gambia, The
    Zebes
    So Muzer's IOS is a cIOS? I thought it's the official one?
     
  18. --=ZerO=--

    --=ZerO=-- GBAtemp Regular

    Member
    279
    7
    Jan 18, 2006
    Gambia, The
    Can i install this even if my Wii has still 3.2 System Menue?
     
  19. ViRGE

    ViRGE GBAtemp Fan

    Member
    370
    15
    Dec 4, 2004
    Unless I'm mistaken, firmware 3.3 included IOS37, and the new firmware (3.3v2?) includes IOS51. So if I'm on 3.2 and this installer only installs a patched version of IOS51, then I would still be lacking IOS 37 and would have no immediate way to get it.
     
  20. CockroachMan

    CockroachMan Scribbling around GBATemp's kitchen.

    Member
    3,889
    5
    Jan 14, 2006
    Brazil
    Brazil
    Yey.. everyone knew this would happen [​IMG]

    Now, couldn't this bring problems in future Nintendo updates? Let's say.. Nintendo brings up update 3.5 required to run Punch-Out or something, and that update assumes that you have everything from 3.4 installed already, couldn't it result in incompatibility problems!? [​IMG]

    Seems to me that we're starting to go in the same road as the PSP..