Wii is dropping the WiFi?

Discussion in 'Wii - Nintendo Wi-Fi Connection' started by Gamesphere, Jun 11, 2008.

Jun 11, 2008

Wii is dropping the WiFi? by Gamesphere at 5:18 PM (4,455 Views / 0 Likes) 15 replies

  1. Gamesphere
    OP

    Member Gamesphere GBAtemp Regular

    Joined:
    Dec 21, 2006
    Messages:
    209
    Country:
    United States
    Hey GBATempers,

    My Wii's wifi connection is very sketchy and I hope someone can help me fix it. Our 1st router crapped out so we have a new one now. It is a Linksys WRT54GL running on default firmware fresh out the box as it was brand new about two weeks ago. The Wii can detect and connect to our wireless network just fine. The problem is maintaining the connection for extended periods. The router is on b/g mode, channel 1, with the Wii MAC address in the allowed list.

    When I say dropping the connection, the Wii refuses to stay connected. When you establish the connection between the Wii and the network, it works perfectly. I am able to play games, use the shop channel, and all that stuff. But if you leave the Wii alone for about 2 days, The Wii loses the connection. I am still able to see my wireless network running at 3 bars if I search for an access point. The Wii says its still using connection one to the network but if you do a connection test, I recieve a 52130 error code. If I try to establish a new connection to the same network, I recieve a 51331 error. It's very fustrating as the router is just only downstairs. I've found that power-cycling works to recover the connection but I can't keep doing that everytime just to play a game. Help? [​IMG] [​IMG]

    I should note the Wii was having the same problem with the old router. But this problem didnt arise until when I deleted the access point connection settings for the first time on the Wii.

    Before someone asks, Yes, I went to Nintendo's support site and yes, I tried all of the recommended solutions to fix it. Thanks.
     
  2. Gamesphere
    OP

    Member Gamesphere GBAtemp Regular

    Joined:
    Dec 21, 2006
    Messages:
    209
    Country:
    United States
    Please try to help me solve this problem...Im so aggravated... and SSBB becomes half a game without online...
     
  3. Renegade_R

    Member Renegade_R Audio/Video Expert

    Joined:
    Apr 21, 2004
    Messages:
    1,654
    Location:
    Toronto, Ontario
    Country:
    Canada
    Are you in a house or appartment? Apartments are notorious for having sketchy wireless due to sheer amount of local networks. Here's a tip, try changing the wireless channel to 11 or 1. Those are the least used channels. It fixed my problem...if it doesn't...try flashing the Tomato firmware as that solved ALL my Linksys issues.
     
  4. Gamesphere
    OP

    Member Gamesphere GBAtemp Regular

    Joined:
    Dec 21, 2006
    Messages:
    209
    Country:
    United States
    Im in a house, Just switched my wifi to 11. No cigar. My dad is planning to flash the router with DD-WRT pretty soon. Should he use Tomato instead?
     
  5. Renegade_R

    Member Renegade_R Audio/Video Expert

    Joined:
    Apr 21, 2004
    Messages:
    1,654
    Location:
    Toronto, Ontario
    Country:
    Canada
    DD-WRT did not fix my problems like Tomato did

    Plus it has the same feature set...just less pretty
     
  6. Renegade_R

    Member Renegade_R Audio/Video Expert

    Joined:
    Apr 21, 2004
    Messages:
    1,654
    Location:
    Toronto, Ontario
    Country:
    Canada
    Oh and one more thing...you might want to try the router NEXT to the Wii and see what happens...for all you know your Wii may have a faulty Wi-Fi chip inside.
     
  7. TheWingless

    Member TheWingless Wafuu~

    Joined:
    Jan 29, 2008
    Messages:
    1,034
    Country:
    United States
    If you're looking at flashing the firmware, you can look at a few differences between Tomato and DD-WRT here: Linky
    It looks like Tomato is the easier one to use?

    According to the Nintendo support page for the code 52130 it has to do with router security, MAC address, or broadcast channels: Linky
     
  8. Renegade_R

    Member Renegade_R Audio/Video Expert

    Joined:
    Apr 21, 2004
    Messages:
    1,654
    Location:
    Toronto, Ontario
    Country:
    Canada
    Just giving you a heads up on what I have:

    I gave all my Nintendo products manual IP addresses by configuring them directly in device. I also added them to a MAC address filter list which only permits those devices from accessing. I use 128-bit WEP encryption (yeah...I know...)...I use Channel 11 for broadcasting.
     
  9. Gamesphere
    OP

    Member Gamesphere GBAtemp Regular

    Joined:
    Dec 21, 2006
    Messages:
    209
    Country:
    United States
    I have my Wii under MAC address allowed zone. WPA encryption, 100 MTU, Auto access IP and DNS. Channel 11and it still doesn't work.

    I can get a router connection with 3 bars upstairs but the problem is maintaining it. Even though it says connection 1 is set up and being used. It's like there is no Wifi set up at all( thats almost the best way to explain it)

    I really hope it's not my Wii's wi-fi card itself as it is modded with a Wiikey. [​IMG] [​IMG] plus I don't think the new Wii's are moddable like my D2B chip so I cant just go and buy another one.

    IDK, Im going to try taking the firewall of the router and then if not, flash it with Tomatoe. I'll post back with results. Thanks so much BTW I really do appreciate it.

    Official Nintendo Forums are some shit.... Posted yesterday and still no reply.
     
  10. Renegade_R

    Member Renegade_R Audio/Video Expert

    Joined:
    Apr 21, 2004
    Messages:
    1,654
    Location:
    Toronto, Ontario
    Country:
    Canada
    Mind you Nintendo forums consist mostly of kids and young teens...they will not be of much help anyways. Post back...or message me...I'll be glad to help.
     
  11. layzieyez

    Member layzieyez GBAtemp Fan

    Joined:
    Jun 24, 2007
    Messages:
    440
    Country:
    United States
  12. Gamesphere
    OP

    Member Gamesphere GBAtemp Regular

    Joined:
    Dec 21, 2006
    Messages:
    209
    Country:
    United States
    OK, I took of the firewall and reseted the router and it worked. The connection is up, the real test is, if it can hold it till sunday. Thanks for your help guys, post back Sunday..
     
  13. Gamesphere
    OP

    Member Gamesphere GBAtemp Regular

    Joined:
    Dec 21, 2006
    Messages:
    209
    Country:
    United States
    Hey, Sadly... The Wii dropped earlier today....damn what could it be? The firewall is turned off... My dad tried with his laptop, he can connect to the network just fine so It is a Wii related issue by itself. I guess the only thing left to do is flash the router with Tomato and try again....If not im sooooo screwed [​IMG] [​IMG] [​IMG]
     
  14. bytor

    Member bytor GBAtemp Regular

    Joined:
    Mar 5, 2008
    Messages:
    296
    Country:
    United Kingdom
    Saved me a bit of typing there. A broadband wired connection will always be faster and always connected. I only switched mine from a LAN to a wireless connection because I was getting the hump with getting off my fat arse and switching the cable lol [​IMG]
     
  15. Gamesphere
    OP

    Member Gamesphere GBAtemp Regular

    Joined:
    Dec 21, 2006
    Messages:
    209
    Country:
    United States
    I would be using LAN but there is no ethernet phone line jack in the room where I use it. It's really pissing me off as the Wii use to work and connect fine the first months I had it until I deleted the Wifi connection the first time. I really need to fix this thing,It already sucks that I lost my DS wifi due to the wifi encryption being WPA. What I will do now is borrow my friends wii to see if its my Wii thats the problem...(Hope not) and flash the router with Tomato....
     
  16. link459

    Member link459 GBAtemp Fan

    Joined:
    Oct 17, 2006
    Messages:
    354
    Country:
    United States
    I had the same issue as you...

    Flashed DD-WRT, never had any issues since. It's amazing.
     

Share This Page