Wii - Currently at 3.1. Need to upgrade to 4.0. Have a few questions.

Discussion in 'Wii - Hacking' started by Lemon187, May 19, 2009.

  1. Lemon187
    OP

    Lemon187 Newbie

    Newcomer
    8
    0
    May 19, 2009
    United States
    Hey I have been doing allot of searching and I keep coming up with mixed tutorials and methods. My wii is a USA wii and is currently at 3.1U. I keep reading about having to do a cIOS install before upgrading to 4.0. My drive is also chipped if this helps.

    I have found a site with a blue background that appears to have all the files necessary for getting it up to par.

    I need to install cIOS rev 10 before I upgrade correct?

    This is what I think I will have to do:

    1. Install cIOS rev7 using a "4.0 softmod pack"
    2. Upgrade to cIOS rev10
    3. Check to ensure bannerbomb is working
    4. Upgrade to 4.0 via wii shop channel ?
    5. Use banner bomb/bootwii to install homebrew channels?

    Can someone please direct me to a full tutorial for a correct upgrade to 4.0 with all the cIOS properly done?

    Thanks for the help!
     
  2. piratesmack

    piratesmack GBAtemp Advanced Fan

    Member
    787
    0
    Mar 28, 2009
    United States
    $(pwd)
    This is what I'd do:

    1.) Download these:

    BannerBomb:
    http://bannerbomb.qoid.us/

    HackMii installer:
    http://www.bootmii.org

    CIOS Rev 10 installer:
    http://teknoconsolas.es/blog/waninkoko/custom-ios36-rev-10

    Waninkoko's Firmware Downgrader (I know it says downgrader, but it can also upgrade):
    http://teknoconsolas.es/blog/waninkoko/fir...downgrader-v111

    2.) User BannerBomb to start the HackMii installer. Install HomeBrew Channel and BootMii

    3.) Run the CIOS Rev 10 Installer from the HomeBrew Channel

    4.) Now run Waninkoko's Firmware Downgrader, choose to install 4.0U
     
  3. Lemon187
    OP

    Lemon187 Newbie

    Newcomer
    8
    0
    May 19, 2009
    United States

    Thanks for the help in plain English [​IMG]

    Quick question though, I already have The Homebrew Channel installed. Should I still install it?

    Also I just looked at Waninkokos firmware downgrader and it is only about 300kb. Will it download 4.0 via wifi?
     
  4. piratesmack

    piratesmack GBAtemp Advanced Fan

    Member
    787
    0
    Mar 28, 2009
    United States
    $(pwd)
    Which version do you have?
    The HackMii installer comes with the new version 1.0.2

    If you already have version 1.0.2 then there is no need to, but t wouldn't hurt to reinstall it.
     
  5. Lemon187
    OP

    Lemon187 Newbie

    Newcomer
    8
    0
    May 19, 2009
    United States
    My HBC is at 1.0.1

    I will follow your setup to the T.

    Thanks man!
     
  6. piratesmack

    piratesmack GBAtemp Advanced Fan

    Member
    787
    0
    Mar 28, 2009
    United States
    $(pwd)
    Yep.
     
  7. Lemon187
    OP

    Lemon187 Newbie

    Newcomer
    8
    0
    May 19, 2009
    United States
    For step #3 do I create a folder for bootmii? For example, SDROOT/Bootmii/boot.elf or do I just put it on the root of the sd card?
     
  8. piratesmack

    piratesmack GBAtemp Advanced Fan

    Member
    787
    0
    Mar 28, 2009
    United States
    $(pwd)
    Just put it in the root of the SD card
     
  9. Lemon187
    OP

    Lemon187 Newbie

    Newcomer
    8
    0
    May 19, 2009
    United States
    Last question them im good to go [​IMG]

    Do I install CIOS Rev 10 installer and Waninkoko's Firmware Downgrader both from HBC?

    So place both .dol files for rev10 and fw downgrader in the apps folder on the SD card?

    My SD card looks like:

    Root:

    boot.elf (Hackmii installer)
    /private (banner bomb inside)
    /apps

    APPS:
    /rev10 (cIOS rev10.dol inside)
    /firmware (firmware dowgrader.dol inside)

    looks right?
     
  10. piratesmack

    piratesmack GBAtemp Advanced Fan

    Member
    787
    0
    Mar 28, 2009
    United States
    $(pwd)
    Create subdirectories for each dol

    Example:
    SD:/apps/bootmii/boot.elf
    SD:/apps/cios rev 10/boot.dol

    Also, you have to rename them to boot.dol or boot.elf
     
  11. Lemon187
    OP

    Lemon187 Newbie

    Newcomer
    8
    0
    May 19, 2009
    United States
    Nice im ready to go [​IMG]

    thanks for the help!!!
     
  12. piratesmack

    piratesmack GBAtemp Advanced Fan

    Member
    787
    0
    Mar 28, 2009
    United States
    $(pwd)

    No problem

    Good luck :-)
     
  13. F34R

    F34R GBAtemp Regular

    Member
    195
    17
    Jun 22, 2006
    United States
    hmmm, upgrading to 4.0U, I get returned error -1036 while it's installing the firmware.

    I have HBC 1.02 installed. I installed cIOS r10.
    When I used the Wann Downgrader, it started downloading everything for the 4.0U firmware, when it started installing, it returned the error and said it failed.
     
  14. Lemon187
    OP

    Lemon187 Newbie

    Newcomer
    8
    0
    May 19, 2009
    United States
    Damn I get the same error! 1036. Im searching a cure for it
     
  15. Lemon187
    OP

    Lemon187 Newbie

    Newcomer
    8
    0
    May 19, 2009
    United States
    You need to install a patched version of ios60 before installing. Fixed the problem for me. Or it could be you do not have enought space. I think 250+ blocks is required