Wii cant update hbc 1.0.3 (vunlerable IOS .security reasons)

Discussion in 'Wii - Hacking' started by KQJai, Jun 1, 2009.

  1. KQJai
    OP

    KQJai Newbie

    Newcomer
    8
    0
    May 31, 2009
    Canada
    I followed some video tutorials on youtube and i
    i installed a hbc 1.0.1 with the bannerbomb exploit
    installed the cIOScorp1.01 with many steps like wad, iso downgrade, ciosrev10installer
    and also preloader v0.29


    i dunno anything about homebrew, but when i got enter the homebrew channel, theres a pop up asking to update.
    clicked yes, and when to the "if u paid, u got scrammed" thing, and the installer stops
    because of there is no known vulnerable IOS, and will not use a fakesigned IOS due to security reasons


    I read it in a thread saying that the CIOScorp was the problem.
    Can some one provide me a step by step tutorial to solve this.


    I also tried updating Custom IOS38 rev12 hoping it would solve my problem. but it didnt.
    Thanks.
     


  2. kyle007

    kyle007 GBAtemp Fan

    Member
    387
    1
    Oct 5, 2008
    United States
    just run iosdowngrader it should download ios12 (it did for me and thats the only one it downloaded) and then it should run properly
     
  3. FenrirWolf

    FenrirWolf GBAtemp Psycho!

    Member
    4,347
    329
    Nov 19, 2008
    United States
    Sandy, UT
    Yup, cioscorp confuses BootMii, so just run IOS downgrader.
     
  4. KQJai
    OP

    KQJai Newbie

    Newcomer
    8
    0
    May 31, 2009
    Canada
    How does the iosdowngrader do?

    downgrades my firmware? i am currently on 4.0U

    do i download Custom IOS Downgrader v1.2?

    please teach how to install that please
     
  5. wolffangalchemist

    wolffangalchemist This is bat country!

    Member
    1,408
    31
    Nov 23, 2008
    United States
    middleofnowhere, AL
    use nus downloader or google to get a (non cios)ios36 wad file and install it with wad manager.
    then run the hackmii installer install hbc then install cios36.wad from your cioscorp folder.
     
  6. TroyTheZombie

    TroyTheZombie GBAtemp Advanced Maniac

    Member
    1,631
    4
    Mar 3, 2009
    Canada
    Calgary, Canada
    IOS downgrader is not the same as cIOS downgrader.

    Once you find IOS downgrader (google is your friend), you simply run it through the homebrew channel.

    (check your PM)
     
  7. Nintendo_Chick

    Nintendo_Chick GBAtemp Fan

    Member
    386
    0
    Feb 6, 2009
    United States
  8. KQJai
    OP

    KQJai Newbie

    Newcomer
    8
    0
    May 31, 2009
    Canada
    THank you guys for much, thanks TroyTheZombie for pm me the link. the IOS downgrader solved the problem.
     
  9. kyle007

    kyle007 GBAtemp Fan

    Member
    387
    1
    Oct 5, 2008
    United States
    whats with everyone and saying ios36? i have cioscorp v2 and when i ran ios downgrader it downloaded ios12 and the installer worked just fine running off of ios12
     
  10. piratesmack

    piratesmack GBAtemp Advanced Fan

    Member
    787
    0
    Mar 28, 2009
    United States
    $(pwd)
    The installer works fine running off of IOS36, too.
     
  11. FenrirWolf

    FenrirWolf GBAtemp Psycho!

    Member
    4,347
    329
    Nov 19, 2008
    United States
    Sandy, UT
    The installer will run off of IOSAnything as long as it's not a patched IOS like cioscorp ones are.
     
  12. lexlth

    lexlth Advanced Member

    Newcomer
    95
    0
    Mar 16, 2009
    Brazil
    but runing ios downgrader will remove cOISCORP functionalities ?
    Will I still be able to boot from Disc Channel ?

    Also, this bootmii, will it aotu remove preloader ? Or it may conflict with it ?

    I think I had to run iosdowngrader once before install preloader, and after that I had to reinstall preloader, because apeared a message of System Files Corrupted...

    What do I do now ???
     
  13. FenrirWolf

    FenrirWolf GBAtemp Psycho!

    Member
    4,347
    329
    Nov 19, 2008
    United States
    Sandy, UT
    It'll remove cioscorp's functionality, but if you care that much about it you can reinstall cioscorp later. But you'd be better off using the USB loader since it's faster than discs and doesn't throw off BootMii's groove.

    And it won't conflict with Preloader at all.
     
  14. MaDDaWg836

    MaDDaWg836 GBAtemp Regular

    Member
    104
    0
    Jun 21, 2006
    United States
    I've tried running the IOS downgrader and it didnt work. my HBC keeps staying at a black screen after the update to 1.03. how can i update it?
     
  15. Chemical_Warfare

    Chemical_Warfare GBAtemp Regular

    Member
    111
    0
    Oct 25, 2008
    Canada
    agreed but disagreed... GH:WT and Rockband dont cooperate the same way they do from USB as they do Disc... I use USBLoader for everything except "band" games. I enjoying having CIOSCORP's disc channel functionality for when i do use discs.
     
  16. dudon

    dudon Newbie

    Newcomer
    7
    0
    May 26, 2009
    United States
     
  17. dudon

    dudon Newbie

    Newcomer
    7
    0
    May 26, 2009
    United States
    TroyZombi - have a question for you
    First - thanks for all your replies, i follow your updates and it looke you have experience - you're tha Maaan

    I have softmod, 3.2U, cios38 rev 13a, HBC 1.01, USBLOADER GX ULNR R550 - I want to upgrade to HBC 1.03 but i know i will get the freeze screen of the HBC ( sisnce it happen when i helped my frined, and we had to redo the whole thing with the Zelda....

    What do i need to do in order to solve it and not getting the UPDATE screen everytime i get to the Hombrrew???
    thanks again. [​IMG]
     
  18. TroyTheZombie

    TroyTheZombie GBAtemp Advanced Maniac

    Member
    1,631
    4
    Mar 3, 2009
    Canada
    Calgary, Canada
    Because you are at 3.2, you are missing the IOS file needed for HBC 1.0.3. That is why the black screen.

    Why not update to 4.0? You'll need to eventually, and It makes running certain things a tad easier.
     
  19. Jaz808

    Jaz808 GBAtemp Fan

    Member
    337
    0
    Jan 21, 2003
    Melb Aus
    Installing IOS36-64-v1042.wad worked for me, i was stuck on HBC 1.0.1 and kept getting a error saying "no vulnerable IOS found," now i can update to 1.0.3
     
  20. mikewill57

    mikewill57 Member

    Newcomer
    10
    0
    Jun 23, 2009
    United States
    Did you just DL it, put it in ur wad folder and launch it via wad manager 1.4?