WII 4.1 > 3.2 now?

Discussion in 'Wii - Hacking' started by freeza, Sep 11, 2009.

Sep 11, 2009

WII 4.1 > 3.2 now? by freeza at 7:30 AM (1,543 Views / 0 Likes) 11 replies

  1. freeza
    OP

    Newcomer freeza Member

    Joined:
    May 4, 2008
    Messages:
    38
    Country:
    United States
    Would you guys say that with all the progress made in the homebrew/hacking community that using system menu 4.x is just as good for homewbrew as 3.2 is?

    I have a fully soft-modded 3.2U system and am wondering with all the 4.x talk, is 4.x now up to par with 3.2 and should I proceed to upgrade?

    I tried to search for topics that discuss this but couldn't find any. Sorry if this is a duplicate topic...
     
  2. technosexual

    Newcomer technosexual Member

    Joined:
    Dec 1, 2008
    Messages:
    49
    Country:
    United States
    replace twilight hack with banner bomb, and then yes.

    there isnt much reason to be on 3.2 any more
     
  3. freeza
    OP

    Newcomer freeza Member

    Joined:
    May 4, 2008
    Messages:
    38
    Country:
    United States
    Thanks for the reply.. I guess it's time to research, read some tutorials, and upgrade lol.

    I hope I don't brick it.
     
  4. WalkerOfTheDay

    Member WalkerOfTheDay GBAtemp Advanced Fan

    Joined:
    Oct 10, 2008
    Messages:
    848
    Country:
    Netherlands
    Make a nand backup first. Then run wanin's 4.0 updater, after that 4.1 updater and preloader.
    Should be fine.
     
  5. freeza
    OP

    Newcomer freeza Member

    Joined:
    May 4, 2008
    Messages:
    38
    Country:
    United States
    Thanks, i'll do it tomorrow morning then.

    So, functionality wise, 3.2 no longer offers anything over 4.1 as in compatibility with homebrew?
     
  6. thesund0g

    Member thesund0g GBAtemp Fan

    Joined:
    Aug 6, 2009
    Messages:
    452
    Location:
    The Boonies
    Country:
    Antarctica
    There's no difference that I'm aware of. You have to switch from Starfall or Preloader to Startpatch, I believe [unfortunately]. I can't think of any real reason to upgrade. Triiforce + cIOS14 isn't any less convenient than the ganky SD loader built into 4.x. I'm not aware of any other remotely interesting features.
     
  7. nabster92

    Member nabster92 GBAtemp Advanced Maniac

    Joined:
    Apr 16, 2009
    Messages:
    1,631
    Country:
    United States
    Did you mean switch from Starfall TO preloader OR Startpatch? Preloader works fine on 4.0/4.1. Why is that unfortunate at all? Both outclass Starfall in pretty much every way.

    Other than that, yea I suppose there isn't all that much 4.0/4.1 offers, but you don't LOSE anything compatibility wise (aside from starfall, which again has better alternatives anyways), so you don't have to be afraid of that regarding updating.
     
  8. HDW

    Newcomer HDW Advanced Member

    Joined:
    Jan 18, 2007
    Messages:
    85
    Country:
    United Kingdom
    I'm currently on 3.1 and wish to upgrade to 4.1. What steps do you suggest I take. I have done the following:

    Installed Bootmii onto boot2
    Installed Waninkoko's 249 IOS
    Installed Waninkoko's c36 IOS

    What else should I do? Would I lose any functionality if I upgraded now?
     
  9. nubecoder

    Newcomer nubecoder Advanced Member

    Joined:
    May 20, 2009
    Messages:
    82
    Country:
    United States
    1 - Backup your NAND with BootMii.
    2 - Run Waninkoko's 4.0 updater.
    3 - Run Waninkoko's 4.1 updater.
    4 - For SD channel loading (optional?) - Run DOPIOSv7 to install IOS60 including the sig hash patch (trucha bug).
    5 - Install Preloader (optional)

    I think that covers it... Make sure to do step 1, and you have no worries.

    Also, WTH is c36 IOS?? If you mean cISO36 revX (where X is the rev number).

    Then that ~IS~ Waninkoko's 249 IOS! And the newer revisions are based on IOS38, so you should update to cIOS38 rev14 (newest ATM).
     
  10. thesund0g

    Member thesund0g GBAtemp Fan

    Joined:
    Aug 6, 2009
    Messages:
    452
    Location:
    The Boonies
    Country:
    Antarctica
    Unfortunate to go from [starfall or preloader] to [startpatch] [​IMG] Startpatch isn't bad, but it's no Preloader.
     
  11. nabster92

    Member nabster92 GBAtemp Advanced Maniac

    Joined:
    Apr 16, 2009
    Messages:
    1,631
    Country:
    United States
    So then don't use StartPatch? Nothing prevents Preloader from working on 4.0/4.1 and there is a full set of hacks for the hacks.ini for all three of those firmwares (3.2, 4.0, 4.1). Anyone who installs Startpatch over Preloader are pretty much just people that are too afraid to do anything that affects the system menu IOS. or don't wan't an extra step in their boot process (even if it's set to autoboot).

    4.0 stops Starfall from working, nothing else. Startpatch replaces it and does it better. Preloader is Preloader, it works on both. It SHOULD be used regardless over either of them. Boot2 Bootmii outclasses them all (as far as brick protection goes at least) and works on anything as long as the system is old enough.

    That's probably another reason anyone would use StartPatch over Preloader, they have all the brick protection they need from boot2 bootmii, so instead of adding another step to their boot process, they just use StartPatch to enable the same hacks Preloader does without touching the system menu IOS.
     
  12. mikgod

    Newcomer mikgod Newbie

    Joined:
    Sep 12, 2009
    Messages:
    1
    Country:
    France
    I've got 3.3E, and I installed boot2, hbc, trushabuged the ios36, ran CIOSrev14 installer on IOS36, ran Dop-IOS v7 on IOS60 and installed preloader.
    If I update, do I have to do these all over again? and should i patch other ios with Dop-IOS or do anything else at this point?
     

Share This Page