Hacking Why does one build of rxTools support TWL/AGB and another doesn't?

wurstpistole

GBAtemp MVP
Member
Joined
Nov 19, 2015
Messages
4,525
Trophies
1
XP
4,488
Country
United Kingdom
Hey there,

a technical question here. I was wondering, why does rxTools in some versions support TWL/AGB, but not MH4U/SM4SH and in other versions it's vice versa? I understand that MH4U and SM4SH reboot the device to another mode, as does GBA VC/ DSiWare, but what's the background that not both can be implemented? And is there any way to see which version does what except of trying it out yourself? Thanks!
 

Tony_93

Well-Known Member
Member
Joined
Jun 13, 2015
Messages
2,453
Trophies
0
Location
California
XP
2,245
Country
United States
There was a time were rxTools didn't support cia installation, the original creator (Roxas75) was anti-piracy, so rxTools was closed source and didn't have signatures patched which means no cia installation.

Some people "hacked" his CFW and released 2 unofficial versions that allowed cia installation. One had Smash/MH4U support but no GBA/DSiware support and the other one had GBA/DSiware support but it didn't have Smash/MH4U support.

That's when he decided to open up rxTools, officially support cia installation and added GBA/DSiware support too.

All versions from 2.5.2 to the latest nighlies suppor both SMASH/MH4U AND GBA/DSIWARE SUPPORT.

Those versions where one of the 2 things are not supported shouldn't be used anymore at this point, they are outdated and more than buggy.
 

wurstpistole

GBAtemp MVP
Member
Joined
Nov 19, 2015
Messages
4,525
Trophies
1
XP
4,488
Country
United Kingdom
People don't seem to get gba VC running with the latest nightly in my tutorial. But these are all people who downgraded and gba VC is also not working in their sysnand. Still suspecting downgrade bugs here. I didn't try gba myself yet on my native 9.0 which was not downgraded.
 

wurstpistole

GBAtemp MVP
Member
Joined
Nov 19, 2015
Messages
4,525
Trophies
1
XP
4,488
Country
United Kingdom
There was a time were rxTools didn't support cia installation, the original creator (Roxas75) was anti-piracy, so rxTools was closed source and didn't have signatures patched which means no cia installation.

Some people "hacked" his CFW and released 2 unofficial versions that allowed cia installation. One had Smash/MH4U support but no GBA/DSiware support and the other one had GBA/DSiware support but it didn't have Smash/MH4U support.

That's when he decided to open up rxTools, officially support cia installation and added GBA/DSiware support too.

All versions from 2.5.2 to the latest nighlies suppor both SMASH/MH4U AND GBA/DSIWARE SUPPORT.

Those versions where one of the 2 things are not supported shouldn't be used anymore at this point, they are outdated and more than buggy.
Could it be that it doesn't work only on n3ds?
 
  • Like
Reactions: 4ur0r

wurstpistole

GBAtemp MVP
Member
Joined
Nov 19, 2015
Messages
4,525
Trophies
1
XP
4,488
Country
United Kingdom
I tried it myself now on my 9.0 N3DS.

I installed 3 gba titles, two were injected roms, and one was a legit ambassador game. Installed them to both SysNAND and EmuNAND. Drumroll for the result...

- they don't work in SysNAND with Pasta
- they don't work in EmuNAND

None of them works, not even in SysNAND and not even the legit one. Just black screen in EmuNAND and "An error occured" in SysNAND.

How is it @Tony_93 that you say they are supported? I am a bit confused.
 
  • Like
Reactions: 4ur0r

wurstpistole

GBAtemp MVP
Member
Joined
Nov 19, 2015
Messages
4,525
Trophies
1
XP
4,488
Country
United Kingdom
Yes . legit CIAs (ambassador games) will work in sysnand. For injected VC you need agb firm patched in sysnand. On new 3ds none of those will work in Emunand at the moment, on o3ds they will but you also need to patch agb firm in Emunand and install the cia to both nands.
 

Site & Scene News

General chit-chat
Help Users
    Marioman65 @ Marioman65: what...