Which USB dongle should I buy if my PS3 has firmware 3.5?

Discussion in 'PS3 - Hacking & Homebrew' started by Boshinator, Dec 23, 2010.

  1. Boshinator
    OP

    Newcomer Boshinator Member

    Joined:
    Jul 12, 2007
    Messages:
    33
    Country:
    Canada
  2. DaMummy

    Member DaMummy GBAtemp Maniac

    Joined:
    Dec 22, 2007
    Messages:
    1,265
    Location:
    Cleveland
    Country:
    United States
    my amazebreak can downgrade, so can my rockbox mp3 player
     
  3. Boshinator
    OP

    Newcomer Boshinator Member

    Joined:
    Jul 12, 2007
    Messages:
    33
    Country:
    Canada
  4. DaMummy

    Member DaMummy GBAtemp Maniac

    Joined:
    Dec 22, 2007
    Messages:
    1,265
    Location:
    Cleveland
    Country:
    United States
    thats the dongle im using now, and it does support downgrade for 3.5, dont have an answer for what apple products are supported
     
  5. ThetaSigma10

    Member ThetaSigma10 GBAtemp Regular

    Joined:
    Apr 16, 2009
    Messages:
    140
    Location:
    Western Australia
    Country:
    Australia
    As far as Idevices, I don't know about the normal Ipods, but the Ipod touch 1g is supported and so is the original Iphone and the Iphone 3g. any other ipod touches/iphones are NOT supported.
     

Share This Page