Which media player to use for usb hdd

Discussion in 'Wii - Emulation and Homebrew' started by scousethief, Jul 3, 2009.

  1. scousethief
    OP

    scousethief GBAtemp Regular

    Member
    286
    0
    Nov 14, 2006
    Hi all , as the title says which should i use for usb hdd playback . Geexbox plays fine i just dont like the interface as im used to media player ( big blue play button as its channel icon ) the media player im used to can play from sdcard but trying to access the hdd it gives a code dump (geexbox works fine and i play games from the hdd if that makes any difference) .

    so really...

    simple interface

    install as a channel if possible

    can play divx/xvid from a usb hdd with minimum of fuss.

    Thanks for any advice guys.


    Scouse


    i did want to try streaming from the hdd in my pc via wireless router but couldnt get anywhere with that at all.
     
  2. Eddie_Brock

    Eddie_Brock GBAtemp Fan

    Member
    344
    0
    Apr 15, 2009
    Canada
    Vancouver Island
    MPlayer_CE is your best bet. I've converted from GeexBox myself, and have never looked back.

    Although I haven't tried it, you can apparently setup SMB in CE so that you can stream videos through the wi-fi. There is a google-code page based entirely on this, hit up their page on wiibrew.org for more details.

    As for running off a USB HDD, make sure that its plugged in to the proper USB port, and that you have a FAT32 primary partition. Its lame I know, but Geexbox supports NTFS and FAT32, but MPlayer_CE only supports FAT32 at this point.

    Good Luck
     
  3. scousethief
    OP

    scousethief GBAtemp Regular

    Member
    286
    0
    Nov 14, 2006
    Cheers Eddie ill look at the streaming options a little later. At the minute 1 have 2 seperate drives one is fat 32 with movies on which CE just gives a code dump when trying to use but geexbox can see , and another with games on which i play through usbloader , ill see what i can figure out lol.
     
  4. Lexip;

    Lexip; GBAtemp Fan

    Member
    413
    0
    Apr 8, 2009
    United States
    The smb works great in mplayer_ce, its just a pain to set up because it is done by ip.
     
  5. imapterodactyl

    imapterodactyl GBAtemp Fan

    Member
    424
    0
    Jan 20, 2009
    United States
    Does CE give you a code dump whenever you launch it, or only when you try to load usb? CE crashed on me consistently at first, as it was trying to get a network connection when there wasn't one. Just comment out everything in smb.conf to fix that issue.
     
  6. UranusKiller

    UranusKiller TranceMaster

    Member
    960
    3
    Feb 9, 2009
    Redcar, England, UK.
    you using an old version?
     
  7. scousethief
    OP

    scousethief GBAtemp Regular

    Member
    286
    0
    Nov 14, 2006
    Hi thanks guys , im using the latest version of CE i think downloaded from the homebrew channel , gives a code dup everytime i try to play from the usb drive , sd card is ok , usb drive is fat 32 and is picked up no problem by geexbox. Ce loads , gives the menu , i choose usb , Path: comes up on the screen and then it gives a code dump.
     
  8. UranusKiller

    UranusKiller TranceMaster

    Member
    960
    3
    Feb 9, 2009
    Redcar, England, UK.
  9. scousethief
    OP

    scousethief GBAtemp Regular

    Member
    286
    0
    Nov 14, 2006
    Yes m8 redone everything again since my last post. Still getting a code dump as soon as i try and access the drive via CE, geexbox sees it perfectly fine .

    Probably makes no difference but i swap the drive to my game drive and usbloader sees it perfectly fine so i sort of "know" that the usb side of things as far as usbloader and geexbox is working ok.

    Im not saying its CE i know its something i havent done somewhere along the line im just trying to figure out what im possibly missing.

    drive is a cheapo dealexetreme caddy with a 2.5 40 gig hitachi laptop drive , so far works in everything so im just guessing im missing something that CE needs.
     
  10. UranusKiller

    UranusKiller TranceMaster

    Member
    960
    3
    Feb 9, 2009
    Redcar, England, UK.
    have you tried the usb2 test?
     
  11. scousethief
    OP

    scousethief GBAtemp Regular

    Member
    286
    0
    Nov 14, 2006
    Just to add , did the cios installer 3.dol and now hard drive is not detected at all in any of the apps [​IMG] nightmare, could someone list the necessary files needed to get the usb hdd working again id be grateful in pm if necessary.

    Thanks
     
  12. imapterodactyl

    imapterodactyl GBAtemp Fan

    Member
    424
    0
    Jan 20, 2009
    United States
    Now that you mention it, yes. This was in .61.

    As it turns out, it appears this has been resolved in .62. Thanks for the heads up!
     
  13. UranusKiller

    UranusKiller TranceMaster

    Member
    960
    3
    Feb 9, 2009
    Redcar, England, UK.
    btw the cios install installs to ios202 so other apps can't be broke using usb.
    imapterodactylall working fine now?
     
  14. nIxx

    nIxx GBAtemp Advanced Maniac

    Member
    1,518
    76
    Sep 30, 2007
    Gambia, The
    Germany
    They are both good i use GeexBox for NTFS and Mplayer CE for FAT
     
  15. scousethief
    OP

    scousethief GBAtemp Regular

    Member
    286
    0
    Nov 14, 2006
    then i really do have a problem as the only thing i have installed is that ios and now i have no usb at all . lol
     
  16. BigBolt

    BigBolt Member

    Newcomer
    26
    0
    Apr 3, 2009
    Brazil
    i prefer geexbox
    meplayer just gives me errors ¬¬´