Where does Saviine inject the save files in the WiiU?

Discussion in 'Wii U - Homebrew' started by Deniii, May 16, 2017.

  1. Deniii
    OP

    Deniii Member

    Newcomer
    47
    2
    Aug 6, 2009
    United States
    I've been meaning to ask this for a while and, since I can't find any info on the web, I decided to finally do it.
    I'd like to know where does Saviine inject to/dump from the save files in the WiiU.

    When I run it, it says the path is "vol/save/80000003", however, when I run ftpiiu everywhere and Filezilla, there's no folder named "vol" and trying to access the path by typing it gives an error (don't remember the code but it's a "path doesn't exist" kind of error)

    I did find however, a folder for save files in "storage_mlc/usr/save/00050000" and it indeed has the save files.
    I transfered the save for Advance Wars: Dual Strike and opened it with Desmume by importing it and it was the same save in the WiiU (save progress, medals, cleared Warroom maps, etc)
    So, I do a couple of extra things in the emulator (clear Combat in Brutal) and try to transfer the save back to the previous folder via Filezilla (storage_mlc/usr/save/00050000/101DA500/user/80000003)
    I delete everything, copy all the files (4 files), exit ftpiiu everywhere and homebrew launcher and run Advance Wars: Dual Strike.
    When I run the game, it got stuck with a black screen. I exit the game (don't remember if it was via Home button or Power button) and try running the game again.
    This time it started fine but the save file wasn't the updated one from the emulator. It was the previous version, with Brutal Combat still not cleared.

    This leads me to believe there is more than one folder for the saves and the whole "vol/save/80000003" is just a representation Maschell used to notify the users that the save folders are being accesed.


    So you might be wondering, what's the point to this story?
    Well, I'd like to know how to manually copy save files to and from the WiiU without having to rely on Saviine. Don't get me wrong, it's a nice tool but it has given me some problems.
    For example, Advance Wars: Dual Strike crashes the console if I press the home button to exit the game when using Saviine (either to dump or inject) and Zelda Breath of the Wild won't inject the files (other people here at GBATemp were able to inject in this game but I'm not, Saviine gives me an error and doesn't inject anything. I don't remember the error message right now)
    I reckon that copying the files manually would be more reliable (as long as you pay attention to what you are doing, of course)

    I thought of asking Maschell but I'm sure he's busy with other awesome stuff so, before I pester him, I ask here in case anyone knows the answer to my question.
    Thanks.
     
  2. QuarkTheAwesome

    QuarkTheAwesome Working for Hugs

    Member
    839
    2,076
    Apr 19, 2015
    Australia
    Stuck in the PowerPC
    Minor clarification: When the Wii U runs a game, it mounts /vol/storage_XXX/titleid/save onto /vol/save, which is the directory the game actually accesses. So Saviine is actually reading from the /vol/save directory, it's just only valid when a game is running. FTPiiU Everywhere also isn't truly everywhere - the root is a bunch of preset paths rather than the actual filesystem as presented to games and whatnot. Using something like wupserver you can change into all the actual virtual directories and things (though you still can't change into /vol for some reason)
    As for your problem; did you restart the console when you swapped out files? There's lots of caching and the like so that may be what's going on.
     
  3. Deniii
    OP

    Deniii Member

    Newcomer
    47
    2
    Aug 6, 2009
    United States
    Thanks for the reply, QuarkTheAwesome.
    Well, I guess I won't be injecting the saves manually then :-(

    Anyway, about the problem, yes, I did restart the console. In fact, the console was shutdown. I booted it, open Haxchi to run homebrew launcher and then run Saviine.

    When I do this with Advance Wars, I can inject the save file without problems but when I want to exit the game, it crashes.

    When I do this with Breath of the Wild, I get an error. If I remember correctly, Saviine says it deleted everything (it doesn't use the word "everything", it lists all the things it deletes) and then starts to inject files. It injects "option.sav" and then when it tries to create the directory "0" (there are 6 save files in directories numbered from 0 to 5) and copy the file "caption.jpg", it stops and gives an error which I can't remember and the console crashes (or at least, I think it crashes since the game is stuck in the splash screen and never boots even if I close Saviine on the PC).
    However, the save files are still there, even though Saviine reported that they were deleted in preparation for the injection so I never tried again. At least, until I finish the game.

    Do you have any idea what the problem could be?