whats the point of .3ds files when we have .cia files? can anyone explain?

Discussion in '3DS - Homebrew Development and Emulators' started by Barrons, Jan 13, 2017.

  1. Barrons
    OP

    Barrons Member

    Newcomer
    21
    1
    Jan 10, 2017
    England
    Hello

    so im new to the 3ds homebrew arena.

    what the point of .3ds files if you have to convert them to .cia files to install them and play them when we already have .cia files available to us?

    thanks
     


  2. addi33

    addi33 GBAtemp Advanced Maniac

    Member
    1,678
    724
    Sep 12, 2016
    Gambia, The
    Flashcards?!
     
    slaphappygamer likes this.
  3. dragonfire535

    dragonfire535 Advanced Member

    Newcomer
    66
    5
    Jul 1, 2016
    United States
    It's a Secret (Shhhhh...)
    Flashcards use .3ds, not .cia.
     
  4. addi33

    addi33 GBAtemp Advanced Maniac

    Member
    1,678
    724
    Sep 12, 2016
    Gambia, The
    :ph34r:
     
  5. Barrons
    OP

    Barrons Member

    Newcomer
    21
    1
    Jan 10, 2017
    England
    ok so wouldnt flash card users just want to upgrade to 11.2 A9LH and Luma3DS CFW as it seems less of a faff?

    or on a flash card can you just load a .3ds file straight away without installing the .cia file like you have to do via FBI application
     
  6. addi33

    addi33 GBAtemp Advanced Maniac

    Member
    1,678
    724
    Sep 12, 2016
    Gambia, The
    you´ll see when 11.3 hits
     
    BADDINOROX99 and proflayton123 like this.
  7. dragonfire535

    dragonfire535 Advanced Member

    Newcomer
    66
    5
    Jul 1, 2016
    United States
    It's a Secret (Shhhhh...)
    They may not want to go through the work, or might believe it can be patched. Personally I don't use flashcards, but I can see why some might want to.

    — Posts automatically merged - Please don't double post! —

    When 11.3 hits I'll just update :D A9LH can't be patched.
     
  8. Lilith Valentine

    Lilith Valentine GBATemp's Wolfdog™ Cuddle lesbian derp

    Member
    20,070
    21,180
    Sep 13, 2009
    Antarctica
    Between insane and insecure
    Because CFW didn't always exist and flashcarts used to use .3DS files. They are still being dumped for those flashcarts.
     
    Darkyose and gnmmarechal like this.
  9. Barrons
    OP

    Barrons Member

    Newcomer
    21
    1
    Jan 10, 2017
    England
    so in my case im on 11.2 luma3ds cfw a9lh from the https://3ds.guide/ i followed on my old 3ds xl. are you saying when nintendo release 11.3 or something i wont be able to play online or upgrade my software?
    as we have the luma3ds updater to update luma...
     
  10. dragonfire535

    dragonfire535 Advanced Member

    Newcomer
    66
    5
    Jul 1, 2016
    United States
    It's a Secret (Shhhhh...)
    Luma/A9LH cannot be patched. You can update and still go online.
     
    slaphappygamer likes this.
  11. proflayton123

    proflayton123 Undeclared Shitposter 2.1

    Member
    5,805
    2,163
    Jan 11, 2016
    Japan
    日本
    Some people have their own preferences, if someone wants to use GW/Sky3DS, let them. It's down to them anyway.
     
  12. Barrons
    OP

    Barrons Member

    Newcomer
    21
    1
    Jan 10, 2017
    England
    seriously? i thought this would be like a psp in the old days where you have to stay on the ofw otherwise you would break your console...
     
  13. proflayton123

    proflayton123 Undeclared Shitposter 2.1

    Member
    5,805
    2,163
    Jan 11, 2016
    Japan
    日本
    Essentially, I hope I don't contradict myself.

    For GW, you have to stay on a sysnand between 4.1~9.2 otherwise it's kinda obsolete, plus you can always chainload it and use it with Luma. The PSP and 3DS are different by far.
     
  14. Shady Guy Jose

    Shady Guy Jose GBAtemp Fan

    Member
    395
    151
    Sep 14, 2008
    Portugal
    This, exactly. I have Luma with A9LH and I still use Gateway for this very reason.
     
  15. Lilith Valentine

    Lilith Valentine GBATemp's Wolfdog™ Cuddle lesbian derp

    Member
    20,070
    21,180
    Sep 13, 2009
    Antarctica
    Between insane and insecure
    3DS CFW is similar to the PSP CFW, where it's basically a patched version of the OFW.
    But A9LH is an exploit that works extremely early in the boot process. So early in fact that Nintendo can't remove it through a system update and attempting to remove it will only brick hacked and non-hacked systems. Thus the Big N is cornered and can't remove it.
    Luma3DS (and in fact all current CFWs) have a feature called FIRM0/1 protection that basically directly blocks any attempts Nintendo could make to removing A9LH.
    Basically this hack is really good.
     
    proflayton123 likes this.
  16. Shady Guy Jose

    Shady Guy Jose GBAtemp Fan

    Member
    395
    151
    Sep 14, 2008
    Portugal
    You don't have to stay between those firmwares. I'm on 11.2 SysNAND (using A9LH with Luma chainloader)
     
  17. proflayton123

    proflayton123 Undeclared Shitposter 2.1

    Member
    5,805
    2,163
    Jan 11, 2016
    Japan
    日本
    For those who aren't keen on transitioning I mean. Also included about chainloading via V2 A9LH
     
  18. Barrons
    OP

    Barrons Member

    Newcomer
    21
    1
    Jan 10, 2017
    England
    ok you guys a brilliant thanks for explaining so i have a better understanding.

    so for my .3ds files are useless as i dont have a flashcard. im installing from the sd card via the .cia in fbi app.
     
  19. Lilith Valentine

    Lilith Valentine GBATemp's Wolfdog™ Cuddle lesbian derp

    Member
    20,070
    21,180
    Sep 13, 2009
    Antarctica
    Between insane and insecure
    When Nintendo release 11.3, they aren't going to do shit to your CFW. You should be able to update just fine and continue your online experience. As well all current CFWs actually allow older OFW to continue going online with older OFWs. So even if you don't update, your current CFW will allow you to online
     
  20. gnmmarechal

    gnmmarechal Kirigiri > Naoto

    Member
    GBAtemp Patron
    gnmmarechal is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    4,666
    2,824
    Jul 13, 2014
    Portugal
    https://gs2012.xyz
    That is a lie. It may very well be possible to patch it. You cannot say for sure that it cannot be patched. Whether they will bother or not, that is different.
     
    proflayton123 likes this.