whats the latest FW for dsi ?

Discussion in 'NDS - Flashcarts and Accessories' started by citrix, Dec 4, 2011.

  1. citrix
    OP

    citrix Newbie

    Newcomer
    4
    0
    Mar 14, 2009
    i have found a card that does ::
    1. Compatible with firmware versions 1.4.1,1.4.2,1.43 and earlier, including 1.4E

    does this cover the latest FW, can't seem to find any info ?
     
  2. Qtis

    Qtis Grey Knight Inquisitor

    Member
    3,791
    1,292
    Feb 28, 2010
    The Forge
    1.4.3 is the latest (1.4.4 for China IIRC). Thus it should be compatible..


    -Qtis