1. TheProxyOne

    OP TheProxyOne Member
    Newcomer

    Joined:
    Nov 16, 2016
    Messages:
    15
    Country:
    Netherlands
    Like in subject, I just unpacking new switch and becouse it has (very) low serial number it seems hackable, but first I like to know are they any reasons to keep it on 4.0.1? And also what is the lowest firmware on which I can enjoy all games lets say with intaling the with tinfoil to skip version check, and what about game updates can I also skip firmware check on game updates somehow?
     
  2. comput3rus3r

    comput3rus3r GBAtemp Psycho!
    Member

    Joined:
    Aug 20, 2016
    Messages:
    3,518
    Country:
    United States
    stay on fm 4 if you want to eventually have the ability to launch cfw through a web exploit that works half the time and takes longer than just using a jig. Otherwise just update to 6.1 which you now have to do with choidjour since the latest official fm is 6.2 and that breaks cfw. or wait for 6.2 to get cracked and then update officially.
     
    Last edited by comput3rus3r, Nov 29, 2018
    splinterbr and TheProxyOne like this.
  3. TheProxyOne

    OP TheProxyOne Member
    Newcomer

    Joined:
    Nov 16, 2016
    Messages:
    15
    Country:
    Netherlands
    ok, and also another thing, lets say i going to update through choidjour (hope thats the name) any reason to not update all controlers firmware?
     
  4. comput3rus3r

    comput3rus3r GBAtemp Psycho!
    Member

    Joined:
    Aug 20, 2016
    Messages:
    3,518
    Country:
    United States
    as long as you don't have a modded joycon. But I could be wrong. anybody else want to elaborate?
     
    TheProxyOne likes this.
  5. Kubas_inko

    Kubas_inko "Something funny goes here."
    Member

    Joined:
    Feb 3, 2017
    Messages:
    6,297
    Country:
    Czech Republic
    Nope. And to your original question, everything works on 6.0 (definitely on 6.1) as of now.
     
    TheProxyOne likes this.
  6. Aisuga

    Aisuga Member
    Newcomer

    Joined:
    Mar 10, 2016
    Messages:
    33
    Country:
    France
    If you use the ignore fw feature of tinfoil, everything still works on 5.X afaik.
     
    PT333 and TheProxyOne like this.
  7. Kubas_inko

    Kubas_inko "Something funny goes here."
    Member

    Joined:
    Feb 3, 2017
    Messages:
    6,297
    Country:
    Czech Republic
    Games which need later master keys (idk the number now) won't work.
     
  8. fiddlefaddle22

    fiddlefaddle22 GBAtemp Regular
    Member

    Joined:
    Nov 24, 2008
    Messages:
    209
    Country:
    I tried Starlink after installing with ignore fw feature on tinfoil when i was on 5.1 that wouldn't work.I had to go to 6.1 sx os emunand to get it working.
     
  9. TheProxyOne

    OP TheProxyOne Member
    Newcomer

    Joined:
    Nov 16, 2016
    Messages:
    15
    Country:
    Netherlands
    thats good to know, for now I did full backup and updated with chominjour :D with Auto RCM but I think I still burned fuse of cartridge port but that doesn't matter for me
     
    fiddlefaddle22 likes this.
  10. Aisuga

    Aisuga Member
    Newcomer

    Joined:
    Mar 10, 2016
    Messages:
    33
    Country:
    France
    It appears to indeed require the new 6.x key. I've yet to run into a game that's on something more recent than 5.x, they must still be rare.

    — Posts automatically merged - Please don't double post! —

    Though, I'm not sure, on that dark site, some report it works on 5.1 if you ignore fw.. Just in case, you need to ignore fw on both the game nsp and update nsp. And reading the entire dark "starlink issues with 5.1" thread, it definitely does not require 6.x.
     
    Last edited by Aisuga, Nov 29, 2018
    fiddlefaddle22 likes this.
  11. fiddlefaddle22

    fiddlefaddle22 GBAtemp Regular
    Member

    Joined:
    Nov 24, 2008
    Messages:
    209
    Country:
    I tried several different nsp's to try and get it to work on 5.1 and 1.01,102 update with tinfoil but it kept asking for a software update.
     
  12. smf

    smf GBAtemp Psycho!
    Member

    Joined:
    Feb 23, 2009
    Messages:
    3,982
    Country:
    United Kingdom
    I can't remember what version it was I was running, but the sonic game worked fine with tinfoil but launching the manual didn't work until I upgraded to a later version.

    Because tinfoil only fixed the main title.

    I don't know why you wouldn't upgrade to 6.1, if you want to avoid burning fuses so you can downgrade to 4.x again then use autorcm and always boot cfw
     
    Last edited by smf, Nov 29, 2018
  13. Ashura66

    Ashura66 GBAtemp Advanced Maniac
    Member

    Joined:
    Feb 1, 2016
    Messages:
    1,634
    Country:
    Portugal
    Really now? Because i'm on 5.1, i installed Starlink, the update and the DLC unlocker using the ignore firmware option on tinfoil and it works PERFECTLY fine for me
     
  14. fiddlefaddle22

    fiddlefaddle22 GBAtemp Regular
    Member

    Joined:
    Nov 24, 2008
    Messages:
    209
    Country:
    I Downloaded tinfoil from here
    https://buildserv.stayathomeserver.club/tinfoil/
    tinfoil-550df97
    so i don't know if this had anything to do with it not working for me?
     
  15. memzinla

    memzinla Member
    Newcomer

    Joined:
    Apr 27, 2010
    Messages:
    16
    Country:
    United States
    I bought a used Switch today, and it has 4.0.1. I'm not sure if I should update.
     
  16. smf

    smf GBAtemp Psycho!
    Member

    Joined:
    Feb 23, 2009
    Messages:
    3,982
    Country:
    United Kingdom
    If you upgrade using choidujournx and leave autorcm enabled by default and always boot cfw so no more fuses are burned, then there is no reason to stay on 4.0.1

    If you want to connect your switch to wifi then make sure you block over the air updates. I block them on my router, but you can do it with homebrew running on the switch (just make sure you don't connect to wifi when it's not running though).
     
  17. TheProxyOne

    OP TheProxyOne Member
    Newcomer

    Joined:
    Nov 16, 2016
    Messages:
    15
    Country:
    Netherlands
    Without fuses burned, can now I play and change firmware between 4.0.1 and 6.1 without consequences? For example today I install 6.1 and tomorrow 4.1?
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - firmware, reasons, lowest