What games do I actually need Luma's region/language emulation for?

Discussion in '3DS - Flashcards & Custom Firmwares' started by theplasmastorm, Oct 3, 2016.

  1. theplasmastorm
    OP

    theplasmastorm Advanced Member

    Newcomer
    93
    3
    Sep 13, 2009
    United States
    I am a bit confused. The general idea for this (as far as I know) is to run out of region DLC and games on my EUR console.

    However, I currently am playing dlc of games that are from the US region (eg Smash), and they didn't require me to emulate anything.

    The only game that I know of that does require this is Rhythm Heaven Megamix.

    How do I know if another game I have requires patching of this kind, other than to just test them all?
     
  2. nechigawara

    nechigawara Citizen of Gamindustri

    Member
    1,181
    390
    Oct 14, 2006
    Thailand
    Planeptune
    On my JPN O3DS, I use language emulation to change:
    • PokéToru (Pokémon Shuffle)
    • Pokémon Picross
    • Everyone's Pokémon Scramble (Pokémon Rumble World)
    to change their language to English instead of Japanese.
     
  3. ih8ih8sn0w

    ih8ih8sn0w Koreaboo

    Member
    1,678
    753
    Aug 22, 2015
    United States
    Hell
    ssb4 mods require this to use saltysd now (unless you are insane and use modified update cias still)
     
  4. DarkSynopsis

    DarkSynopsis GBAtemp Fan

    Member
    427
    250
    Oct 15, 2014
    New Zealand
    New Zealand
    I'm not sure why some DLCs will need it and others won't I know US Fates works fine on my EU console, its safe to assume anything JPN though won't work, though it is possible to modify DLC to work on different regions without emulation with some hex editing/cia rebuilding.

    Don't think there is really a way to know if a game needs it until you test, most cases I haven't.
     
  5. Jiro2

    Jiro2 GBAtemp Advanced Fan

    Member
    771
    191
    Mar 28, 2011
    United States
    The fan translation of Beyond the Labyrinth requires this, or the character names are shown as blanks.
     
  6. Aroth

    Aroth GBAtemp Addict

    Member
    2,066
    745
    Apr 14, 2015
    United States
    Afaik the language emulation thing is to change the display language of games that otherwise would display in the language of the originating region. Since you are using a EUR console with USA games/dlc, you probably wont run into an issue where this is needed. It would be more for trying to run a JPN version of a game (like Pokemon Shuffle example earlier), where the game would display in Japanese instead of English. To my knowledge the only thing you can do is run the game/dlc and if it has issues with its display language, try using the emulation patch.

    Regarding playing DLC with out of region games, as far as I know even Luma doesn't allow you to mix/match DLC and Game regions. All DLC and Patch data for a given game MUST match the region of the game. So if you installed a USA version of a game, you will need to install the USA versions of any patches and DLC for them to be recognized.
     
  7. nechigawara

    nechigawara Citizen of Gamindustri

    Member
    1,181
    390
    Oct 14, 2006
    Thailand
    Planeptune
    Is it need to set to JP or US?
     
  8. Jiro2

    Jiro2 GBAtemp Advanced Fan

    Member
    771
    191
    Mar 28, 2011
    United States
    It has to be set to JP.
     
    nechigawara likes this.
  9. JimmyZ

    JimmyZ Sarcastic Troll

    Member
    675
    388
    Apr 2, 2009
    Zimbabwe
    Zelda Majora's mask US needs to be set to US on a JP 3DS or it will crash

    And title region emulation doesn't always work, Zelda triforce heros US internet play doesn't work on a JP 3DS

    Both tested on retail cart, not pirate CIA
     
Loading...