What firmware should i update to from 5.00 m33-6?

Discussion in 'PSP - Games & Content' started by Aman27deep, Jun 24, 2010.

  1. Aman27deep
    OP

    Member Aman27deep GBAtemp Fan

    Joined:
    May 3, 2007
    Messages:
    442
    Location:
    Calcutta.
    Country:
    India
    I got a psp from my friend 4 days back, its a PSP-2004, he said its fully hackable and all, but its not runnin games such as MotorStorm Arctic, Tekken 6 and Fifa 10. I searched and i found out that it needs a newer custom firmware to run all those new games, my questions are that

    1. What firmware should i upgrade to? there are too many out there.. which is the stable/nice one that runs all the games? Please also guide me how to upgrade too *ashamed*

    I just got this PSP-2004 four days back, am a very big noob on PSP's... HEELPP!
     


  2. Bulit

    Member Bulit GBAtemp Regular

    Joined:
    Sep 15, 2009
    Messages:
    293
    Location:
    San Jose, CA
    Country:
    United States
  3. Ultralex

    Member Ultralex GBAtemp Fan

    Joined:
    Mar 18, 2009
    Messages:
    334
    Country:
    Germany
    Better upgrade to GEN-D2,because D3 has the savegame corruption bug.
    When the PSP is on D2,upgrade to Prometeus v3 to have the ability to run the newest games.
     
  4. Jolan

    Member Jolan Unlimited Bear Works

    Joined:
    Mar 20, 2010
    Messages:
    1,384
    Location:
    Netherlands, currently
    Country:
    Bulgaria
    Yeah, D2->D4 should be the way to go.
     
  5. thedicemaster

    Member thedicemaster GBAtemp Addict

    Joined:
    Apr 26, 2008
    Messages:
    2,412
    Country:
    Netherlands
    little warning, the Prometheus firmware may have some compatibility problems with pre-6.20 protected games because it does lack a few GEN patches.
     
  6. azoreseuropa

    Member azoreseuropa GBAtemp Psycho!

    Joined:
    Nov 6, 2002
    Messages:
    4,502
    Location:
    I am deaf and live in the USA for now :D
    Country:
    Portugal
    I dont have any problem with the newest games even older games and the save works fine using Prometeus v1 through v4 I had been update so far. No problem.
     
  7. fgghjjkll

    Member fgghjjkll GBATemp MegaMan

    Joined:
    Jul 7, 2008
    Messages:
    2,038
    Country:
    Australia
    Well i have problems with God Eater. Doesn't start [​IMG]
    I guess i'll try fix that up tonight.
     
  8. azoreseuropa

    Member azoreseuropa GBAtemp Psycho!

    Joined:
    Nov 6, 2002
    Messages:
    4,502
    Location:
    I am deaf and live in the USA for now :D
    Country:
    Portugal
    God Eater, huh ? JP version right since USA isnt out ? I can test it if you want me to ?
     
  9. BoxShot

    Member BoxShot Chiyo-chan :3

    Joined:
    Dec 18, 2008
    Messages:
    3,447
    Location:
    Middle of the ocean.
    Country:
    United States
    God Eater doesn't have a US version yet. :/
     
  10. LufianGuy

    Member LufianGuy GBAtemp Regular

    Joined:
    Oct 7, 2008
    Messages:
    244
    Country:
    United States
    I'd stay on 5.00 m33-6. Everyone I know who has tried GEN anything has gone back to 5.00 m33-6.

    There are programs out there you can use to decrypt the games for 5.00 m33-6 (1st link is most recent):
    http://forums.qj.net/guides-psp-hacks-home...-firmwares.html
    http://forums.pspslimhacks.com/tutorials/2...-w-screens.html
    http://forums.afterdawn.com/t.cfm/f-149/ne...w_games-853531/

    If you care to look, you will find prepatched games that say "will run on all firmware" etc.

    GEN users are just too lazy to patch their own games (GEN auto patches but isn't always perfect) and don't mind less stability and the loss of 1.5 Kernal apps in their CFW.

    Also if you want to connect the psp to the PS3, look up some plugin called PSN Fker or Lover.
     
  11. fgghjjkll

    Member fgghjjkll GBATemp MegaMan

    Joined:
    Jul 7, 2008
    Messages:
    2,038
    Country:
    Australia
    I have the JP version, not the USA version sorry [​IMG]
    It was already pre-patched but it doesn't load on 5.50 Prometheus v3 and shows an error code on boot. Imma patch it with the Prometheus Module v3 tonight.
     
  12. azoreseuropa

    Member azoreseuropa GBAtemp Psycho!

    Joined:
    Nov 6, 2002
    Messages:
    4,502
    Location:
    I am deaf and live in the USA for now :D
    Country:
    Portugal
    I will be glad to test the pre-patched one and let you know in half an hour. [​IMG]
     
  13. azoreseuropa

    Member azoreseuropa GBAtemp Psycho!

    Joined:
    Nov 6, 2002
    Messages:
    4,502
    Location:
    I am deaf and live in the USA for now :D
    Country:
    Portugal
    Okay, I try it now and guess what ? It works fine for me.

    EDIT: Something's not right about yours. Did you have 5.50 Gen-D3 then install over 5.50 Prometheus v3 ? Did you disabled something ? Mine is default expect PSNlover network is enable and works for psn demo over internet.
     
  14. Aman27deep
    OP

    Member Aman27deep GBAtemp Fan

    Joined:
    May 3, 2007
    Messages:
    442
    Location:
    Calcutta.
    Country:
    India
    Thanks for the reply guys... But i see people telling me 4 things to do...

    1. Do not upgrade to nothing
    2. Gen d3
    3. GEN-D2 > D4
    4. Prometeus v1 to v4

    Now it gets real tough for me when u dunno shit and people tell u 4 things to do. Which one should i choose? I want my save games intact... ( IMP )
     
  15. Aman27deep
    OP

    Member Aman27deep GBAtemp Fan

    Joined:
    May 3, 2007
    Messages:
    442
    Location:
    Calcutta.
    Country:
    India
    One more thing is that i don't have a pandora battery. If i brick or something will it remain that way? o.0
     
  16. BoxShot

    Member BoxShot Chiyo-chan :3

    Joined:
    Dec 18, 2008
    Messages:
    3,447
    Location:
    Middle of the ocean.
    Country:
    United States
    Try this plugin first. If you keep it on older saves won't work but when you disable it they should work again. http://gbatemp.net/t233363-m33-620-prx-plugin-by-torky-beta

    After this you can try other things as this shouldn't take too long anyways.

    Remember to backup your saves anyways.

    Edit: If you brick it its a brick until you unbrick it with a pandora battery.
     
  17. azoreseuropa

    Member azoreseuropa GBAtemp Psycho!

    Joined:
    Nov 6, 2002
    Messages:
    4,502
    Location:
    I am deaf and live in the USA for now :D
    Country:
    Portugal
    I did from gen d3 then Prometeus v1 through v4 without a problem. [​IMG]
     
  18. Aman27deep
    OP

    Member Aman27deep GBAtemp Fan

    Joined:
    May 3, 2007
    Messages:
    442
    Location:
    Calcutta.
    Country:
    India
    guys i thought and have decided to upgrade to "5.50gen-D3", is it okay?? anyone using it here... and cons of it?
     
  19. fgghjjkll

    Member fgghjjkll GBATemp MegaMan

    Joined:
    Jul 7, 2008
    Messages:
    2,038
    Country:
    Australia
    Cons:
    Lack of 1.5 Plugin, if you have a phat.
    Does not support 1.5 homebrew (M33 supports LEDA)
    Has this "Save corruption" bug
    Cannot connect to PSN without a plugin.
     
  20. Aman27deep
    OP

    Member Aman27deep GBAtemp Fan

    Joined:
    May 3, 2007
    Messages:
    442
    Location:
    Calcutta.
    Country:
    India
    So that means all my current saves will be incompatible with that? For the other 2, I have a slim (2004), and i dont care about PSN.
     

Share This Page