What firmware does the 3DS XL ship with at the moment?

Discussion in '3DS - Flashcards & Custom Firmwares' started by AverageNinja, Dec 1, 2012.

  1. AverageNinja
    OP

    Newcomer AverageNinja Member

    Joined:
    Dec 1, 2012
    Messages:
    12
    Country:
    Netherlands
    Hi there GBATemp!
    So lately I've been wanting to purchase a 3DS XL, but I want to make sure flashcards are working on it.
    I don't plan on playing online so I'm also not updating the system from the firmware which comes installed on the system.
    Thanks in advance,
    AverageNinja
     


  2. Pluupy

    Member Pluupy Woof!

    Joined:
    Sep 13, 2009
    Messages:
    603
    Country:
    United States
    I would also like to request this information. I am interested in purchasing the $200 mario kart 7 3DS XL bundle being released on Dec 3rd and want to know which version the 3ds is running.
     
  3. Rydian

    Member Rydian Resident Furvert™

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    It's been two and a half months since 4.4.x, and a bit over four months sinxe 4.3.x, so assume 4.3.x or 4.4.x.

    Even if you keep it offline, future 3DS games will try to update the 3DS.
     
  4. Snailface

    Member Snailface My frothing demand for 3ds homebrew is increasing

    Joined:
    Sep 20, 2010
    Messages:
    4,324
    Location:
    Engine Room with Cyan, watching him learn.
    Country:
    Antarctica
    Purchase a r4ids.cn r4iGold or DStwo and you won't have to worry about the 3ds firmware (just make sure the seller pre-updates the card if you don't have a ds/dsi to update it)
     
  5. djricekcn

    Member djricekcn GBAtemp Advanced Fan

    Joined:
    May 29, 2009
    Messages:
    792
    Country:
    United States
    I wouldn't say won't have to worry, you never know...might be blocked one day
     
  6. Deltaechoe

    Member Deltaechoe The Dopefish

    Joined:
    May 3, 2012
    Messages:
    509
    Country:
    United States
    they get blocked all the time, but the flashcart teams are still active so the carts will be updated
     
  7. AverageNinja
    OP

    Newcomer AverageNinja Member

    Joined:
    Dec 1, 2012
    Messages:
    12
    Country:
    Netherlands
    I'm getting it somewhere near Christmas. I think I found a good site in the Netherlands and I'll get the r4iGold. The webshop where I'll buy will pre-update it :D
     
  8. gamer765

    Member gamer765 GBAtemp Regular

    Joined:
    Nov 13, 2012
    Messages:
    172
    Country:
    United States
    My 3DS XL came with 4.2.0. Got it 2 weeks ago.
     
  9. Elenciel

    Newcomer Elenciel Newbie

    Joined:
    Dec 6, 2012
    Messages:
    1
    Country:
    Australia
    I got my 3DS this week (Bundle with Super Mario 3D Land) and it came with 4.3.0-10.
     
  10. spanner

    Newcomer spanner Member

    Joined:
    Jan 25, 2008
    Messages:
    31
    Country:
    United Kingdom
    Yup and now its asking you to updated the firmware again..
     
  11. blaisedinsd

    Member blaisedinsd GBAtemp Advanced Fan

    Joined:
    Dec 6, 2012
    Messages:
    947
    Country:
    United States
    Got it about a week ago from target.com sale.....has 4.2.0-9u
     
  12. gamer765

    Member gamer765 GBAtemp Regular

    Joined:
    Nov 13, 2012
    Messages:
    172
    Country:
    United States
    Same place I got my 3DS XL, except at the B&M.
     
  13. Lirath15

    Newcomer Lirath15 Member

    Joined:
    Dec 8, 2012
    Messages:
    11
    Country:
    United States
    You need a ds/dsi to update it? I can't just plug the sd card into my computer and download the latest firmware?
     
  14. Dewott

    Newcomer Dewott Newbie

    Joined:
    Dec 8, 2012
    Messages:
    2
    Country:
    United States
    My 3ds is broken...
     
  15. WiiUBricker

    Member WiiUBricker Insert Custom Title

    Joined:
    Sep 19, 2009
    Messages:
    5,828
    Location:
    Espresso
    Country:
    Argentina
    My came with 4.4.0. And I bought it just a few days ago.
     
  16. Rydian

    Member Rydian Resident Furvert™

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    The software you put in the MicroSD that launches games and is updated for game compatibility is NOT the "firmware", even though tons of people call it that.

    The actual firmware is on the cart itself, and that is what determines DSi/3DS compatibility. When you put the firmware update on the MicroSD, that's just the installer. You need to run it, and then it writes the new firmware onto the cart itself (from the MicroSD).

    If you can't run it, you can't install it.
     
  17. Lirath15

    Newcomer Lirath15 Member

    Joined:
    Dec 8, 2012
    Messages:
    11
    Country:
    United States
    Ah ok, hopefully the 3ds XL I buy tomorrow has 4.40. Would I just put the supercard into my 3ds after downloading the latest "firmware" and then it'll install and run fine? Also, not sure if you read the message I put on your wall, but I ended up cancelling that order and getting the supercard dstwo as the store was using a revision of the r4i gold that hasn't been updated.

    Playing GBA games might be cool too.
     
  18. Rydian

    Member Rydian Resident Furvert™

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    The DSTwo will automatically detect the update and offer to run it when you put it on the MicroSD, yeah.
     
  19. Lirath15

    Newcomer Lirath15 Member

    Joined:
    Dec 8, 2012
    Messages:
    11
    Country:
    United States
    Awesome, one more question. If the 3DS I get ends up having 4.5 in the box, do I need need to use a regular DS in order to update it?
     
  20. Rydian

    Member Rydian Resident Furvert™

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    Not with the DSTwo, it has it's own update method that should be able to work, but it's a little risky so let's see if it's needed first.
     

Share This Page