1. Arizato

    OP Arizato Memento Mori
    Member

    Joined:
    Jun 1, 2009
    Messages:
    499
    Country:
    I am really interested in getting Shin Megami Tensei: Devil Summoner - Soul Hackers since it came out in Europe a few days ago. But my 3DS is currently on 4.5 and I don't want to update. Does anyone here know what firmware version Soul Hackers require in Europe?
     
  2. Arizato

    OP Arizato Memento Mori
    Member

    Joined:
    Jun 1, 2009
    Messages:
    499
    Country:
    Got the game anyway now. Just in case anyone is wondering sometime: Soul Hackers requires 5.1.0-9 in Europe.
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - firmware, Hackers, require