What exactly do i need to install the usb loader GX?

Discussion in 'Wii - Hacking' started by Silithas, Nov 17, 2015.

  1. Silithas
    OP

    Silithas GBAtemp Regular

    Member
    143
    3
    May 12, 2012
    Norway
    I can´t seem to find ios 36 v3607 anywhere which seems to be required to load up the wad manager to install the usb loader...

    I´m gonna softmod and install usb loader GX and some emu´s on my GF´s wii, but i can¨t seem to find the files i need to open the wad manager without risking bricking the wii.
     
    Last edited by Silithas, Nov 17, 2015
  2. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,749
    9,035
    Oct 27, 2002
    France
    Engine room, learning
    you don't need that.
    following old tutorial are not advised.
    And even if you followed and old tutorial, you ALREADY have that IOS. you don't need it on another place than on your console.
    the tutorial you are following is bad if it tells you that you need this file.

    To install USBLoaderGX, you need two things:

    1. USBLoaderGX
    Current Latest program (from today) (Which means it will be old soon, look at this message's date)

    - Extract USBLoaderGX to your SD card.
    - install complete ! yes, that's all you need to do. It works with channels and gamecube games from SD and USB
    - but if you want Wii backup from USB, and IF you never softmodded your wii with modmii, you need to follow step 2 to install d2x :


    2. d2x installer
    For Wii
    for WiiU vWii

    extract d2x for your console to Sd card/apps/d2x installer/ folder.
    launch it
    select with d-pad:
    d2x v8 final, slot249, base57, version 21008
    press A, then exit with home.
    Done !

    everything will work.
    Wii backups from USB FAT32 or NTFS.
    If you need a program to transfer ISO to your drive, use WiiBackupManager (not wbfs manager!)
    NEVER USE WBFS partition, NEVER use WBFS manager. NEVER follow old tutorials.



    There are additional and optional steps you can do, like installing a forwarder channel.
    You need a wad manager and the forwarder for wii or for vWii
     
    RosaliinaDaHacker64 likes this.
  3. Silithas
    OP

    Silithas GBAtemp Regular

    Member
    143
    3
    May 12, 2012
    Norway
    Could you please make them into zip´s? I´m at my GF´s place and she only has a mac, and it cannot handle other than rar and zip´s :P
     
  4. Silithas
    OP

    Silithas GBAtemp Regular

    Member
    143
    3
    May 12, 2012
    Norway
    Edit, got them extracted now, but which files for the d2x did i need? there where v7, v8 and v10 in there, aswell as some other files located in that folder with the DOL file.
     
  5. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,749
    9,035
    Oct 27, 2002
    France
    Engine room, learning
    you need ALL the files.
    it's a package, not multiple homebrew to choose.

    it's one single homebrew with all files and versions included.
    extract it into a folder on your SD:/apps/folder you want/

    SD:/apps/folder you want/boot.dol
    SD:/apps/folder you want/meta.xml
    SD:/apps/folder you want/icon.png
    SD:/apps/folder you want/ciosmap.xml
    SD:/apps/folder you want/7/
    SD:/apps/folder you want/8/
    SD:/apps/folder you want/10/



    But you really never hacked your wii before ?
    you are new to Wii hacking and only installed HBC ? you never run any homebrew since then?
    maybe you don't need to install d2x at all because you already have it.

    if you never used a wad manager or followed a hacking tutorial to install cIOS, then you need to install d2x like I explained above.
     
  6. Silithas
    OP

    Silithas GBAtemp Regular

    Member
    143
    3
    May 12, 2012
    Norway
    I got help with everthing and forgotten most of it unfortunately, so my own wii has loads of stuff installed, i just forgot which ios things i needed for the wad installer.
     
  7. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,749
    9,035
    Oct 27, 2002
    France
    Engine room, learning
    wad installer doesn't need any patched IOS anymore.
    use the one I linked, it's not using the old deprecated cIOSes anymore.

    It's using the official IOS58 which you already have.

    what you can do is run syscheck (link in my signature) to list the current IOS from the console.
    We will see if you need to install d2x or not.
    no need to edit the system files if not required. (but you can reinstall and overwrite it if you want without checking what you already have)
     
  8. Silithas
    OP

    Silithas GBAtemp Regular

    Member
    143
    3
    May 12, 2012
    Norway
    I got help with everthing and forgotten most of it unfortunately, so my own wii has loads of stuff installed, i just forgot which ios things i needed for the wad installer.

    Here\s the menu i get

    what now?

    [​IMG]
     
  9. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,749
    9,035
    Oct 27, 2002
    France
    Engine room, learning
    I listed above what you needed to select :
    use d-PAD to change line and choices

    D2x v8 Final
    base 57 (NOT 37)
    slot 249
    revision 21008
    then press A to install (it will show you a confirmation screen first, with slots and you should see slot249 blinking), press A again.

    I hope you have online access, as it will download the needed files from nintendo's servers.
    after install, you can press home to exit and launch the loader.
     
  10. Silithas
    OP

    Silithas GBAtemp Regular

    Member
    143
    3
    May 12, 2012
    Norway
    Did'nt have online access, but it's installed now.

    So how do i now install usb loaderGX to launch it from the dashboard of the regular wii menu?

    and thanks for being paitent with me (slow learner heh)
     
    Last edited by Silithas, Nov 17, 2015
  11. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,749
    9,035
    Oct 27, 2002
    France
    Engine room, learning
    you didn't have online but it installed anyway ?
    maybe you said you didn't have it initially but added it later to make the installer work correctly.

    So, now that you have d2x installed, and USBGX on SD card, did you try running it from the Homebrew channel?


    To install a channel on the "dashboard" (called "System Menu" on wii), you need to use the wad manager I linked above and the forwarder wad file I linked above too.
    extract the manager to SD (in apps folder, like any other homebrew)
    extract the forwarder wad file to sd:/wad/ folder
    launch the installer on HBC, select install wad and select the forwarder file.

    that's really easy.
    extract all to SD, launch installer, select what to install.
     
  12. roo1234

    roo1234 Member

    Newcomer
    43
    42
    Aug 6, 2015
    Brazil
    Hi Cyan
    Just some questions... Why d2x v8 and not v10. Why base 57 and not 58 (or 56 btw)? Is this combination the definitive necessary to run usbloader?
     
  13. Silithas
    OP

    Silithas GBAtemp Regular

    Member
    143
    3
    May 12, 2012
    Norway
    (sorry for the delayed response)

    So i can reinstall it and update it properly this time? Sorry for the blurry image, had to hurry to take the pic before it reloaded.
    [​IMG]
    Yep, ran just fine and played games like it should

    Well, for the wad manager, i have to use an ios thing, and it said it may brick the device or something. Which ios do i need to install it with? Was it 246?

    And also, when i tried to download the game covers, i got this in the end, what does it mean?
     
  14. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,749
    9,035
    Oct 27, 2002
    France
    Engine room, learning
    there are different installation guide, and all are telling users different things.
    most guides are telling users to install LATEST of everything, but it's not always good !

    v8 is last stable
    v10 r52 is update of v8 with additional HDD support.
    v10 r53 is update of v8 + Port 1 but with EmuNAND issues.

    if you don't need port1 support (one HDD at a time is enough), you don't need v10 r53.
    if v8 works, you don't need v10 r52

    recommended : v8


    now the base :
    base 56 : 90% game compatibility. Best USB access read speed.
    base 57 : 99% game compatibility. slightly slower USB access read speed.
    base 58 : remaining game compatibility. Slowest USB access read speed.


    most guides are installing all 2 or 3 bases. Because "56 is faster" (very very very small difference with 57 anyway), but not all games are working. Music games need base 57, call of duty need base 57.
    so users need to setup the USBLoader settings differently based on the game they want to play, it's annoying and need ANOTHER guide and users are asking question why it's not working, etc.

    I suggest users to install base 57 directly, no more issues. all games are working.
    the only non working games could be USB accessories games (microphone, wiispeak, etc.) which will require a base58.


    So common usage :
    56 57 58

    me : 57 and no more issues


    you got this with r1259?
    I made a new version (beta), wich fix download issue. maybe you can test it.
    just replace the boot.dol in usbloader_gx folder.
    http://www.mediafire.com/download/angj2ghp6ns146i/USBLoaderGX_r1259Mod01.7z

    For the wad installer, you DON'T NEED any IOS thing.
    I don't know what you are talking about, probably not the correct menu.
    you don't need IOS236 (not 246), you need only IOS58 !
    do not select "reload to a different IOS" or something like that.
    If you have choice between IOS and AHB, select AHB.
     
    roo1234 likes this.
  15. Silithas
    OP

    Silithas GBAtemp Regular

    Member
    143
    3
    May 12, 2012
    Norway
    R whatnow?
     
  16. TaiAno

    TaiAno Member

    Newcomer
    46
    1
    May 10, 2015
    United States
    i tried to install the thing into slot 249 using the d2x installer but it stops at 'get tmd. 5918' and says Net_init failed. what did i do wrong there?
     
  17. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,749
    9,035
    Oct 27, 2002
    France
    Engine room, learning
    your netwok is usually working fine? verify your network is working and connection test is successful from your network menu.

    do you have a wiiu ? maybe you added a filter to your router to prevent the wiiU from connecting to the update servers, in that case the wii is also affected and can't download system files from nintendo's servers.
     
  18. TaiAno

    TaiAno Member

    Newcomer
    46
    1
    May 10, 2015
    United States
    no wii just a normal wii. and yes my internet conection is working fine.
     
  19. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,749
    9,035
    Oct 27, 2002
    France
    Engine room, learning
    then I don't know why you have that error, sorry.
    try again later (maybe the nintendo server is temporarily offline)
     
  20. TaiAno

    TaiAno Member

    Newcomer
    46
    1
    May 10, 2015
    United States