What do i need to play PS1 games on my PSP?

Discussion in 'PSP - Hacking & Homebrew' started by Gundam Eclipse, Oct 23, 2011.

  1. Gundam Eclipse
    OP

    Member Gundam Eclipse True Demon Route

    Joined:
    Sep 23, 2008
    Messages:
    1,167
    Location:
    Vortex World
    Country:
    India
    Guide has me confused @@;
    I have a PSP 3004, 6.39 PRO-B6, and a FFVII EBOOT in a folder. Said folder contains two within, one with the eboot, and another with an icon.
    Do i need anything else to play it? Also, where do i place it exactly?
     
  2. xist

    Member xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Joined:
    Jul 14, 2008
    Messages:
    5,861
    Country:
    United Kingdom
    PSN FFVII or PSX ISO converted?

    PSX games of both types are placed as follows -

    X:\PSP\GAME\psxgamename\eboot.pbp

    Popsloader isn't required for all PSX games but may be necessary for certain games that won't boot on your native pops (in this case 6.39)...besides popsloader support wasn't added until PROB8 anyway.
     
  3. Gundam Eclipse
    OP

    Member Gundam Eclipse True Demon Route

    Joined:
    Sep 23, 2008
    Messages:
    1,167
    Location:
    Vortex World
    Country:
    India
    Um, i think its a converted PSX ISO.
    Do i need to upgrade to a later PRO then? Which is the latest?
     
  4. xist

    Member xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Joined:
    Jul 14, 2008
    Messages:
    5,861
    Country:
    United Kingdom
    Just do what i said in the first reply. Ignore the folder with the image inside.

    Place the folder with the eboot.pbp into PSP\GAME\

    (So it's X:\PSP\GAME\FFVII\eboot.pbp)

    Then just run from XMB.
     
  5. Gundam Eclipse
    OP

    Member Gundam Eclipse True Demon Route

    Joined:
    Sep 23, 2008
    Messages:
    1,167
    Location:
    Vortex World
    Country:
    India
    Fuck yeah, its working!
    Thanks for the help, i guess i do the same for other games as well, right?
    Is there a compatibility list i can check or something?
     
  6. xist

    Member xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Joined:
    Jul 14, 2008
    Messages:
    5,861
    Country:
    United Kingdom
    Not for 6.39 no.

    Many PSX games should work just fine doing exactly what you're doing. If/When you run into problems (and after you've confirmed the eboot is good) it's at that point you dig up the old "PSX on PSP Compatibility List" (google it!) to see if it runs on a different version of pops. You'd then need to update your version of PRO so that you can utilise popsloader.

    For now don't worry about it. Keep things simple and just make sure you place eboots in the right location else they'll show as corrupted.
     
  7. Gundam Eclipse
    OP

    Member Gundam Eclipse True Demon Route

    Joined:
    Sep 23, 2008
    Messages:
    1,167
    Location:
    Vortex World
    Country:
    India
    Gotcha, thanks!
    Gonna have fun playing all the FF's and Digimon games
     
  8. Saken

    Member Saken GBAtemp Fan

    Joined:
    Sep 12, 2009
    Messages:
    347
    Country:
    Australia
    xist to the rescue!
     
  9. xist

    Member xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Joined:
    Jul 14, 2008
    Messages:
    5,861
    Country:
    United Kingdom
    Erk........so quickly you stray into trouble...Digimon World 3 is a notorious black spot for problems....you'll need popsloader for 3.71 pops for that one, and a decently made eboot with the appropriate Game ID. Worry about it when you come to it....
     
  10. Gundam Eclipse
    OP

    Member Gundam Eclipse True Demon Route

    Joined:
    Sep 23, 2008
    Messages:
    1,167
    Location:
    Vortex World
    Country:
    India
    Don't worry, i am only interested in the first one, completely uninterested in both 2 and 3 lol.
     
  11. BORTZ

    Global Moderator BORTZ wtf, nintendo

    Joined:
    Dec 2, 2007
    Messages:
    10,652
    Country:
    United States
    i played ff7, 9 , and Tactics with NO problems what so ever. only a few MINOR slowdowns that were barely noticeable.
     
  12. ragingchaosgod

    Member ragingchaosgod JUBILEUS QAAL OVOF VOMSARG

    Joined:
    Dec 20, 2008
    Messages:
    575
    Country:
    Philippines
    How's the most recent Pops with FFVIII?
     
  13. death_knight

    Newcomer death_knight Newbie

    Joined:
    Jan 15, 2013
    Messages:
    1
    Country:
    United Kingdom
    hay you all obviously know more on this subject than me iv tried every thing you've said but it just doesn't want to play persona 1 on psp go 6.60 bro b10? sorry if this is in the wrong place peeps
     
  14. koimayeul

    Member koimayeul GBAtemp Maniac

    Joined:
    Dec 2, 2009
    Messages:
    1,339
    Location:
    France
    Country:
    France
    Hi, you might as well play Persona PSP remade version with updated translation and audiovisuals.. If you really want the PSX version then google will surely link some custom eboot made from other people for your needs.
     

Share This Page