What do I need to do to update to Wii v3.3?

Discussion in 'Wii - Hacking' started by blueoakleyz, Jun 28, 2008.

  1. blueoakleyz
    OP

    blueoakleyz GBAtemp Regular

    Member
    237
    0
    Jun 26, 2008
    United States
    I already have 3.2 with homebrew, TP hack, homebrew channel, custom wads/channels etc...
    Now if I want to 3.3 what do I need to do to make sure everything stays the same again? Just "run" The twilight hack (the new one) once more? Does the twilight hack actually do something to the wii or are you supposed to actually use it to install something like homebrew channel?

    Or do I just update to 3.3 and use hbc and wad manager etc just as usual?
     


  2. pokemongalaxy

    pokemongalaxy Banned

    Banned
    717
    0
    Mar 10, 2008
    Canada
    I think I can answer your question, though Im not sure Im right, since I chose not to update to 3.3(im at 3.2U). Anyway, everything should stay the same, just use the new T.H. for your homebrew
     
  3. teq

    teq GBAtemp Maniac

    Member
    1,232
    0
    May 13, 2008
    United States
    After updating to 3.3, the old Twilight hack will no longer work and will be deleted from your console. This is not an issue, as there is already a new one that can be loaded.

    To make the update go more smoothly, I recommend installing the new Twilight hack now, so that the update overlooks any issues.

    As far as there being any concern, at this point in time, there isn't any. A few weeks ago, however, there wasn't a new Twilight hack released, which drove people to panic.
     
  4. AvEnGeR-X

    AvEnGeR-X Advanced Member

    Newcomer
    71
    1
    May 20, 2008
    1. Delete your current Twilight hack.
    2. Update your Wii.
    3. Download the new twilight hack from here.
    4. Install the correct save for the Twilight hack in the correct folder. (should be the same as your old one).
    5. Your Wii is exactly as normal now, only with new update, and you can't run Trucha Signed games from the Wii's main menu. You will require Gecko to run Trucha Signed games, use HBC to run Gecko, or install the GeckoOS channel. Found here. It's a Wad file, the channel. Use Wad manager 1.1 to install it.
     
  5. elm

    elm GBAtemp Fan

    Member
    352
    22
    Jun 20, 2007
    United States
    Just so I don't make a mistake (that I would regret), if anyone could answer this for me

    I'm at 3.2 (NTSC) and I would like to update to 3.3, The only thing I use the Zelda hack for is the Snes, Nes & Gameboy Emulators. Would the latest update allow me to play the emulators using the new Zelda hack?



    Thanks everyone, Elm
     
  6. teq

    teq GBAtemp Maniac

    Member
    1,232
    0
    May 13, 2008
    United States
    Yes, the new hack is exactly like the old hack, except it has a few bug fixes and works with 3.3.


    Remove the current Twilight hack, install the new one, and update. Also, I would use the Homebrew Channel for your emulators.
     
  7. Dermy

    Dermy GBAtemp Fan

    Member
    314
    4
    Jul 1, 2007
    United States
    Don't bother to update to 3.3. If you're at 3.2 stay at 3.2. There are more cons than pros imo. There is no good enough reason to update. Also you can use the new twilight hack beta. It works with 3.2 and 3.3, not just 3.3.
     
  8. JimmyBobAlex

    JimmyBobAlex GBAtemp Regular

    Member
    162
    0
    Nov 5, 2002
    United States
    [​IMG]

    Had to do it, I lol'd good the first time for some reason.
     
  9. killplaystation

    killplaystation GBAtemp Fan

    Member
    467
    1
    May 23, 2008
    United States
    We don't know the reason either
     
  10. blueoakleyz
    OP

    blueoakleyz GBAtemp Regular

    Member
    237
    0
    Jun 26, 2008
    United States
    The problem I forsee:
    THey update to 3.4 in the near future, which remains unhacked for a while, and I cannot upgrade to 3.3 which may be required by some future game.

    I'm a little confused here. Does actually running TP and running the hack DO something by itself? Or is it only useful when you want to install something?
     
  11. teq

    teq GBAtemp Maniac

    Member
    1,232
    0
    May 13, 2008
    United States
    Running the Twilight hack allows you to boot homebrew, which allows you to boot the WAD installer. Once you boot the WAD installer, you can install the Homebrew Channel WAD, from which you can boot homebrew without TP.
     
  12. blueoakleyz
    OP

    blueoakleyz GBAtemp Regular

    Member
    237
    0
    Jun 26, 2008
    United States
    well I already have the HBC and wad manager installed. Do i have to reinstall them?

    Anyway let me restate my original question (well sorta).

    If I run the twilight hack by itself.. and don't use it to install any other wads/channels/homebrew,, does it actually do anything?
     
  13. teq

    teq GBAtemp Maniac

    Member
    1,232
    0
    May 13, 2008
    United States
    I pretty much just explained everything it does.

    It allows you to run code. It's an enabler.

    If you have the HBC, you don't need it until you go to 3.3.
     
  14. blueoakleyz
    OP

    blueoakleyz GBAtemp Regular

    Member
    237
    0
    Jun 26, 2008
    United States
    oK...but, if I just run the twilight hack by itself.. nothing else, does it actually do anything to the wii system?
     
  15. DaveMode

    DaveMode Advanced Member

    Newcomer
    72
    0
    Oct 29, 2007
    United States
    The only people at this point who shouldn't update are those with a large number of Trucha signed games. Although Gecko OS will allow them to work, I think it's an annoying extra step. I personally have about 20 Trucha signed discs. About 10 discs where I removed "Error 001 protection" and about 10 custom GH3 discs, so I personally have been holding off on updating. Maybe one day I'll be crazy drunk and feel the need to have a Mii Parade, and I'll update. Until then... I guess I'll keep drinking.
     
  16. davhuit

    davhuit GBAtemp Advanced Fan

    Member
    991
    304
    Nov 23, 2005
    France
    Smash Bros Brawl PAL (released only yesterday in Europe) probably have the 3.3 on it. Didn't bought it yet but chance are high that the update is on the DVD (as the update was dated from March in the update files) and so, required to play the game.

    So that's maybe why he's asking, if he's European.

    To answer to the question, the best advice is to remove VC games you didn't bought if you have some, same for the WiiWare (even if Nintendo shouldn't be able to see if they are legit or not, as for the moment, the shop recognize them as "legit games" even if they originally aren't), remove the twilight hack, then do the update, then reinstall everything, so let's summary.

    - Uninstall any VC/WiiWare games downloaded from the web and installed with Wad Installer or such appz (not required, should work without doing that, but the best thing is to remove it, it take a few seconds so), and everything you installed from .wad found on the web (Homebrew Channel, Wad Installer/Uninstaller, Emulators).
    - Remove the old Twilight Hack (also not required, as the update will delete it itself if you leave it, but same, the best advice would be to remove it before, it also take a few seconds so)
    - Run the update.
    - Once the update is done, install the new Twilight Hack, and the VC/WiiWare you uninstalled before the update if you had somes.
    - Enjoy.

    Remove all those things aren't required, like the Homebrew Channel. Even if you leave it, it won't corrupt your Wii and the channel will always work fine, but that's just a precaution, as it cost nothing.
     
  17. elm

    elm GBAtemp Fan

    Member
    352
    22
    Jun 20, 2007
    United States


    Okay, just a few more questions before I consider updating.

    I only have Emulators on my NTSC Wii (Snes & Visual Boy), so what are some of the bugs people keep talking about when updating to 3.3, do they have anything to do with emulators or the ROMS ?

    Do I need to delete my Emu banners before installing the new Zelda hack?

    Thanks Elm
     
  18. Pikachu025

    Pikachu025 GBAtemp Advanced Fan

    Member
    969
    29
    May 3, 2006
    Australia
    Austria
    Brawl doesn't have 3.3E update.

    Also: Whee mass paranoia, again! Come on guys, do we need to go scared every time Nintendo releases something new or some new homebrew thing is found?
     
  19. elm

    elm GBAtemp Fan

    Member
    352
    22
    Jun 20, 2007
    United States
    Okay, just a few more questions before I consider updating.

    I only have Emulators on my NTSC Wii (Snes & Visual Boy), so what are some of the bugs people keep talking about when updating to 3.3, do they have anything to do with emulators or the ROMS ?

    Do I need to delete my Emu banners before installing the new Zelda hack?

    Thanks Elm
    [/quote]



    Anybody plz..... [​IMG]
     
  20. jan777

    jan777 motion control..? srsly? so 2008. 3DS is teh bombz

    Member
    2,829
    36
    Jan 4, 2008
    if you like the trouble to do so