What Did I Do To Deserve This, My Lord? 2

Discussion in 'PSP - Games & Content' started by ConraDargo, Jul 10, 2010.

  1. ConraDargo
    OP

    ConraDargo Flashback Fanatic

    Member
    1,764
    2
    Dec 29, 2003
    Sweden
    People who have downloaded this title seem to have trouble running it, with "The game could not be started (80020148)" popping up as the game loads. Well that's where I'm currently standing as well, and I was just wondering if anyone here has seen any solution to this problem, apart from the obvious "get it on PSN" [​IMG]

    It looks pretty neat (not to mention hilarious) but I wanna try it out before I decide whether or not the game is actually worth my money.

    Edit: oh, and I'm running 5.50 GEN-A on my PSP 1000.
     
  2. Leamonde.Halcyon

    Leamonde.Halcyon 6x9=42

    Member
    736
    0
    Apr 16, 2008
    United States
    6x9=42
    I've had it work flawlessly for me on my PSP 1000 using 5.50 GEN-D3 so upgrading to that might be what you need to do.
     
  3. ConraDargo
    OP

    ConraDargo Flashback Fanatic

    Member
    1,764
    2
    Dec 29, 2003
    Sweden
    That was quick [​IMG] Thank, I'll give it a try ASAP!
     
  4. Leamonde.Halcyon

    Leamonde.Halcyon 6x9=42

    Member
    736
    0
    Apr 16, 2008
    United States
    6x9=42
    Np [​IMG] Hope it works for you
     
  5. ConraDargo
    OP

    ConraDargo Flashback Fanatic

    Member
    1,764
    2
    Dec 29, 2003
    Sweden
    Aw shoot, didn't make a difference - same error :/ Well at least I'm up to date now, though I got some corrupted save data because of it >
     
  6. xist

    xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Member
    5,861
    863
    Jul 14, 2008
    Well technically you're still not on the latest firmware.....
     
  7. Leamonde.Halcyon

    Leamonde.Halcyon 6x9=42

    Member
    736
    0
    Apr 16, 2008
    United States
    6x9=42
    I believe there's a program or something that can fix those corrupted saves. I've never had to use it so I don't know what it is, but do some looking I'm pretty sure I've seen people with this problem who fixed the saves before

    Also, it could be the iso you're using. I was using one that had been ripped and cso'd down to 74 MB and it was working great for me. 5.50 GEN-D3 Final
     
  8. ConraDargo
    OP

    ConraDargo Flashback Fanatic

    Member
    1,764
    2
    Dec 29, 2003
    Sweden
    The game ISO you mean? Because I've been thinking the same thing but can't find any other release apart from Bahamut's (240MB).

    And yeah I installed the GEN-D3 Final.
     
  9. nl255

    nl255 GBAtemp Addict

    Member
    2,571
    360
    Apr 9, 2004
    The fix is to install the Prometheus addon, which replaces pegasus.prx just like the other fix does as the other fix just replaces pegasus.prx with one from D2. D3-Prometheus also gives you compatability with 6.20 games like Persona 3.
     
  10. ConraDargo
    OP

    ConraDargo Flashback Fanatic

    Member
    1,764
    2
    Dec 29, 2003
    Sweden
    Well what do you know, Prometheus fixed everything [​IMG]

    Thanks a bunch for helping out, everyone. This is why the GBAtemp community is one of the best
     
  11. fgghjjkll

    fgghjjkll GBATemp MegaMan

    Member
    GBAtemp Patron
    fgghjjkll is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    2,041
    42
    Jul 7, 2008
    /me facepalms

    Get GEN-D3 next time from PSPGEN.com or psp-hacks.com
    There are several GEN-D3 builds on the internet and some older ones have the save corruption bug.
    I'f reccomend reinstalling GEN-D3 from the sites i listed and then reinstall Prometheus.
     
  12. bluufish

    bluufish Newbie

    Newcomer
    3
    0
    Mar 15, 2009
    United States
    Just a heads up, don't turn on autosave, it's been known to freeze the game AFTER beating an entire level ;___;
     
  13. nl255

    nl255 GBAtemp Addict

    Member
    2,571
    360
    Apr 9, 2004
    No, the problem is with GEN-D3's prometheus.prx (the module that enables 6.XX game compatibility). The previous fix was to replace that file with the one from D2 fixing the bug but losing the increased compatibility of D3. Fortunately, the Prometheus addon also replaces pegasus.prx with a much better one capable of running the newest 6.20 games as well as fixing the save game bug present in the version included with D3.
     
  14. fgghjjkll

    fgghjjkll GBATemp MegaMan

    Member
    GBAtemp Patron
    fgghjjkll is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    2,041
    42
    Jul 7, 2008
    I could compare a old GEN-D3's prometheus.prx with a new GEN-D3 prometheus.prx. I predict they could be different meaning that GENySUS has modified promethes.prx in the final build of GEN-D3.

    Also, Prometheus is based on GEN. So depending where liquidzigong got his prometheus.prx from which GEN-D3, it could still have the save corruption bug.
     
  15. nl255

    nl255 GBAtemp Addict

    Member
    2,571
    360
    Apr 9, 2004
    Prometheus (v4) does not have the save corruption bug, at least not that I can tell.