what CFW do i need to get persona 1 to run on my psp

Discussion in 'PSP - Games & Content' started by Grink, Jul 3, 2010.

  1. Grink
    OP

    Grink GBAtemp Regular

    Member
    2
    Jan 24, 2009
    United States
    trapped in a gutter
    im running 5.50 gen-d2

    on an early slim that came in a corepack with daxter
     
  2. YoshiChao

    YoshiChao Member

    Newcomer
    1
    Dec 15, 2009
    Melbourne
    Try 5.50 GEN-D3. If that doesn't work, try 5.50 Promethius.
     
  3. Grink
    OP

    Grink GBAtemp Regular

    Member
    2
    Jan 24, 2009
    United States
    trapped in a gutter
    is 5.50 prom compatible with the european version of peacewalker?
     
  4. lildeathboy

    lildeathboy Member

    Newcomer
    1
    Dec 19, 2008
    United States
    @Grink i dink at least it is a clean iso from peacewalker itll work. im not on 5.50 pro or playing peacewalker yet
     
  5. bloshengland

    bloshengland Member

    Newcomer
    1
    Jan 8, 2009
    yeah it will work but put no cheats on
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice