Well, the PSP is screwed (Soul Calibur Related)

Discussion in 'PSP - Games & Content' started by dgwillia, Aug 27, 2009.

  1. dgwillia
    OP

    dgwillia The Bacon Lover

    Member
    2,171
    215
    Mar 9, 2008
    United States
    Columbia Station, Ohio
    Well, Soul Calibur has been leaked, and its 5.55 OFW......and to top it off, Dark Alex closed down his site today......man the PSP is screwed.... T.T (Dont want to wait 1 month and 6 days to play Soul Calibur.....)
     


  2. Excellentnuke

    Excellentnuke GBAtemp Advanced Fan

    Member
    612
    2
    May 19, 2008
    United States
    On a boat
    Just wait for GEN to update their firmware. I'm sure that once 5.55 hits the US it won't take long for an update.

    And darn. I was looking forward to Soul Calibur.
     
  3. dgwillia
    OP

    dgwillia The Bacon Lover

    Member
    2,171
    215
    Mar 9, 2008
    United States
    Columbia Station, Ohio
    Meh, not a fan of GEN, its so dam buggy. And can a M33 PSP update directly to GEN? Or do you need a MMS/Pandora Battery?
     
  4. AGENT209T

    AGENT209T Member

    Newcomer
    46
    0
    Mar 16, 2006
    United States
    Winter Haven, FL
    aw he did? well this sucks thanks again DA unless this is another trick lol but oh well it was a good run.
     
  5. dgwillia
    OP

    dgwillia The Bacon Lover

    Member
    2,171
    215
    Mar 9, 2008
    United States
    Columbia Station, Ohio
    Im hoping he ressurects on us....but im thinking M33 is done. Either gotta wait for a GEN or something else update, or to buy it on the PSP Go. Im just praying Disgaea 2 doesnt require 5.55, been waiting for that game for over a year.....
     
  6. Excellentnuke

    Excellentnuke GBAtemp Advanced Fan

    Member
    612
    2
    May 19, 2008
    United States
    On a boat
    You can update to GEN directly from M33 perfectly fine without any problems.
     
  7. dgwillia
    OP

    dgwillia The Bacon Lover

    Member
    2,171
    215
    Mar 9, 2008
    United States
    Columbia Station, Ohio
    Oh, that makes me feel a bit better then.
     
  8. vergilite

    vergilite GBATemps Regular Clown

    Member
    737
    0
    Apr 14, 2009
    Liv-Liv-Liverpool YEAH!
    damn it!! well i got a few partys to keep me busy for a month (and school [​IMG]) so i guess i can wait for a "possible" fix
     
  9. blitzer320

    blitzer320 GBAtemp Fan

    Member
    370
    0
    Sep 29, 2008
    United States
    NYC
    a good question is why even leak it if you can't play it unless someone out there has found a umd burner with a blank umd it just teasing everyone
     
  10. 8BitWalugi

    8BitWalugi Taiyohhhhhh!

    Member
    3,422
    273
    Mar 22, 2008
    Australia
    Side 7
    Hold on... So what's the difference between GEN and M33? And if I install GEN, can I switch back to M33?
     
  11. r9delta

    r9delta Banned

    Banned
    168
    0
    May 17, 2008
    United States
    You can go back to M33. Anyway on topic good game Sony, even if just for a (likely very) short while. Even though I pirate a few games myself it's good to see a few helpless failures on here think their world is coming to an end because they can't pirate and play a leaked game immediately.
     
  12. blitzer320

    blitzer320 GBAtemp Fan

    Member
    370
    0
    Sep 29, 2008
    United States
    NYC
    m33 and gen to me seem the same but some people have said that gen is buggy maybe that was the first versions but people have to understand that when dark alex slowed down on updating m33 gen stepped in and ithey haven't had many updates so give them time to correct things just like m33 had bugs when it first came out, way back when but if your on m33 i suggest to go to gen i did had no problem and now i can go back on the psn network
     
  13. 8BitWalugi

    8BitWalugi Taiyohhhhhh!

    Member
    3,422
    273
    Mar 22, 2008
    Australia
    Side 7
    Im confused. I ran the GEN-B updater and under system info, it still says 5.00 M33-6. What happened?
     
  14. blitzer320

    blitzer320 GBAtemp Fan

    Member
    370
    0
    Sep 29, 2008
    United States
    NYC
    thats because gen-b updater is for the latest gen-a you need the latest gen-a then update to gen-b
     
  15. 8BitWalugi

    8BitWalugi Taiyohhhhhh!

    Member
    3,422
    273
    Mar 22, 2008
    Australia
    Side 7
    Sooo... update to GEN-A, then update to GEN-B?
     
  16. FAST6191

    FAST6191 Techromancer

    pip Reporter
    23,361
    9,154
    Nov 21, 2005
    M33 is based on the 5.00 kernel, GEN is based on the newer 5.50 kernel. As I understand the people behind M33 said they were skipping the 5.5 as it had nothing of interest and were waiting for the 6.00 line which should have something more.

    Now a few games have appeared that demand the 5.55 kernel (or something other than 5.0 and the M33 still "fakes" 5.0 which obviously means the game decides not to run (there are a handful of hacks that I know of to dodge protection but I am lacking in knowledge on this front so I will stay quiet for now)).
    The firmware otherwise known as GEN will work once it is updated (assuming we are still talking soul calibur, other 5.5 demanding games should now work) but when compared to M33 it can best be described as rough and ready and some games have some good protection that can make it a bit unstable which does not help this image.
    This being many years on in PSP land a fair few seemingly quite vocal people are kind of used to highly polished hacks for whatever reason (going back to the DS how many people would use a passme2 today?) so GEN firmwares have not quite escaped their rough and ready image just yet.

    As for changing firmware you should be able to change back and forth if you have a 1000 or 2000 that is up for this sort of thing (TA-88v3 series boards are not remember) but there is little point. Those still fiddling with 2000 and 3000 models and Custom Firmware Enabler should be OK as it is is obviously a ram thing but I am not up on the goings on of the 2000 and 3000 these days so I suggest some reading.

    Also no love for MHU people?

    @blitzer320 seen a PS3 release lately?
     
  17. r9delta

    r9delta Banned

    Banned
    168
    0
    May 17, 2008
    United States
    Oh man, if those few vocal people had to, for some unforeseen reason, go back to the days of 1.5 firmware and the 2 memory stick swap (right before you only needed 1 stick) I believe they'd crap their pants several times over. Never used a passme2 myself though, my first was a ez pass 3 card and g6 lite.
     
  18. Chris_Skylock

    Chris_Skylock GBAtemp Advanced Maniac

    Member
    1,501
    0
    Dec 26, 2008
    Philippines
    http://www.youtube.com/watch?v=uyKOmc51ms8

    So DA has closed down or what? I want my PSP to be up to date and still play games from the memory card. Didnt bother if it's new or old as long as I can play my favorite games.
     
  19. 8BitWalugi

    8BitWalugi Taiyohhhhhh!

    Member
    3,422
    273
    Mar 22, 2008
    Australia
    Side 7
    Updated to GEN-B. Wow. I can make a Pandora battery now! Now, if one of my friends want to install CFW, can i make the pandora battery on my PSP, than take it out and put it in his and it'll work?
     
  20. xist

    xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Member
    5,861
    863
    Jul 14, 2008
    Double screwed....DAX's forum's have shut down, whether from external pressure or otherwise. Prospects of a new M33 firmware are going from unlikely to never.