1. RHOPKINS13

    OP RHOPKINS13 Geek
    Member

    Joined:
    Jan 31, 2009
    Messages:
    1,247
    Country:
    United States
    I'm having a weird problem in MarioKart 8 Deluxe. I'm running it from an installed NSP backup, Switch is on 5.1.0 with ReiNX CFW & exFAT support. I have the Switch docked with an official Wii U Gamecube Adapter plugged into the side of the dock.

    Any time I use a Gamecube controller in Port 1 of the adapter, during the race the vehicle constantly accelerates. Smart Steer / Tilt Control / Auto Acceleration are all turned off. It's weird, because it's acting like the A button is stuck being pressed down, but I have no problems hitting the A button when navigating the menus and picking a kart. It even causes the kart to rev up and spin out at the beginning of every race. I've tried two different Gamecube controllers, one black, and one silver. They're both official OEM Nintendo controllers from when the Gamecube was still being manufactured.

    This problem only happens with a controller plugged into Port 1. I can leave Port 1 empty, and plug my controllers into ports 2 and 3, and everything works fine. This kind of leads me to think it's a problem with the adapter, but I've never had a problem playing games like Smash Bros. on my Wii U with it. And it still seems awfully strange that hitting the A button still works in menus, and it only affects kart acceleration. Is there any other button that it could simulate being stuck down that could cause this?

    I was wondering if anyone else had a Wii U GC adapter that could give this a shot? I'm curious whether or not buying a new adapter would fix my problem.
     
  2. Memoir

    Memoir Hi, I'm Cynical!
    Member

    Joined:
    Jun 24, 2007
    Messages:
    10,507
    Country:
    United States
    Could be reading c-stick as UP. AFAIK that is also "accelerate"
     
  3. Wowjinxy

    Wowjinxy Member
    Newcomer

    Joined:
    Oct 15, 2017
    Messages:
    17
    Country:
    United States
    Finally someone I can help! This is actually not a glitch at all, MK8D has a few new options for newer players. Of those there is a option to help prevent you from falling off the track, turn motion controls on and off, and the one you are experiencing a always move forward option! While in the cart select screen press the + or - and you will see the 3 options right below the kart stats.
     
  4. KiiWii

    KiiWii Reporter
    Reviewer

    Joined:
    Nov 17, 2008
    Messages:
    12,561
    Country:
    United Kingdom
    Op stated:
    “Smart Steer / Tilt Control / Auto Acceleration are all turned off“
     
    RHOPKINS13 likes this.
  5. RHOPKINS13

    OP RHOPKINS13 Geek
    Member

    Joined:
    Jan 31, 2009
    Messages:
    1,247
    Country:
    United States
    That Auto Acceleration feature would not normally cause a cart to spin out at the start of every race.
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Adapter, Glitch, Weird