Hardware Weird color bars on PSP-3001 screen.

Cyberfalcon

Well-Known Member
OP
Newcomer
Joined
Jan 8, 2019
Messages
58
Trophies
0
XP
511
Country
United States
I have this little project of mine about getting PSP and restore it as new as much as possible. So, bought a pre-owned PSP-3001 and the previous owen told me that everything but the stick works. So I decided to open the PSP and replace the joystick then assemble it back but after powering the PSP I found a problem with the screen, there are some weird color bars on the upper area of the screen making me think that somehow the lcd got damaged, even though I did the proccess as calm and careful as possible.

So what do you think is the problem? the motherboard or the screen?

I already teardown again my PSP to check if the ribbon cables are connected properly but the problem persist. I Also, connect my PSP to my pc throught remotejoy and the problem dissapears.

So....I'm not sure what shoud I do. What else should I test?
 

Attachments

  • psp3.jpg
    psp3.jpg
    354.8 KB · Views: 236
  • psp2.jpg
    psp2.jpg
    157.6 KB · Views: 206
  • psp1.jpg
    psp1.jpg
    410.8 KB · Views: 233
Last edited by Cyberfalcon,

slaphappygamer

Well-Known Member
Member
Joined
Nov 30, 2008
Messages
3,779
Trophies
2
Age
45
Location
California
XP
5,618
Country
United States
Definitely a fault in the screen. Could be dirty connection. I don’t think it’s damage to the screen. You’d see cracking. Could be a damaged ribbon cable to the screen as well.
 

Ryccardo

watching Thames TV from London
Member
Joined
Feb 13, 2015
Messages
7,403
Trophies
0
Age
27
Location
Imola
XP
6,390
Country
Italy
The 3000's display uses a serial interface so it's pretty much impossible for a cable/connector problem to result in that pattern...
Looks like it's a problem with the internal row/column flat cables, not really fixable unless you disassemble the screen and try questionable (on calculators and original Game Boys, wouldn't want to imagine on a comparatively high resolution screen like this one) hairdryer and tweezers tricks... or maybe the actual controller chip (also inside the screen) has gone bad
 

Cyberfalcon

Well-Known Member
OP
Newcomer
Joined
Jan 8, 2019
Messages
58
Trophies
0
XP
511
Country
United States
So...a Simple LCD swap should fix this issue?
Hopefully the problem is related to the lcd and not the Motherboard or any connector.

Here's something new I found out btw.
Any icon or text that appears on the upper area get marked but disappears within seconds. Like a water mark that dries out.
 

Attachments

  • 20191104_190157.jpg
    20191104_190157.jpg
    1,023 KB · Views: 217
Last edited by Cyberfalcon,

You may also like...

General chit-chat
Help Users
    AncientBoi @ AncientBoi: I think I'll get the Hail effect joycons for summertime :rofl2: