WD PASSPORT 3.0 x USB Loader GX- Issues that need resolving.

Discussion in 'Wii U - Hacking & Backup Loaders' started by WarMachine77, Oct 4, 2013.

  1. WarMachine77
    OP

    WarMachine77 GBAtemp Regular

    Member
    175
    17
    Jan 29, 2010
    United States
    Okay, so first and foremost, I did my own research before posting this.

    After looking into it, I determined that I would need a USB hub and a Y cable.

    With a Y cable and a hub, the Wii U asks if I want to format the HDD, which is a good sign I suppose, seeing as how it doesn't detect it at all in other circumstances.

    However, using USB Loader GX, it does not detect an HDD at all, even after I've formatted the entire drive in WBFS format using Wii Backup Manager.

    I believe I'm using IOS 249

    Please help! I don't want to go out and get another HDD.

    Thank you,

    -WarMachine
     


  2. tbgtbg

    tbgtbg Shaking the ring ropes up in the sky

    Member
    1,951
    448
    Nov 27, 2006
    United States
    Try FAT32 instead of WBFS.
     
    WarMachine77 and Unsought like this.
  3. OriginalHamster

    OriginalHamster UStealthy

    Member
    3,381
    642
    Nov 2, 2008
    Cote d'Ivoire
    Did you tried connecting the data cable in the other port?
    The data cable should go in top USB (Wii U in horizontal position), in the back of the console, and the power USB cable in the bottom one.

    Wii U system can detect it in whatever USB port, that's why it can see it.
     
    WarMachine77 likes this.
  4. Unsought

    Unsought Stop being a fucking dinosaur and get a job

    Newcomer
    60
    16
    Mar 20, 2013
    United States
    Somewhere that is here but isn't here
    I agree with tbgtbg.
    Try using Fat32 with WBFS files.
     
    WarMachine77 likes this.
  5. WarMachine77
    OP

    WarMachine77 GBAtemp Regular

    Member
    175
    17
    Jan 29, 2010
    United States
    Tried, but that didn't work. Also tried using a Y cable and a DYNEX USB 2.0 Port Hub with a power adapter. USB Loader hands during the loading screen. This is getting really frustrating.

    And OriginalHamster, I don't know what that means, sorry. All I have is the 3.0 wire running into a hub with a Y coming out of it which is powered by an external supply
     
  6. hms

    hms Member

    Newcomer
    15
    4
    Dec 16, 2012
    Seychelles
    Only one of the split end (2 connectors) of usb cords connectors carry both data and power , and the other only power, so make sure you put the right one to top usb port on weakU.


    ASCII starts here:
    ----------------------

    Code:
    Data+power                  only extra power
     
    ||||                                ||
     
    ||||                                ||
     
    -----------------||||-----------------
     
                    ||||
     
                    ||||
     
    WarMachine77 likes this.
  7. WarMachine77
    OP

    WarMachine77 GBAtemp Regular

    Member
    175
    17
    Jan 29, 2010
    United States
    I see, thanks! I think my HDD was filled with garbage data partitions, so I consolidated it and I'm now formatting with EASEUS in FAt32..with 32 bit clusters..thanks guys!
     
  8. WarMachine77
    OP

    WarMachine77 GBAtemp Regular

    Member
    175
    17
    Jan 29, 2010
    United States
    Okay, somebody unplugged my HDD during the FAT32 format.

    However, I did try it as WBFS and in NTFS....and I still get the same error. I'm going to let it format into FAT 32 before I go to work, but honestly, this thing is pissing me off. I have an external power supply via the HUB

    Something to note is that Wiiflow claims I have a copy of Brawl that does not boot up, and USB Loader GX kept saying I only had a FAT16 Parition of 1.83 GB even though this was not the case.
     
  9. Unsought

    Unsought Stop being a fucking dinosaur and get a job

    Newcomer
    60
    16
    Mar 20, 2013
    United States
    Somewhere that is here but isn't here
    Format it to Fat 32 and try connecting your usb 3.0 into a female to male usb 2.0. It worked for me.
     
  10. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,027
    8,549
    Oct 27, 2002
    France
    Engine room, learning
    HUBs are not working.
    Connect your drive in direct mode.
     
    blinkzane likes this.
  11. WarMachine77
    OP

    WarMachine77 GBAtemp Regular

    Member
    175
    17
    Jan 29, 2010
    United States
    What does this mean? Wii U can still pick it up.
    I tried FAT32 as well. This was the fix that eveyrbody suggested, with the solution for the WD Passport everybody suggested.

    Hopefully, I don't come across as snippy, but I've spent close to $50 trying to get this thing to work.
     
  12. WarMachine77
    OP

    WarMachine77 GBAtemp Regular

    Member
    175
    17
    Jan 29, 2010
    United States
    I'm bumping my own topic, because apparently it's a common model, but those that figured out how to get it to work, pretty much don't share.

    Holy run on sentence, Batman!

    But seriously, I need some help PLEASE. I've been working on this for days between my job. Do I need a different Y cable? What do I do?




    What does this mean exactly? Pardon the ignorance, but I don't get it.
     
  13. Unsought

    Unsought Stop being a fucking dinosaur and get a job

    Newcomer
    60
    16
    Mar 20, 2013
    United States
    Somewhere that is here but isn't here
    Try plugging your usb 3.0 into a female to male 2.0 usb.
     
  14. WarMachine77
    OP

    WarMachine77 GBAtemp Regular

    Member
    175
    17
    Jan 29, 2010
    United States
    So forget the hub with many slots and is powered?

    Because I have another hub that I purchased for 3 dollars that is not powered and has the ipod wires...I think it's just better if I show a picture;

    [​IMG]

    Could I use that? I used that with a Y and nothing happened. Would I just use it with a male USB to USB?
     
  15. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,027
    8,549
    Oct 27, 2002
    France
    Engine room, learning
    Can't you connect your drive directly to the console without using a hub?
    the console might be compatible with hub, but USBLoaders are not. (it could be added but I don't know how hubs are working, I don't have one to see how it works)

    First, determine if the problem is your drive or the hub presence :
    Connect your drive directly to the Wii (not WiiU) without hub : drive <> USB3 cable <> Wii, see if USBLoaders can mount the drive. (usb3 should work as usb2 automatically)
    then test your hub : drive <> hub <> Wii, see if it's still working. If not,then the loader doesn't support hub.

    Do the same test on WiiU's vWii.


    Your problem is the drive is not extrenally powered? (I though USB3 required a lot of power and should always be externally powered)
    If it's not powered, use a USB3-y-Cable or an adapter (not hub) to usb3-usb-ycable. The shorter the cables are, the better it is.
     
    WarMachine77 likes this.
  16. WarMachine77
    OP

    WarMachine77 GBAtemp Regular

    Member
    175
    17
    Jan 29, 2010
    United States

    Seems like a good method of trial and error. I will try this by the end of the week...but there are a few problems;

    The Wii U cannot read my USB 3.0 device. At all. It isn't until I use a Y splitter that I get a prompt to format it.

    My Wii's USB port (the one used for USB Loading is broken) This is why I have the Wii U. If you mean, for HBC, etc, since Wii can read both ports for this, okay, I will try it after midterms-but it seems redundant since my friend has the same model and he reports it as working fine for the Wii. Still..I'll try it when I have the time.

    USB3-y-cable-I haven't seen this in Canada, and I'm not quite sure what you mean by an adapter.

    This is the alternative that I also tried with to no avail;

    [​IMG]

    http://www.bestbuy.ca/en-CA/product/dynex-dynex-7-port-usb-2-0-hub-dx-hb7pt-dx-hb7pt/10174354.aspx
     
  17. Unsought

    Unsought Stop being a fucking dinosaur and get a job

    Newcomer
    60
    16
    Mar 20, 2013
    United States
    Somewhere that is here but isn't here
    Try without the hub.
    What I did with my 3.0 USB is plugged it into a female to male USB 2.0 and put it in the right usb slot on the back of the Wii U because the USB Loader GX screen would just hang on the left.
     
  18. adrenochrome

    adrenochrome Member

    Newcomer
    42
    9
    Sep 12, 2009
    France
    NO hub at all !

    first check your usb3 hd on a computer, does it have an extra undeletable partition including a software named like "WDsmartware" , if yes you'll have to get ride of it (there are tools for this)



    once you'll be sure your hd is clean,



    use a "Y" usb2 cable + your usb3 cable
    [​IMG]
    or a female to female adapter + "Y" usb2 cable + your usb3 cable
    [​IMG] + [​IMG]
    or change your usb3 cable for a "Y" usb3 cable
    [​IMG]
    and connect the data plug (the one with 2 wires) to the right port of the wiiu
     
  19. WarMachine77
    OP

    WarMachine77 GBAtemp Regular

    Member
    175
    17
    Jan 29, 2010
    United States
    This seems like the most simple, and I found an Amazon retailer that will sell this.

    http://www.amazon.ca/eForCity-Micro-B-USB-Cable-Black/dp/B005M0ICG2/ref=sr_1_1?s=electronics&ie=UTF8&qid=1381387392&sr=1-1&keywords=usb 3.0 y cable

    So just to confirm, it would be JUST this one cable, after which, it would be working for certain?

    I have my doubts as I don't think the Wii U can draw enough power, even from both ports...or would I be wrong?

    Please let me know at your earliest convenience, after which, I will place an order.
     
  20. Unsought

    Unsought Stop being a fucking dinosaur and get a job

    Newcomer
    60
    16
    Mar 20, 2013
    United States
    Somewhere that is here but isn't here
    It seems to be the correct cord and the only one you will need.
     
    WarMachine77 likes this.