Was hoping someone could help me understand an error I sometimes encounter.

Discussion in 'PS Vita - Hacking & Homebrew' started by Dirty-Steve, Sep 22, 2018.

  1. Dirty-Steve
    OP

    Dirty-Steve Newbie

    Newcomer
    1
    Sep 22, 2018
    United States
    New York
    Currently using SD2Vita and it’s working well. Just started backing up my game carts to my ux0 app folder and they work but sometimes the actual game folder in my ux0/app folder just doesn’t show unless I mount and unmount my ux0. Like last night I backed up Marvel vs Capcom 3. And had it running. This morning I turned my vita back on, did the whole h-encore thing because I’m on 3.68 and then when I tried to run the game it said corrupt. So I went to vita shell and it was missing although on my pc it was clearly there... so I mount and unmount ux0 and the folder was there and I refreshed t back to live area all over again. Can I fix or prevent this???

    Let me provide a clearer example. (USing SD2Vita)
    1. Insert game cart.
    2. Dump game folder to memory card and generate license
    3. Copy game dump folder with renamed license to pc
    4. Switch my ux0 to SD2vita
    5. Place folder in proper space in ux0 app folder
    6. When browsing vitashell on the vita itself, the game folder I copied sometimes isn't visible.
    7. If I mount then unmount ux0 the folder appears in vitashell. Sometimes after rebooting I get an error when starting the dumped game. Entering vitashell shows the file is somehow missing again causing me to mount unmount delete my bubble and re add the bubble by refreshing live area again.
     
  2. eighthdayregret

    eighthdayregret fnerrrrrrrrrr!

    Member
    3
    Sep 27, 2017
    United States
    I would connect your Vita to your PC via USB and check the disk for errors.
    Also, which plugin are you using for your SD2Vita? storagemgr or gamesd?
     
  3. Dirty-Steve
    OP

    Dirty-Steve Newbie

    Newcomer
    1
    Sep 22, 2018
    United States
    New York
    Looking at my config.txt its storagemgr. Checking for errors now.
     
    Last edited by Dirty-Steve, Sep 22, 2018
  4. eighthdayregret

    eighthdayregret fnerrrrrrrrrr!

    Member
    3
    Sep 27, 2017
    United States
    You should really only see the corruption error if a.) the game is actually corrupt, or b.) your SD2VITA is not mounted to ux0 when trying to start the game.
    a.) seems like a non-issue if you've been able to play the backed up version before.
    Check the storagemgr config file and make sure there aren't any conflicts in the settings. Your regular memory card is mounted as ux0 by default, so if the game is not backed up there, you wouldn't see the folder for the game in the app folder in VitaShell, but the issue would be "fixed" if you were to mount the SD2Vita through VitaShell and go back to what would only appear to be the same folder.
     
  5. Dirty-Steve
    OP

    Dirty-Steve Newbie

    Newcomer
    1
    Sep 22, 2018
    United States
    New York
    If after i install the backup and then use psn to update the app and install officially purchased dlc should it work? Or could that cause an issue?
     
  6. eighthdayregret

    eighthdayregret fnerrrrrrrrrr!

    Member
    3
    Sep 27, 2017
    United States
    It should work fine, assuming it's dumped and installed correctly. NoNPDRM games are able to update straight from PSN without issues.
     
  7. Dirty-Steve
    OP

    Dirty-Steve Newbie

    Newcomer
    1
    Sep 22, 2018
    United States
    New York
    Well I managed to copy all of my cartridge dumps over and got them working right. I guess maybe some copied over poorly the first time around. Here’s the kicker, now with my game carts finished I’m adding some more psp ISO’s. I’m having a similar issue where after they are copied over I can’t see them in adrenaline or vita shell. However the adrenaline bubble manager sees the files and lets me creates working bubbles. Any ISO’s I copied over before switching to SD2Vita are visible in vita shell, everything I’ve been trying to add since I switched I only see browsing via pc or adrenaline bubble manager.
     
Loading...