Waninkoko prepares Firmware Updater 4.2

Discussion in 'Wii - Hacking' started by manaphy4ever, Sep 29, 2009.

  1. manaphy4ever
    OP

    manaphy4ever GBAtemp Advanced Fan

    Member
    505
    1
    May 7, 2008
    Bosnia and Herzegovina
    Bahrain
    I've been talking to Waninkoko and is already preparing its Firmware Updater 4.2 to upgrade to 4.2 and lose nothing. Q I do not think more than a week late in getting it ready.


    Source: i can't tell because from the site to download wii games it's a rules from gbatemp. (sorry)
     


  2. screamq3

    screamq3 GBAtemp Regular

    Member
    188
    0
    Nov 23, 2008
    if this is true then great news [​IMG]
     
  3. illinialex24

    illinialex24 GBAtemp Advanced Fan

    Member
    968
    0
    May 26, 2009
    United States
    The Midwest
    That would be amazing. I really want the update check gone.
     
  4. King Of Chaos

    King Of Chaos GBAtemp Regular

    Member
    189
    0
    Sep 12, 2009
    United States
    If indeed true, this will be great!
     
  5. moosehunter

    moosehunter GBAtemp Regular

    Member
    199
    1
    Nov 26, 2008
    United States
    Do we really need a firmware updater?
    Can't we just download the new IOSs/system menu and install them with wad manager
    What would a firmware updater do that we can't do on our own? Or is there something i'm missing here?
     
  6. King Of Chaos

    King Of Chaos GBAtemp Regular

    Member
    189
    0
    Sep 12, 2009
    United States
    Well, if you update it yourself, you'll lose Homebrew when updating the system menu to 4.2.
     
  7. Satangel

    Satangel BEAST

    Member
    10,255
    555
    Nov 27, 2006
    Belgium
    Bruges, Belgium
    Damn, he's fast.... Gotta love it, hopefully he releases it soon.

    Big thanks already Waninkoko, you're amazing!
     
  8. smash_brew

    smash_brew I may or may not have fallen

    Member
    708
    2
    Oct 8, 2008
    United States
    moosehunter is right. and there really is no need to update to 4.2 in the first place. shit i'm still on 3.2
     
  9. chrisf

    chrisf Banned

    Banned
    112
    0
    Jun 7, 2009
    United States
    you wont be saying that when new super mario bros requires 4.2 system menu even if u have updated your ios's on 4.1 or lower
     
  10. Satangel

    Satangel BEAST

    Member
    10,255
    555
    Nov 27, 2006
    Belgium
    Bruges, Belgium
    Same here, but it will help the flood of questions and help solve a lot of problems.
     
  11. Perfect Slayer

    Perfect Slayer Newbie

    Newcomer
    7
    0
    Sep 13, 2009
    France
    France
    This is at last a good news today !
     
  12. moosehunter

    moosehunter GBAtemp Regular

    Member
    199
    1
    Nov 26, 2008
    United States
    How would installing the 4.2 wad remove HBC? Unless... the system menu itself deletes HBC instead of the update process deleting it
     
  13. Helsionium

    Helsionium Alpha and Omega

    Member
    351
    12
    Jul 18, 2008
    Australia
    Innsbruck, Austria
    That's just what System Menu 4.2 does... unfortunately.
     
  14. King Of Chaos

    King Of Chaos GBAtemp Regular

    Member
    189
    0
    Sep 12, 2009
    United States
    If you update the system menu itself with the system menu WAD, it will automatically delete HBC on every launch. You'll need the Indiana Pwns or Smash Stack exploit to run homebrew again if you do indeed update the system menu itself.

    Regarding the IOS wads, I don't see any reason to update them just yet to the latest versions until it's deemed safe or some technique is found.
     
  15. jabmaster2

    jabmaster2 GBAtemp Fan

    Member
    477
    0
    Apr 24, 2009
    United States
    That's exacly how it works. The system menu does the deleting not the update. That's why u can't just reinstall the hbc after official update
     
  16. urherenow

    urherenow GBAtemp Addict

    Member
    2,748
    786
    Mar 8, 2009
    United States
    Japan
    I'd say you can get the latest IOS files using NUS and run them through freethebug, but DoP-IOS is updated already so you can use that to have all of them

    Still on 3.2... you're retarded there's no reason NOT to be on 4.1

    latest IOS files keep discs from asking for updates, but then so does one of the hacks in preloader.

    so some technique found? DoP-IOS = latest IOS with Trucha
    Safe? Of course! installing the latest IOS files does not mean you are installing system menu 4.2... just the new IOS.

    There is even a third option (many here find it to be a stupid option, but it's still an option) and that's install cIOSCORP 3.4. It makes *almost* all IOS version numbers the maximum value so your Wii will not ask you for an update. (a disc might still ask though unless you disabled it in preloader or startpatch)
     
  17. Ossot

    Ossot GBAtemp Fan

    Member
    494
    0
    Jun 7, 2009
    United States
    The only thing retarded is what you just said. There's no real reason TO be on 4.1 either. The only real benefit ever was copying wads over to the SDcard, but with nand emulation that's out the window. I ran 3.1 until about 2 weeks ago.. no preloader or anything else, shocking I know.
     
  18. Krestent

    Krestent What to post?

    Member
    3,953
    33
    Mar 31, 2009
    United States
    Couldn't you just do a WAD install of only SM4.2 and IOS70, allowing you to keep cIOS and BootMii? For HBC you could just change the Title ID of a HBC WAD using WADder.
     
  19. TiMeBoMb4u2

    TiMeBoMb4u2 GBAtemp Maniac

    Member
    1,306
    201
    Oct 25, 2008
    United States
    Waninkoko = AMAZING! = WIN!

    I'm sure glad he's still willing to help the scene a little...I mean...a LOT! [​IMG]
     
  20. TiMeBoMb4u2

    TiMeBoMb4u2 GBAtemp Maniac

    Member
    1,306
    201
    Oct 25, 2008
    United States
    Doesn't the System Menu do a IOS version check on even the IOS's it doesn't use? If not, that's a dumb mistake on Ninty's part!

    [​IMG]