Hacking vWii Emunand works on SD but not on USB ?

xoINARIox

Member
OP
Newcomer
Joined
Oct 2, 2017
Messages
21
Trophies
0
Age
25
XP
125
Country
Germany
I recently dug out my WiiU again and wanted to play Wiiware using Emunand.
After I created a nand dump with Usbloader GX on my SD I was able to play without any problems.
However, it just doesn't want to work via USB (and yes I changed the path to usb and tried 4 different drives all formatted as FAT32 with 32kb cluster size). Wii and Gamecube games work flawlessly on my drive but every time I want to start a Wiiware/VC game it just brings me back to the loader.
Im using d2x-v10beta52-vWii and also tried it with with a fresh re-install of those cIOS......but still nothing :wacko:

Since I just don't know what to do anymore, I hope that one of you has an idea what it could be.:bow:

SysCheck HDE v2.4.0 HacksDen Edition von JoostinOnline, Double_A, R2-D2199, und Nano
...laeuft auf dem vIOS58 (rev 6432).

Region: PAL
Systemmenue 4.3E (v610)

Laufwerksdatum: 12.07.2012
Homebrewkanal 1.1.2 benutzt IOS58
Homebrew Filter rev47 benutzt IOS58
Hollywood v0x21
Konsolen-ID: 620272067
Konsolentyp: vWii
Shop-Kanal-Land: Germany (78)
Boot2 v0
Es wurden 88 Titel gefunden.
Es wurden 35 IOS gefunden, von denen 0 funktionslos (Stub) sind.

vIOS9 (rev 1290): Keine Patches
vIOS12 (rev 782): Keine Patches
vIOS13 (rev 1288): Keine Patches
vIOS14 (rev 1288): Keine Patches
vIOS15 (rev 1288): Keine Patches
vIOS17 (rev 1288): Keine Patches
vIOS21 (rev 1295): Keine Patches
vIOS22 (rev 1550): Keine Patches
vIOS28 (rev 2063): Keine Patches
vIOS31 (rev 3864): Keine Patches
vIOS33 (rev 3864): Keine Patches
vIOS34 (rev 3864): Keine Patches
vIOS35 (rev 3864): Keine Patches
vIOS36 (rev 3864): Keine Patches
vIOS37 (rev 5919): Keine Patches
vIOS38 (rev 4380): Keine Patches
vIOS41 (rev 3863): Keine Patches
vIOS43 (rev 3863): Keine Patches
vIOS45 (rev 3863): Keine Patches
vIOS46 (rev 3863): Keine Patches
vIOS48 (rev 4380): Keine Patches
vIOS53 (rev 5919): Keine Patches
vIOS55 (rev 5919): Keine Patches
vIOS56 (rev 5918): Keine Patches
vIOS57 (rev 6175): Keine Patches
vIOS58 (rev 6432): USB 2.0
vIOS59 (rev 9249): Keine Patches
vIOS62 (rev 6942): Keine Patches
vIOS80 (rev 7200): Keine Patches
vIOS236 (rev 65535): Trucha Bug, ES Identify, NAND Zugriff
vIOS249[56] (rev 21010, Info: d2x-v10beta52-vWii): Trucha Bug, NAND Zugriff
vIOS250[57] (rev 21010, Info: d2x-v10beta52-vWii): Trucha Bug, NAND Zugriff
vIOS251[58] (rev 21010, Info: d2x-v10beta52-vWii): Trucha Bug, NAND Zugriff
vIOS512 (rev 7): Keine Patches
vIOS513 (rev 1): Keine Patches
Bericht wurde am 11.09.2021 generiert.
 
  • Like
Reactions: Yvaning

xoINARIox

Member
OP
Newcomer
Joined
Oct 2, 2017
Messages
21
Trophies
0
Age
25
XP
125
Country
Germany
Is there really no one with a slight idea what it could be?

If not could someone with a working USB setup tell me what external HDD he uses.
 

xoINARIox

Member
OP
Newcomer
Joined
Oct 2, 2017
Messages
21
Trophies
0
Age
25
XP
125
Country
Germany
are you using ustealth? if so, you need to use a different FAT library with beta52. it's in the ustealth thread.
No I do not use ustealth . . . . but I have installed the mod of airline38 with the different/modified FAT libary. And before that I ve used the normal version for the vWii from https://wiiu.hacks.guide/#/vwii-modding .
But in both cases I can’t play Wiiware/VC via USB.
 
Last edited by xoINARIox,

godreborn

Well-Known Member
Member
Joined
Oct 10, 2009
Messages
20,833
Trophies
1
XP
12,869
Country
United States
I think it's the fat library or I assume it's messing something up. You're using beta 52 of the cios? I think that's the only one with the fat library. It takes you back to usb loader gx if it's not working iirc. Don't know if it's the same with an SD card.
 

xoINARIox

Member
OP
Newcomer
Joined
Oct 2, 2017
Messages
21
Trophies
0
Age
25
XP
125
Country
Germany
I think it's the fat library or I assume it's messing something up. You're using beta 52 of the cios? I think that's the only one with the fat library. It takes you back to usb loader gx if it's not working iirc. Don't know if it's the same with an SD card.
As described above I use beta 52 and can play WiiWare/VC without any problems from the SD card.
But as soon as I try it via USB it brings me back to the loader immediately.
I have also reinstalled beta 52 several times from different sources . . . . . . . . and each time there was the same problem.
 

Cyan

GBATemp's lurking knight
Former Staff
Joined
Oct 27, 2002
Messages
23,422
Trophies
2
Age
43
Location
Engine room, learning
XP
14,523
Country
France
I thought about ustealth and fat mod too, but you already answered that question.

It acts like it can't find the path, or the drive (not enough power, not initialized, wrong partition type, wrong partition table type, etc.)
so I also thought the drive might not be compatible with cIOS, but you also said Wii games are working fine, which also uses cIOS so it's not the problem.

Maybe emuNAND works only with MBR, not GPT ? but all 4 drives using GPT would be a bad coincidence.
Please verify the table type if you know how, or try with smaller drives (less than 2TB, more chance they are not using GPT), or flashdrive (even if they usually are problematic with cIOS and FAT). the first thing to do is find a working setup by trying different element, to know which thing is wrong and then focus on what's different and change it.

That's all I can think. sorry, it's not very useful.
 
Last edited by Cyan,
  • Like
Reactions: godreborn

godreborn

Well-Known Member
Member
Joined
Oct 10, 2009
Messages
20,833
Trophies
1
XP
12,869
Country
United States
yeah, @Cyan is the one who mentioned to me that there's a specific FAT library for wiiware/vc games and ustealth a while back, because my system was doing the same as the op's, only with those games. after reinstalling the cios with the new FAT library, all wiiware and vc games I've tried have worked. :D
 

xoINARIox

Member
OP
Newcomer
Joined
Oct 2, 2017
Messages
21
Trophies
0
Age
25
XP
125
Country
Germany
First of all, thank you for the feedback.

I tried it again with MBR, used a USB flash drive and last but not least I completely reinstalled USB loader GX.
But unfortunately it still doesn't work.
The only thing that was different is that I was not sent back to the loader when I tried a USB flash drive instead I just got a black screen and had to pull the power supply (I waited about 10 minutes)

I guess it just won't work ........
So I will stick with my SD setup for now.
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    KennieDaMeanie @ KennieDaMeanie: I couldn't really get into moon it's too different for my likes