Very strange problem with preloader in SM4.0U

Discussion in 'Wii - Hacking' started by Pip_X, Jun 17, 2009.

  1. Pip_X
    OP

    Pip_X GBAtemp Regular

    Member
    152
    0
    Jul 4, 2006
    Malaysia
    - I have a Wii with System Menu v417 and IOS60-64-v6174.
    - I then installed preloader 0.29 with hack.ini for 4.0U
    - Preloader installer patches IOS60 and boot to preloader menu.
    - Without enabling any hack or change any setting, I immediately go to System Menu from preloader menu, but I got error: File System Corrupted.
    - I go back to preloader menu, and it shows "IOS60 v417" and I double checked, preloader uses IOS60 to load System Menu.
    - I then reinstall preloader again, this time preloader installer did not patch IOS60 because it patched.
    - After the 2nd install, I try to run System Menu again, still the same error message comeout.
    - I try to brick the Wii by installing IOS60-64-v6174 again, and from my understanding, preloader should not work anymore.
    - But after installing IOS60-64-v6174, preloader still loads up, System Menu still show File System Corrupted error.
    - I run the preloader installer again, this time it patch ios60 again.
    - Back to preloader menu, access again System Menu still show File System Corrupted error.
    - I then set the preloader to load System Menu using other IOS (30,50,233,249), the System Menu booted! But will hang when a disc is inserted or the SD menu is accessed.
    - Set in preloader to load System Menu with IOS60 again, File System Corrupted error again.

    - I have never install cIOSCROP, but only cIOS60BF, but it got replaced by IOS60-64-v6174 before I try to install preloader to the Wii.

    - A install of System Menu v417 fixed all this but I cannot get preloader to be installed on the Wii.
     
  2. Pip_X
    OP

    Pip_X GBAtemp Regular

    Member
    152
    0
    Jul 4, 2006
    Malaysia
    Anyone have any idea?
     
  3. koffieleut

    koffieleut GBAtemp Fan

    Member
    364
    43
    Jan 22, 2009
    Netherlands
    probably at home
    hmmm strange, the hang part I also had when running on ios249. have you tried to install a patched ios60 on you're wii? otherwise try to run on ios36 like me. it works(almost(atleast you can acces the wad files and play games))
     
  4. Dio141

    Dio141 Member

    Newcomer
    15
    0
    Mar 29, 2009
    Brazil
    that exactly same problem happened to me too, tried to use ios 60(mine's patched) it said the system was currupted, and i could only unbrick it with bootmii, and tried many others....but i didn't tried ios 36, will try probably tomorow...if it works i'll edit this post so you can try that on your wii.
     
  5. Pip_X
    OP

    Pip_X GBAtemp Regular

    Member
    152
    0
    Jul 4, 2006
    Malaysia
    Loading System Menu v417 on IOS36 wont hang if we insert a DVD or accessing the SD Menu?
    Can we play games form SD Menu as well?
     
  6. Pip_X
    OP

    Pip_X GBAtemp Regular

    Member
    152
    0
    Jul 4, 2006
    Malaysia
    Loading System Menu v417 on IOS36 will hang occassionally on the SD Card Menu.
    And games copies to SD Card wont load.
     
  7. clownz

    clownz GBAtemp Regular

    Member
    121
    6
    Dec 27, 2008
    United States
    Hi Pip,
    Something similiar happened to me and this is how I got mine working right ..

    Installed Cioscorp
    Then reinstalled the patch for ios60
    then reinstalled preloader

    if it says patch already applied, then your going to run into the same error again. You need to get it to where preloader will apply the patch again. I had to do this several times before I got mine working I know on the second try

    I believe at some point I got so ticked off with doing over and over again I might have used Wiiscu at one point to do the update to 60 patched with trucha, but most people havent talked about using wiiscu.

    let me know what happens if you retry with cioscorp. i used the ultimate 4.0 guide steps.
     
  8. Pip_X
    OP

    Pip_X GBAtemp Regular

    Member
    152
    0
    Jul 4, 2006
    Malaysia
    I feel not safe installing cIOSCORP...
     
  9. koffieleut

    koffieleut GBAtemp Fan

    Member
    364
    43
    Jan 22, 2009
    Netherlands
    probably at home
    could it be a patched ios60 file I installed before going to 4.0e? Did you need to install the original ios60 so that waninkoko's 4.0 installer had to patch it? or preloader im not sure of which program patches the ios.
     
  10. Pip_X
    OP

    Pip_X GBAtemp Regular

    Member
    152
    0
    Jul 4, 2006
    Malaysia
    Yes, I'm using the IOS60-64-v6174 from NUS.... But to no avail...
     
  11. jwcgator

    jwcgator GBAtemp Regular

    Member
    140
    9
    May 10, 2007
    United States
    I'm having this exact same problem. I talked to crediar for a bit about it on IRC, and he said that the ES_DIverify module is shared and that maybe something overwrote it with something newer and preloader couldn't patch it, but that was all speculation really.
     
  12. Pip_X
    OP

    Pip_X GBAtemp Regular

    Member
    152
    0
    Jul 4, 2006
    Malaysia
    I cant understand this:

    - I try to brick the Wii by installing IOS60-64-v6174 again, and from my understanding, preloader should not work anymore.
    - But after installing IOS60-64-v6174, preloader still loads up.

    Why preloader still load? The Wii should brick. Why I cannot make it brick this way?
     
  13. jwcgator

    jwcgator GBAtemp Regular

    Member
    140
    9
    May 10, 2007
    United States
    Preloader only patches ios60 so that the system menu can load, not so that Preloader can load. Preloader can use a clean slate IOS60, but it won't be able to load the System Menu
     
  14. _Zephyr

    _Zephyr Member

    Newcomer
    15
    0
    Sep 13, 2009
    Indonesia
    anyone solved this yet? I got the same problem here [​IMG]
     
  15. xzxero

    xzxero ♥bong milk does good for the brain♥

    Member
    3,831
    28
    Jul 18, 2008
    United States
    SB
    It;'s not hard guys, change the IOS in preloaders settings to 30 save restart then back to 60
     
  16. piratesmack

    piratesmack GBAtemp Advanced Fan

    Member
    787
    0
    Mar 28, 2009
    United States
    $(pwd)
    Had the same problem
    Not sure why, but the ES_DiVerifiy patch wasn't working right.

    This is how I fixed it:
    -Downgrade to a system menu that DOES NOT use IOS60
    -Delete IOS60 with Anytitle Deleter
    -Reinstall IOS60 and update again
    -Reinstall preloader

    Uninstalling and reinstalling IOS60 with wad manager didn't work, I had to use anytitle deleter.