VBA Wii (through Homebrew Channel) Save issues

Discussion in 'Wii - Hacking' started by moo948, Jul 23, 2008.

Jul 23, 2008
  1. moo948
    OP

    Newcomer moo948 Newbie

    Joined:
    Jul 23, 2008
    Messages:
    8
    Country:
    United States
    Hello,

    I am new to the whole hacking/homebrew idea, but after I was able to get the Homebrew Channel through the Twilight Hack, things are pretty good.

    However, I have a problem that needs resolving.

    As many of you know, a form of Visual Boy Advance( the GBA/GBC Emulator) can be used in the Wii Homebrew Channel.
    I downloaded the newest version of VBA for Homebrew Channel from wiibrew.org.

    Its called "Visual Boy Advance Version 1.7.2 Port to Wii".

    VBA works fine in the Homebrew Channel. It loads my ROMs perfectly.

    However, some of my ROMs have issues. Pokemon Firered for instance, is 16MB, so it takes a little while for the emulator to load it. Not a problem at all.

    But, after you press start at the title screen of Pokemon Firered, it shows a message: "The 1M sub-circuit board is not installed." Then the game continues on with no problem, until I try to save in game (like you would on a real GBA).

    It says "Save error, Please exchange the backup memory".


    On VBA on the Hombrew Channel, upon choosing Pokemon Firered ROM, it says: 16MB (128Mbits)

    Whenever I save the game using the VBA Pause Menu, it always says "save OK!"

    However, if I exit the channel or ever try to play Pokemon Firered again, I must start all over with the same "sub-cicuit board" message and in game save error.


    I have noticed, that all of my ROMs that are 16MB (128Mbits) will not allow me to save my progress or load it. Whenever I exit a game that is 128Mbits, I must always start over again upon loading it.



    I have been told that some GBA games (Pokemon Firered/LeafGreen), save in Flash 128K instead of Flash 64K.

    This is the problem, I need to be able to save/load my games fro ROMs that use 128K for saving.


    I can fix this problem on the computer version of VBA. I just go to options --> save type --> Falsh 128K. Then it works!


    However, I cannot do this on the Wii version. (as you know)


    If there is an IPS Patch that allows me to do this for use on Wii, please tell me.


    If anyone has a solution, please let me know. Your guess is better than mine.
     
  2. Majin Vegeta

    Member Majin Vegeta GBAtemp Regular

    Joined:
    Jul 12, 2008
    Messages:
    159
    Country:
    Germany
    Never heard of such a error like "The 1M sub-circuit board is not installed." I would suggest downloading the ROM again, maybe from a different location

    For saving ussues:
    SRAM-patch the ROMs which are not working with that tool. You can patch RTC too and also trim it. Don't forget to delete the save file too.
     
  3. zeldarocks

    Newcomer zeldarocks Advanced Member

    Joined:
    Jul 17, 2008
    Messages:
    78
    Country:
    Surprisingly, NONE of my roms have ANY problems whatsoever, I don't even need to patch them, when I need to save, I just press the Home button and press the + key, and its done, no issues whatsoever for me!!! [​IMG] Also , I don't get the Circuit board problem with Leaf Green, why is that?
     
  4. moo948
    OP

    Newcomer moo948 Newbie

    Joined:
    Jul 23, 2008
    Messages:
    8
    Country:
    United States
    Ok, instead of patching the like Vegeta said, I tried something else.

    On VBA for my cmputer, I go to options --> save type --> Falsh 128K. Then I load Firered, and then save the game (not save states, but actual save) as soon as I gain control of the character.

    I think that becasue the sav is now in 128K, it works. So I copied the sav files to the SAVES folders on my SD card.

    It worked great!!!
     
  5. Lumstar

    Member Lumstar Princess

    Joined:
    Mar 6, 2006
    Messages:
    3,531
    Location:
    Darling
    Country:
    United States
    Many flash carts and emulators lack complete support for 128 kilobyte save files in GBA games...
     

Share This Page