VBA - Corrupt Save Files

Discussion in 'GBA - Emulation' started by Elemental, Jul 7, 2007.

Jul 7, 2007

VBA - Corrupt Save Files by Elemental at 2:01 AM (5,551 Views / 0 Likes) 1 replies

  1. Elemental

    Newcomer Elemental Newbie

    Jul 6, 2007
    United States
    Hello, I have a problem. For some reason, whenever I try to import a battery save, or a gameshark snapshot into VisualBoyAdvance (I'm using version 1.8.0 beta 3) it won't load in properly. What I mean, is that, either nothing will happen, or it tells me the data is corrupt. I've tried different save types, and for each of those, I have used Flash 64k or Flash 128k. I also tried opening VBA, changing the save type, closing it, and reopening the rom (in this case, "The Legend of Zelda - A Link to the Past / Four Swords". I have also tried converting one of the GSV (GameShark SP Gameboy Advance Game Save Info) files to the raw SAV file using file trimmer. While I know I converted it right (as when its even a byte lower or higher removed it gives me an error), it still gives me the same corrupt message, or it just doesn't load. Also, I get different results using different save types, so it's not random or anything (ie. EEPROM won't load, and SRAM will give me a corrupt message, on the file selection screen). I've tried using google to see if anyone else has posted concerning the problem I have, but it yeilds no results, or results that have nothing to do with what I want to find. The reason I want to do this is because I want to export a gameshark save file, and load it on to my ALTTP cartridge, as it seems trying to restore any of the saves from GameFaqs doesn't work, either. It can't be that my gameshark (it's an Action Replay GBX - GBA with v3.3 firmware, but I call it a gameshark, as I'm used to saying that) isn't restoring saves properly, as I have no trouble restoring game saves from certain games (ie. Pokemon). Other games, however, like Sonic Advance, don't restore properly either (basically, I'm getting the feeling that it's not actually getting loaded into the cartridge, as I don't get any errors, and none of my files get replaced after trying to restore a game save).

    I'm not sure why this occurs, but I'm guessing that it's the different save types that cause trouble. The odd thing is that I have no trouble loading in Pokemon save states from GameFaqs. I even used one of the save states I made about 5 months ago (SGM) and then saving, and seeing if it bears a SAV file. It however, doesn't create a SAV file when saving. It's also not the ROM file I'm using, as the save states were made using the US version, and the ROM version is the same (AGB-AZLE-USA).

    The save state I am trying to get to load (which is a raw SAV file) is available for download here.

    Anyways, if someone could explain what I'm doing wrong to load SAV/SPS files into VBA, I would really appreciate it.
  2. hdofu

    Member hdofu GBAtemp Regular

    Oct 4, 2007
    United States
    That was formated for a flash advance card and isn't a raw sav. I too have been trying to get working sav file out of this to use on the m3 real and also can't get any of those files to work with either version of the game.

    The GS Snapshots don't seem to work with either the euro version or the US Version of the game in VBA.

Share This Page