Use NTSC wads on PAL Boot2 v4 (LU64+) wii

Discussion in 'Wii - Hacking' started by R4ndom, Sep 8, 2014.

  1. R4ndom
    OP

    R4ndom Advanced Member

    Newcomer
    63
    3
    Mar 18, 2012
    Norway
    Hello, have been trying for a while to make Majora's Mask (both NTSC-U and NTSC-J) work on my PAL Wii for speedrunning purposes. Using Priiloader I have made my Wii region-free, so installing and launching the wads is not an issue. The issue however is that my Wii is forcing the games to run in PAL50, making the audio distorted.

    Solutions I have tried are:

    Patching the wads with this application:
    http://gbatemp.net/threads/custom-nand-loader-mod-1-1.198242/

    • This proved unuseful because when I press the reset button on my Wii, it reboots completely instead of starting the game over again, and additionally, I could only make it work with the japanese wad for some reason.

    Making a wad based on Sin&Pun PAL Wad:
    http://gbatemp.net/threads/finally-pal-n64-in-480p.127689/

    • Could unfortunately not make the end product work at all. When I tried booting it in Dolphin, I got these error messages: "
    • "BackPatch: Currently only supporting reads. Attempted to write to a1380000" "Backpatch write - not through EAX"
    Changing my game region with AnyRegionChanger:
    • Learnt that this application will not work with my Wii because it is too new. :/ This would probably have been the ultimate fix, but oh well.
    Launching the games in an EmuNand:
    • This is the best fix I have for my issue as of right now, as both versions run prefectly. However, when the VC emulator (I presume) boots the ROM after the "You will need the Classic Controller"-message has disappeared, it takes at least half a minute until the Nintendo64-logo shows up on the screen, resulting in a huge timeloss. After this however there is no slow loading in-game. Booting the ROM in a wad install directly to system memory takes at most a 5 to 6 seconds. Both my EmuNands are on my SD Card, class 10 16 GB SanDisk through SNEEK. I have no USB memory unit.
    Launching the versions through the "Force NTSC"-setting in USB Loader GX:
    • This is also makes the versions run perfectly and boot quick, but when I try resetting the Wii softlocks at an all black screen, and I have to hold in the power button to turn it off to get it working. Not a preferred solution. I know I tried at least Gecko OS as well without success.

    Here are my Wii's system specs, in case anyone needs it.

    SysCheck v2.3.0 HacksDen Edition by JoostinOnline, Double_A, R2-D2199, and Nano
    ...runs on IOS58 (rev 6176).

    Region: PAL
    System Menu 4.3E (v514)
    Priiloader installed
    Drive date: 07.14.200807
    Homebrew Channel 1.1.0 running on IOS58

    Hollywood v0x21
    Console ID: 96544323
    Console Type: Wii
    Shop Channel Country: Norway (96)
    Boot2 v4
    Found 105 titles.
    Found 52 IOS on this console. 5 of them are stub.

    IOS3 (rev 65280): Stub
    IOS4 (rev 65280): Stub
    IOS9 (rev 1034): No Patches
    IOS10 (rev 768): Stub
    IOS11 (rev 16174): Trucha Bug, NAND Access
    IOS12 (rev 526): No Patches
    IOS13 (rev 1032): No Patches
    IOS14 (rev 1032): No Patches
    IOS15 (rev 1032): No Patches
    IOS16 (rev 512): Stub
    IOS17 (rev 1032): No Patches
    IOS20 (rev 16174): Trucha Bug, NAND Access
    IOS21 (rev 1039): No Patches
    IOS22 (rev 1294): No Patches
    IOS28 (rev 1807): No Patches
    IOS30 (rev 16174): Trucha Bug, NAND Access
    IOS31 (rev 3608): No Patches
    IOS33 (rev 3608): No Patches
    IOS34 (rev 3608): No Patches
    IOS35 (rev 3608): No Patches
    IOS36 (rev 3608): No Patches
    IOS37 (rev 5663): No Patches
    IOS38 (rev 4124): No Patches
    IOS40 (rev 16174): Trucha Bug, NAND Access
    IOS41 (rev 3607): No Patches
    IOS43 (rev 3607): No Patches
    IOS45 (rev 3607): No Patches
    IOS46 (rev 3607): No Patches
    IOS48 (rev 4124): No Patches
    IOS50 (rev 14889): Trucha Bug, NAND Access
    IOS51 (rev 4864): Stub
    IOS52 (rev 15661): Trucha Bug, NAND Access
    IOS53 (rev 4113): No Patches
    IOS55 (rev 5663): No Patches
    IOS56 (rev 5662): No Patches
    IOS57 (rev 5919): No Patches
    IOS58 (rev 6176): USB 2.0
    IOS60 (rev 16174): Trucha Bug, NAND Access
    IOS61 (rev 5662): No Patches
    IOS70 (rev 16174): Trucha Bug, NAND Access
    IOS80 (rev 16944): Trucha Bug, NAND Access
    IOS202[57] (rev 65535, Info: hermes-v5.0): Trucha Bug, NAND Access, USB 2.0
    IOS222[38] (rev 65535, Info: hermes-v5.0): Trucha Bug, ES Identify, NAND Access, USB 2.0
    IOS223[37] (rev 65535, Info: hermes-v5.0): Trucha Bug, NAND Access, USB 2.0
    IOS224[57] (rev 65535, Info: hermes-v5.0): Trucha Bug, NAND Access, USB 2.0
    IOS236[36] (rev 65535, Info: rev 3351): Trucha Bug, ES Identify, NAND Access
    IOS246[37] (rev 65535, Info: d2x-v3): Trucha Bug, NAND Access, USB 2.0
    IOS247 (rev 65535): Trucha Bug, ES Identify, NAND Access
    IOS248 (rev 65535): Trucha Bug, NAND Access, USB 2.0
    IOS249[37] (rev 21006, Info: d2x-v6): Trucha Bug, NAND Access, USB 2.0
    IOS250 (rev 65535): Trucha Bug, ES Identify, NAND Access
    IOS254 (rev 65281): BootMii
    BC v6
    MIOS v10 (DIOS MIOS Lite 2.11+)
    Report generated on 09/08/2014.

    So my question is: is there a way to make the versions run in 60 Hz on my PAL wii, where resetting or booting is not an issue?