USB Loaders GX and CFG stuck at splash screen / Nintendont working fine

Discussion in 'Wii - Backup Loaders' started by Joe_B, Jan 4, 2019.

  1. Joe_B
    OP

    Joe_B Member

    Newcomer
    1
    Dec 11, 2018
    Canada
    Hello,

    I have 2 USB HDD, both the same model, WD My Book Premium Edition (WD5000P032).

    With one of the two, everything works as expected... I can play through CFG Loader, GX Loader and Nintendont, I can save games, download covers, etc...

    I took out another of these HDD, because the first one is full, and I just can't have the USB Loaders, both GX and CFG, to even start properly... GX hangs at "Initializing USB device", and CFG hangs at the splash screen... However, I can play through Nintendont directly, so the Wii must be able to access the HDD, otherwise Nintendont wouldn't work...

    Here are a few more details:
    • To do proper troubleshooting, I have copy-pasted the exact same content from disk 1 to disk 2.
    • Both disks are formatted as FAT32.
    • I have tried changing the USB cables without any success.
    • So, both HDD are exactly the same, but the Loaders won't load one of the two, when Nintendont is able to read from both drives...
    I need help here, I searched on the net, and some posts suggested playing with IOS, others were talking about HDD compatibility... This is weird, they are the same disks...

    Thanks!
     
  2. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    21
    Oct 27, 2002
    France
    Engine room, learning
    newer hdd seems to require different initialization command that cIOS doesn't have. even if they are the same brand and model, manufacturer update their internal drive firmwares regularly, oddly they lost backward compatibility with old commands.
    it works with nintendont because it's using IOS58, not a cIOS.
    what you can try is to set the loader to use IOS58 at boot too.

    in USBLoaderGX :
    unplug the HDD first so it doesn't get stuck on init drive screen.
    loader's setting > loader's IOS : replace 249 with 58. save, reboot and try again with the drive plugged.
     
    Last edited by Cyan, Jan 5, 2019
    Joe_B likes this.
  3. Joe_B
    OP

    Joe_B Member

    Newcomer
    1
    Dec 11, 2018
    Canada
    Will test this tomorrow and report back...

    Are there some drives that I can upgrade/downgrade the firmware version with some tools from the manufacturer?
     
  4. Joe_B
    OP

    Joe_B Member

    Newcomer
    1
    Dec 11, 2018
    Canada
    Hello!

    I have changed IOS 249 to IOS 58 in USB Loader GX and now everything is working! Am I loosing any functionality by doing this, or is it the same thing with the 2 IOS?

    In CFG USB Loader, there is no choice to use IOS 58, only other IOS... Does this mean I won't be able to use CFG USB Loader with this HDD?

    Thank you so much for your help :)
     
  5. richittgb1

    richittgb1 Member

    Newcomer
    1
    Dec 26, 2018
    Peru
    when I format my hard drive with "BOOTICE" in fat 32, my pc does not recognize it. when formatting in NTFS usb loader remains loading in "initializing usb device". it helps as I format it and in what size to be able to play games of wii and gamecube and how to pass the games to the hard disk. psdt: My hard drive if it is compatible, try with a usb and it only works when I format it in wbfs
     
  6. tswntk

    tswntk GBAtemp Advanced Fan

    Member
    4
    Aug 6, 2012
    Switzerland
    Stop spamming the forum with the same problem over multiple threads.
    Who would want to help you and then finds out its been solved or have contradicting ideas in other threads? And to keep track of multiple threads?
    You are driving helper away instead of drawing more helpers.
     
Loading...