Hacking USB Loader GX

  • Thread starter cyrex
  • Start date
  • Views 6,490,815
  • Replies 28,066
  • Likes 42

Oddx

Member
Newcomer
Joined
Dec 1, 2015
Messages
22
Trophies
0
Age
43
XP
200
Country
United States
hbc stays on scam screen for me as well if launched from the loader but exit to hbc works fine. thought that was default behavior?
 

gforalex

Member
Newcomer
Joined
May 16, 2022
Messages
6
Trophies
0
Location
Virginia
XP
42
Country
United States
Is there a way to hide all buttons to the left of the Parental Lock button when the lock is enabled?

If not, I’d like to suggest this to be an option in the Settings. Thank you.
 

blackb0x

Well-Known Member
Member
Joined
Apr 22, 2019
Messages
463
Trophies
1
XP
2,202
Country
United Kingdom
Is there a way to hide all buttons to the left of the Parental Lock button when the lock is enabled?

If not, I’d like to suggest this to be an option in the Settings. Thank you.
There isn't an option and I don't know if one can easily be added because the buttons aren't generated on the fly, so the lock button wouldn't become rounded. And some of them other buttons do still have a purpose even when parental features are activated.

You could create or install a custom theme to hide or move buttons.

https://yuuiko.github.io/sWiich/
https://gbatemp.net/threads/534875/
https://theme.rc24.xyz/
 
Last edited by blackb0x,

gforalex

Member
Newcomer
Joined
May 16, 2022
Messages
6
Trophies
0
Location
Virginia
XP
42
Country
United States
There isn't an option and I don't know if one can easily be added because the buttons aren't generated on the fly, so the lock button wouldn't become rounded. And some of them other buttons do still have a purpose even when parental features are activated.

You could create or install a custom theme to hide or move buttons.

Thanks, I’ll look into the custom themes.
 

Niavy

Member
Newcomer
Joined
May 9, 2022
Messages
17
Trophies
0
Age
35
Location
Pau
XP
28
Country
France
OK, that will help us determine if it's a GX issue in isolation or something unrelated to GX
Homebrew channel loads fine through system menu channel
Homebrew channel loads fine through USBLOADERGX CHANNEL

That's better than previously, but homebrew loader softlocks on an empty Wii-like screen, whereas it is expected to show homebrews.
I "updated" apps folder path settings (just clicking) but it does not change anything
 
Last edited by Niavy,

XFlak

Wiitired but still kicking
Member
Joined
Sep 12, 2009
Messages
12,737
Trophies
2
Age
36
Location
Cyprus, originally from Toronto
Website
modmii.github.io
XP
7,228
Country
Cyprus
Homebrew channel loads fine through system menu channel
Homebrew channel loads fine through USBLOADERGX CHANNEL

That's better than previously, but homebrew loader softlocks on an empty Wii-like screen, whereas it is expected to show homebrews.
I "updated" apps folder path settings (just clicking) but it does not change anything
Do you have a lot of apps? Can you try with only 1 or 2 and see if that makes a difference? If it's a particular app or icon that is causing an issue it would help to identify it by slowly adding more apps until you find the problematic one. That being said, now we're talking about GX and I'm working a bit outside my wheelhouse, definitely blackb0x is the man for this, but I'm sure providing him with the info I mentioned can't hurt
 

Niavy

Member
Newcomer
Joined
May 9, 2022
Messages
17
Trophies
0
Age
35
Location
Pau
XP
28
Country
France
Yet
Do you have a lot of apps? Can you try with only 1 or 2 and see if that makes a difference? If it's a particular app or icon that is causing an issue it would help to identify it by slowly adding more apps until you find the problematic one. That being said, now we're talking about GX and I'm working a bit outside my wheelhouse, definitely blackb0x is the man for this, but I'm sure providing him with the info I mentioned can't hurt
Don't worry, you're giving me good clues to solve it step by step!

I would not have thought about identifying possible problematic apps. I don't see why there could be one since I cannot remember any SD card noticeable change... This blank screen softlocking appeared out of nowhere. Yet, I'm gonna empty apps folder minus USBloaderGX of course and a test homebrew app.

@blackb0x any more clues about my unexpected and sudden USBloaderGX issue?
 

Niavy

Member
Newcomer
Joined
May 9, 2022
Messages
17
Trophies
0
Age
35
Location
Pau
XP
28
Country
France
WAIT wait wait. Does it make sense to keep USBloaderGX app folder in apps once it is installed through Priiloader 🤔 ? I already have the forwarder in order to replace the "Wii Menu" shortcut
 

Niavy

Member
Newcomer
Joined
May 9, 2022
Messages
17
Trophies
0
Age
35
Location
Pau
XP
28
Country
France
gxo
What homebrew loader are you talking about. The HBC or Priiloader or the homebrew part of usbloadergx or something else?
Talking about the small homebrew icon on the bottom right of the USBloaderGX home screen @Oddx
 

Oddx

Member
Newcomer
Joined
Dec 1, 2015
Messages
22
Trophies
0
Age
43
XP
200
Country
United States
Talking about the small homebrew icon on the bottom right of the USBloaderGX home screen @Oddx
how many files are in your app directory. im working on a fix for a similar issue in the homebrew part of usbloadergx dealing with limiting how deep it searches sub directories. im guessing you have lots of files in the cache_bnr and images folder causing the delay before the homebrew screen actually shows.
 

Niavy

Member
Newcomer
Joined
May 9, 2022
Messages
17
Trophies
0
Age
35
Location
Pau
XP
28
Country
France
how many files are in your app directory. im working on a fix for a similar issue in the homebrew part of usbloadergx dealing with limiting how deep it searches sub directories. im guessing you have lots of files in the cache_bnr and images folder causing the delay before the homebrew screen actually shows.
Yes, quite a lot, 104 GC and Wii games.
I have less than a dozen of homebrews (counting: YAWMM, d2x cIOS installer, Atari2600, FCEUltra, SNES9X, Not64, VGBA, WiiSX, USBloaderGX and a few more I forgot
 
Last edited by Niavy,

Clutz450

Well-Known Member
Member
Joined
Jul 20, 2013
Messages
746
Trophies
0
Age
39
XP
686
Country
United States
I have the Triforce Arcade games running fine when launched directly from Nintendont. However, when I try to launch them through USB Loader GX, I just get a black screen. Launching regular GameCube games work fine though. Any ideas what would cause this? I'm assuming its a setting somewhere but just can't pin point which one. Thanks.

Edit: I could have sworn GameCube games were working but I guess not. GameCube and Triforce games work from Nintendont directly but when launched through USB Loader GX I just get a black screen.

Edit 2: I updated Nintendont from the Features tab in USB Loader GX and now it seems to be working. Not sure what I did wrong but whatever.
 
Last edited by Clutz450,

XFlak

Wiitired but still kicking
Member
Joined
Sep 12, 2009
Messages
12,737
Trophies
2
Age
36
Location
Cyprus, originally from Toronto
Website
modmii.github.io
XP
7,228
Country
Cyprus
I have the Triforce Arcade games running fine when launched directly from Nintendont. However, when I try to launch them through USB Loader GX, I just get a black screen. Launching regular GameCube games work fine though. Any ideas what would cause this? I'm assuming its a setting somewhere but just can't pin point which one. Thanks.

Edit: I could have sworn GameCube games were working but I guess not. GameCube and Triforce games work from Nintendont directly but when launched through USB Loader GX I just get a black screen.

Edit 2: I updated Nintendont from the Features tab in USB Loader GX and now it seems to be working. Not sure what I did wrong but whatever.
I didn't realize GX could update nintendont, good to know, thanks!
 

Clutz450

Well-Known Member
Member
Joined
Jul 20, 2013
Messages
746
Trophies
0
Age
39
XP
686
Country
United States
I have the Triforce Arcade games running fine when launched directly from Nintendont. However, when I try to launch them through USB Loader GX, I just get a black screen. Launching regular GameCube games work fine though. Any ideas what would cause this? I'm assuming its a setting somewhere but just can't pin point which one. Thanks.

Edit: I could have sworn GameCube games were working but I guess not. GameCube and Triforce games work from Nintendont directly but when launched through USB Loader GX I just get a black screen.

Edit 2: I updated Nintendont from the Features tab in USB Loader GX and now it seems to be working. Not sure what I did wrong but whatever.
So I kinda narrowed down my issue from before. The version of Nintendont I was originally trying to load was a mod from here (https://send0r.de/MMMod.html). This latest and greatest boot.dol for whatever reason will only boot from the Homebrew Channel and not from USB Loader GX. However, I found an older version of this mod from 2016 on an old drive and tried that out and it worked fine. It's also worth noting that the official boot.dol from Nintendont works fine as well. I have no idea what would cause this new boot.dol mod to not work from USB Loader GX and was wondering if someone can try using it on their setup and see if they get the same results and maybe have any ideas on how to fix it. I posted the same thing in the Nintendont Mod's thread but I know that developer isn't as active anymore and not sure when he will respond. But you can check it out here if interested (https://gbatemp.net/threads/nintendont-themes-and-custom-mods.374469/post-9831469). Thank you.
 

_47iscool

Anti-communist
Member
Joined
Nov 18, 2013
Messages
221
Trophies
0
XP
366
Country
United States
An earlier post mentioned something about RVZ.

Is support for this compressed format going to be added to USB Loader GX for Wii games?

Nintendont could also benefit from this as well, using a bit higher compression maybe due to GC games originally only running on the GC's PPC at 486 MHz though some games produce increased FPS with the Wii's 729MHz PPC like the NFS games.
 

fandango

Well-Known Member
Member
Joined
May 17, 2021
Messages
129
Trophies
0
Age
20
XP
512
Country
United Kingdom
For Wii games ULGX supports wbfs which are quite small, so rvz wouldn't save much space and rvz would open slower as they will have to be decompressed first. I'm not even sure the Wii is powerful enough to decompress rvz, as it doesn't have the power of a PC. But @blackb0x monitors this thread and can consider it.

Nintendont supports nkit.iso, which again are quite small, and again rvz will open slower, although there is a seperate Nintendont thread which would be the place to request gamecube rvz support.
 
Last edited by fandango,
  • Like
Reactions: XFlak
General chit-chat
Help Users
  • No one is chatting at the moment.
    Dark_Phoras @ Dark_Phoras: That's nice. I think by principle we should assume all poetry is bad, so we wouldn't restrict...