USB Loader GX Stuck at loading cIOS 200 on New USB

Discussion in 'Wii - Backup Loaders' started by hunterxandy, Jul 12, 2017.

  1. hunterxandy
    OP

    hunterxandy Member

    Newcomer
    11
    1
    Jul 12, 2017
    Indonesia
    Hi, i recently buy a nintendo Wii from pawn shop, basiclly the shop told me that this usb has already jail broken and give free HHD with copied game inside,
    The problem is, the HDD is toshiba and every 20 min goes to sleeping mode causing game to freeze, i look for a way to solve this but basically all said i need to change my hdd

    So i bought Sandisk Cruzer glide 8GB, Copied some of the game from HDD and a zelda game i just download to USB using Wiibackup manager, the thing is my USB stuck at Loading config, and if i copied the config and apps from HDD it stuck at loading cIOS 200. Is there any way to solve this?

    My wii fw is 4.2 U, the USB Loader GX is at 3.0c, and the homebrew channel 1.1.2 IOS58 v25.32

    And the USB Loader Installed on Wii System menu, and i don't need to launch it from homebrew channel.

    Thank you in advance
     
    Last edited by hunterxandy, Jul 12, 2017
  2. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,594
    8,930
    Oct 27, 2002
    France
    Engine room, learning
    1.
    update your loader.
    3.0c is very old.

    follow this guide :
    https://gbatemp.net/posts/6478222


    2.
    cIOS 200 doesn't exist.
    if it's really "200" and not 249, then you have a problem.
    if it's 249, and it's not working, you need to install the cIOS (nintendo has a dummy (inactive) system file installed in that location, you need to install a working one)

    but first, follow the 1st step.
    if you still need help, I'll give you direction for the second step.
     
  3. hunterxandy
    OP

    hunterxandy Member

    Newcomer
    11
    1
    Jul 12, 2017
    Indonesia
    Thank you for your attention sir,
     
    Last edited by hunterxandy, Jul 12, 2017
  4. hunterxandy
    OP

    hunterxandy Member

    Newcomer
    11
    1
    Jul 12, 2017
    Indonesia
    I try your guide using thumbdrive
    Now i'm at the YAWMM, i unistall the full channel wad, but when i try to install the forwarder WAD i got error code
    instaling content #00 error ( ret = -1022 )

    So i deleted the USB Loader GX in system from wii setting instead, and i copied the newest USB Loader to the thumbdrive, run it from HBC, and get stuck in loading config
     
  5. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,594
    8,930
    Oct 27, 2002
    France
    Engine room, learning
    in YAWMM you are using a cIOS (236 ? 249 ?) or IOS58 with AHB access?
    if you use IOS58 (or AHB, or AHBPROT) you shouldn't have that error.

    That's strange that it's stuck when loading the config, maybe the old config you had in your SD or USB has some incompatible information with the loader launched from HBC, but it's usually not an issue when updating the loader.
    You can try to reset the settings :

    The config file (GXGlobal.cfg) can be located in two different places :
    SD:/config/GXGlobal.cfg (or SD:/options/ I don't remember)
    or
    SD:/apps/USBLoader_gx/GXGlobal.cfg

    If you don't use SD card, then that file is on USB.

    If you want, you can keep a backup instead of deleting it completely, in case you want to recover some settings later.
     
  6. hunterxandy
    OP

    hunterxandy Member

    Newcomer
    11
    1
    Jul 12, 2017
    Indonesia
    Yes it using IOS58, before selecting ios there is a message saying that the AHBPROT is disable, and say to use IOS instead

    Should it be become the problem??

    I launch the loader using a new usb, if im using the old HDD, the loader works, but still have the same sleeping USB problem.
    I tried to copy the HDD config to the USB, but it stuck at "reloading to config file's cIOS ... "

    update:
    I tried syscheck, using using thumbdrive, i got error while saving the data to SD so i just post this picture instead, hope this can help

    photo_2017-07-13_22-12-29.jpg photo_2017-07-13_22-12-05.jpg photo_2017-07-13_22-12-15.jpg photo_2017-07-13_22-12-19.jpg photo_2017-07-13_22-12-23.jpg
     
    Last edited by hunterxandy, Jul 13, 2017
  7. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,594
    8,930
    Oct 27, 2002
    France
    Engine room, learning
    About Wad manager :

    AHBPROT should work if you are using "the homebrew channel 1.1.2 IOS58 v25.32" like you said on your first post.

    in fact, "AHB" is working, as you could noticed syscheck is running with IOS58 (top of the syscheck log).
    AHB is used to get hardware access (NAND access, system file install access, etc.)


    I don't know what to tell you for the wad manager, except :
    1. Did you use the correct version ? THIS version : http://www.hacksden.com/showthread.php/7241-YAWMM-DE-English-Translation/
    2. did you place ALL the files in the folder ? you need the meta.xml too, or else AHB will not work.


    Now about USB Loaders :
    You are missing the correct custom system files used by the USB loaders.

    What you have :
    slot247 and 248 : OLD cIOS (probably Waninkoko rev17 or 20)
    What's strange is that Syscheck didn't detect which cIOS it is. Maybe syscheck 2.4.0 is not the latest version too.

    What you need :

    slot 249 : cIOS d2x v8 final, base 57

    (this alone should work with 99% of games)

    What to do :
    1. download d2x cIOS installer full pack for Wii (not vWii)
    2. create a folder named "d2x_installer" on your SD card:/apps/
    sd:/apps/d2x_installer/
    3. extract the installer inside that folder.
    you should have some files and 3 folders inside :

    sd:/apps/d2x_installer/boot.dol
    sd:/apps/d2x_installer/meta.xml
    sd:/apps/d2x_installer/icon.png
    sd:/apps/d2x_installer/ciosmap.xml
    sd:/apps/d2x_installer/7/
    sd:/apps/d2x_installer/8/
    sd:/apps/d2x_installer/10/

    4. put the SD in your Wii, and launch d2x installer from HBC.
    5. press A until you are on the selection screen. select this :

    What : d2x v8 final
    where : 249
    base : 57 (not 56, it's useless, unless you want to play Spiro with USB gate accessory)
    version : 21008
    Press A to install from internet, wait, wait, done.
    Press Home to exit.

    Now USB Loader is working.
     
    Last edited by Cyan, Jul 13, 2017
  8. hunterxandy
    OP

    hunterxandy Member

    Newcomer
    11
    1
    Jul 12, 2017
    Indonesia
    My wii froze at d2x custom ios installer screen, right when it says press any button to continue

    I do check all installer file, its perfect, and has no error while extracting

    I just notice my wii cant connect to internet because it lock under parental control, and the previous owner doesn't the password
     
    Last edited by hunterxandy, Jul 13, 2017
  9. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,594
    8,930
    Oct 27, 2002
    France
    Engine room, learning
    I think your IOS58 is wrong.
    isn't v6432 the vWii version ?
    syscheck has vWii check disabled on Wii, so we can't tell from the log if it's really the vWii version, but I'm almost sure 6432 is not for Wii.


    you can try to use this :
    http://wiibrew.org/wiki/IOS58_Installer

    it will install an old IOS58 version (not the latest) but it will be the Wii version for sure.


    but it's strange that other homebrew are working fine with that IOS if it was really the vWii version.
    HBC works, syscheck works.


    but other tools using it are freezing :
    Wad manager saying it lost AHB access from 58, IOS installer
     
    Last edited by Cyan, Jul 13, 2017
  10. hunterxandy
    OP

    hunterxandy Member

    Newcomer
    11
    1
    Jul 12, 2017
    Indonesia
    i can't connect to internet, do i need to unlock that first??
     
  11. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,594
    8,930
    Oct 27, 2002
    France
    Engine room, learning
    yes,
    you need internet to install cIOS, or even get the correct IOS58 from that installer.

    1. internet
    2. IOS58 installer
    3. d2x installer
    4. wad manager to delete the full channel (if you still have it) and install the forwarder
     
  12. hunterxandy
    OP

    hunterxandy Member

    Newcomer
    11
    1
    Jul 12, 2017
    Indonesia
    internet is working, already tried installing ios58 3 times, after finished downloading it said installation failed

    Also i notice something strange, when i installing d2x, current Ios is : 58 v6432 , but at HBC it says 58 v25.32
     
    Last edited by hunterxandy, Jul 13, 2017
  13. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,594
    8,930
    Oct 27, 2002
    France
    Engine room, learning
    About your IOS 58 v6432, it's normal HBC gives you a different version.

    6432 is the decimal value.
    in hexadecimal, 6432 = 0x1920, the version is xx.xx (revision, version)
    version 0x20 = 25
    revision 0x19 = 32


    your system file seems broken, maybe that's why that console was sold in the first time, after a broken softmod the user prefered selling it instead of fixing it.
    It should be possible to fix, don't worry. just don't try things without asking here first.

    What you can try is load YAWMM, and instead of telling it to use IOS58 or AHB access, tell it to reload to IOS36, which is patched and has NAND access.

    It seems ALL your IOS have been patched. the previous user probably tried to install CIOSCORP (which was used to patch ALL the system files to allow playing burned CD directly from the Disc channel).

    So :
    I suggest you RE softmod your entire console, this time by using modmii to get ALL the proper, unpatched, IOS files.
    then, you'll have to use a wad manager to install all the downloaded WAD files, don't follow the modmii guide for the wad manager, instead launch yawmm -> reload to 236 (if it's the Wii version, it will work).

    install all the IOS downloaded from modmii



    Maybe you could wait for another user to confirm what I'm telling you, just to be sure.
    I rarely used modmii, and never had to re-softmod an entire console after Darkcorp/CIOSCorp.
    I wouldn't want you to start replacing IOS and being stuck midway with no way to run HBC again.
     
    Last edited by Cyan, Jul 13, 2017
  14. hunterxandy
    OP

    hunterxandy Member

    Newcomer
    11
    1
    Jul 12, 2017
    Indonesia
    okay thanks for u'r response. I think you are right, i remember the seller told me that this wii cannot work with DVD anymore.
    Meanwhile i will download the ios and wait for another response
     
  15. hunterxandy
    OP

    hunterxandy Member

    Newcomer
    11
    1
    Jul 12, 2017
    Indonesia
    I just need to skip to installing wad step right? i dont need to redo from step one, or should i??

    Or do i need to manually remove it first using this guide first? Is that guide still work? I mean is it okay just to reinstall the ios without removing the cIOSCoro/DARKCorp??
     
    Last edited by hunterxandy, Jul 14, 2017
  16. hunterxandy
    OP

    hunterxandy Member

    Newcomer
    11
    1
    Jul 12, 2017
    Indonesia
    As you suggested, I already re softmod my wii, and then try to instal IOS 58, still failed, but i tried the d2x installer and it works perfectly fine, i can load the new thumbdrive with USB loader, and my HHD doesn't freeze anymore in USB Loader, but still can't install the forwarder, i can only run from HBC and everytime i tried to back to wii menu, it freeze with black screen, and i need to hard reset my wii using power button ...

    Is there any step that i miss ??
     
    Last edited by hunterxandy, Jul 14, 2017
  17. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,594
    8,930
    Oct 27, 2002
    France
    Engine room, learning
    when I said you had to skip the wad manager step from modmii it's because it's relying on IOS58+AHB access to install all IOSes.
    So, by using a wad + cIOS236, you can install the WAD without relying on the bad IOS58.

    The channels and forwarders are using IOS58, that's why you can't launch it, nor use the "return to loader" option when exiting a game because it's in fact not returning to the loader but reloading the channel.

    You followed the cIOSCORP remover guide? it's in fact just reinstalling all proper unpatched IOS. But it's installing priiloader first as brick protection, which I didn't ask if you had it. my steps could be dangerous and having priiloader is safer (to an extend, it's not a 100% brick protection)

    You said you could install d2x ? how did you do that? reloading to 236 or 247 maybe, instead of keeping 58+AHB?
    You also said you already re-softmoded your console, what do you mean? You replaced all IOS using modmii's downloaded wad files?

    if you already replaced all the wads, then IOS58 should work.
    so I suspect you didn't successfully replaced nor resoftmodded your console.


    could you post a new syscheck log?
    please, no screenshot, just follow the tutorial in my signature.
     
    Last edited by Cyan, Jul 14, 2017
    hunterxandy likes this.
  18. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    4,189
    809
    Mar 2, 2015
    United States
    It's also worth checking to make sure the meta.xml for your wad mananager has the "<ahb_access/>" tag in it.
     
  19. hunterxandy
    OP

    hunterxandy Member

    Newcomer
    11
    1
    Jul 12, 2017
    Indonesia
    Im not following cioscorp remover guide. Yeah i'm re softmod all wad using modwii, idk what happen but i can d2x, but the return to not working
    So i tried re-install the ios58 wad using YAWMM again, and then instal d2x, and wii works perfectly fine now :D

    Thank you so much Cyan, this forum is blessed to have you as mod :*
     
    Cyan likes this.