USB Loader GX stuck at "Changing USB Port to 1"

Discussion in 'Wii U - Hacking & Backup Loaders' started by cantthink278, Mar 25, 2013.

  1. cantthink278
    OP

    cantthink278 Member

    Newcomer
    18
    0
    Feb 9, 2013
    United States
    Staten Island, New York
    So I recently ordered an external hard drive (self powered) a weekish ago and it finally came. I formatted it in the Wii backup loader and added all WBFS games to it, problem is when I load it up in USB loader GX It just sits at "Changing USB Port to 1" Any ideas how to fix this?

    It basically sits at "Initialize USB Device" than goes to Waiting for HDD , than goes to Changing USB Port to 1 and just sits there. My usb cable is in the back top USB port, I tried the one below it but it doesnt recognize the HDD. Not really sure what to do at this point anymore.

    After going into USB loader and changing it to load both ports or whatever, now its at Mounting USB port to 1 but still no luck getting usb loader gx to load with the hard drive in.


    I used a workaround that I found online, leave my hard drive off until it says looking for harddrive than turn it on. works 100% now
     
  2. metroid maniac

    metroid maniac An idiot with an opinion

    Member
    1,796
    716
    May 16, 2009
    Post once. Go back and edit your post if you have to.
     
  3. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    17,413
    7,997
    Oct 27, 2002
    France
    Engine room, learning
    the port 0 is the one you should use (the bottom one, near the edge)
    It tries to mount port1 because your drive wasn't detected on port0, but the loader being stuck on waiting port1 was a bug.
    It's corrected in r1211
     
  4. cantthink278
    OP

    cantthink278 Member

    Newcomer
    18
    0
    Feb 9, 2013
    United States
    Staten Island, New York
    Even with this new usb loader you gave me, it just sits on loading usb device and does nothing UNLESS i have the hard drive powered off and turn it on while it is searching for the hdd..than it works. would just like to bw able to run usb loader gx without having to power off and on my hdd every time.

    Oh also port 0 does not work. I put the HDD into port 0 and even with the workaround I have been using it just does not detect my HDD at all. Only works in the top back USB slot.
     
  5. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,099
    4,519
    Mar 17, 2010
    Norway
    Alola
    Which cIOS version are you using? Some people suggest using d2x v10 beta 52 (not 53-alt) and that one only supports the bottom USB slot to my knowledge, but supposedly has higher compatibility.
    I use the 53-alt and have had no issues with it, but your mileage might vary.
     
  6. GIngaRanga

    GIngaRanga Member

    Newcomer
    38
    4
    Feb 3, 2016
    Canada
    I have the same issue. After waiting 20 minutes it loads but not my USB HDD only channels. I haven dx2 beta 53 alt and my HDD formatted to FAT32 with 32KB sections. Any help??

    — Posts automatically merged - Please don't double post! —


    I'm also using on a vWii and USB loader v.3 rev. 1256
     
  7. retrofan_k

    retrofan_k GBAtemp Advanced Maniac

    Member
    1,731
    1,048
    May 31, 2013
    Belarus
    Caves
    Bumping this, as no point making a new thread because I have had this issue on my setup for a long while now and could never figure out why it hangs on boot "Loading... Mounting USB Port to 1" screen

    All IOS's up to date including v10 beta53-alt. Nintendont is up to date (V4.442), GX is 1260 revision, so not new but this has happens on older versions.

    2x USB 2.0 drives connected to the Wii (one is a Desktop type and has a separate wall power supply containing Wii games) and the other is a Portable Passport USB HDD (powered by USB only, seperate power is not required) containing GC games.

    Hard Drive Settings:

    Multiple partitions "ON"
    USB Ports = "Both"
    Mount USB at Launch = "ON"

    Custom paths:


    Main Gamecube Path = USB2:/games


    It works for a bit, showing both GC and Wii games in the GX menu, and selecting GC and Wii games load without no problem. However, randomly when exiting a game back to the loader or from a cold boot, I get the hang on the loading screen described above.

    To fix it, I have to remove the drives and reset GX settings and then add the drives again, which is getting annoying.

    I don't know if this could be my drives, yet they work independently on their own with (one drive for GC games with Nintendont and the other with GX for Wii games. It's only when both are connected this problem occurs.

    @Cyan
     
    Last edited by retrofan_k, May 18, 2017