USB Loader GX shows Games but returns to Wii Menu when starting them

Discussion in 'Wii - Backup Loaders' started by toastking, Sep 17, 2016.

  1. toastking
    OP

    toastking Newbie

    Newcomer
    4
    0
    Sep 17, 2016
    Gambia, The
    Hi guys,

    I really hope some of you experts will be able to help me with this!

    I have installed the Homebrew channel on my Wii U using Super Smash Bros.
    After that, I installed USB Loader GX without encountering any problems.

    I can start the Homebrew channel as well as the USB Loader GX without errors.

    I've put Mario Party 8 on a 16GB USB drive in [Drive]:\wbfs\ (as a wbfs file, tried it with and without a subfolder for the game - which one is correct?). USB Loader GX recognizes the game and even downloads the cover. It can't display game details when pressing button 2 due to some missing file though.

    My main problem is that I'm unable to start the game. Every time I try, it seems for a second that the game is being loaded, but it just goes to a black screen for a second and then goes back to wherever USB Loader GX was started from, i.e. either the Homebrew channel or the main Wii menu.

    In order to exclude errors resulting from a faulty Mario Party 8 game image, I tried ripping the original Super Smash Bros game disc with Loader GX to the USB drive. This seems to work just fine for a few seconds, but the screen gets completely stuck at 0.37% every time. The console is gone from this moment on. The screen keeps showing the GX loader status screen with the percentage, but I'm only able to turn off the console or abort the whole thing by plugging the power cord. Even pressing the power button for a few seconds has no effect.

    So... what have I done wrong? :(
    Here's my SysCheck report.

    Thank you so much!

    Warning: Spoilers inside!
     
  2. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    4,280
    823
    Mar 2, 2015
    United States
    Flash drives aren't that reliable on Wii. Try it with an actual HDD.
     
  3. toastking
    OP

    toastking Newbie

    Newcomer
    4
    0
    Sep 17, 2016
    Gambia, The
    Thanks GreyWolf,
    this has solved the problem at least partially. I am now able to rip the Smash Bros Disc to the HDD and start it afterwards.
    However, I'm still unable to start Mario Party 8 which I haven't ripped using Loader GX before but instead directly put the wbfs file on the hard drive using Windows Explorer. The first time I tried to start it from the HDD the Wii went to a black screen and then froze (had to plug the cord), after a reboot it went back to the behavior where it just returns to the Wii main menu (or the Homebrew channel if I started Loader GX from there).

    How do I best approach this?

    This is my dir structure on the hard disc (sorry, it's in German, but should be understandable either way):

    Dir J:\

    19.09.2016 12:29 0 dir.txt
    19.09.2016 09:26 <DIR> wbfs
    1 Datei(en), 0 Bytes

    Dir J:\wbfs

    19.09.2016 09:26 <DIR> .
    19.09.2016 09:26 <DIR> ..
    19.09.2016 09:22 <DIR> Mario Party 8 [RM8P01]
    19.09.2016 12:18 <DIR> Super Smash Bros. Brawl [RSBP01]
    0 Datei(en), 0 Bytes

    Dir J:\wbfs\Mario Party 8 [RM8P01]

    19.09.2016 09:22 <DIR> .
    19.09.2016 09:22 <DIR> ..
    05.03.2013 19:29 3.544.186.880 MarioParty8.wbfs
    1 Datei(en), 3.544.186.880 Bytes

    Dir J:\wbfs\Super Smash Bros. Brawl [RSBP01]

    19.09.2016 12:18 <DIR> .
    19.09.2016 12:18 <DIR> ..
    19.09.2016 12:10 2.950.725.632 RSBP01.wbf1
    19.09.2016 11:58 4.294.934.528 RSBP01.wbfs
    2 Datei(en), 7.245.660.160 Bytes

    Anzahl der angezeigten Dateien:
    4 Datei(en), 10.789.847.040 Bytes
    9 Verzeichnis(se), 1.489.272.147.968 Bytes frei

    — Posts automatically merged - Please don't double post! —

    Nevermind - I fixed the issue by renaming the wbfs file of Mario Party 8 to RM8P01. This was obviously my fault.
    Thanks again for your help!
     
  4. toastking
    OP

    toastking Newbie

    Newcomer
    4
    0
    Sep 17, 2016
    Gambia, The
    I'm still having trouble with a few games. Most of them work just fine, but some won't show the preview before launching the game and when trying to launch them will reset me back to the Wii menu after showing the 9 'loading' boxes. One of these games is Just Dance 2016 (I've tried setting iOS to 250). Other examples include super Mario galaxy 2 and raving rabbids 2. GX shows these games on the list but I can't start them no matter what I try. Could you please check my sysreport at the top again? Is everything alright with my setup?
     
  5. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,531
    5,475
    Mar 17, 2010
    Norway
    Alola
    If the banner isn't showing up, it's probably a bad/corrupted dump, try another one.