USB Loader GX resets to Wii menu when launching game

Discussion in 'Wii - Hacking' started by Europe, Sep 10, 2013.

  1. Europe
    OP

    Europe Newbie

    Newcomer
    2
    0
    Sep 10, 2013
    Canada
    I'm really noobish to all this Wii hacking, so please try to make things simple.

    I had a friend hack my Wii a few years back, it was working fine until I stopped using it for 2-3 years.. I got a new External Hard Drive, reformatted to WBFS etc etc. I run it with the Wii, the USB Loader resets to the menu. I recently reinstalled a lot of the files onto the SD card I'm using due to that conundrum, and nothing fixed it. I also did a bit of research into this, tried the many fixes I found..Nothing still. I threw sysCheck on it and this is the result:
    sysCheck v2.1.0b19 by Double_A and R2-D2199
    Nano
    ...runs on IOS58 (rev 6176).

    Region: NTSC-U
    System Menu 4.2U (v481)

    Drive date: 2006.09.07
    Homebrew Channel 1.1.2 running on IOS58
    HomebrewFilter ist nicht installiert
    Hollywood v0x11
    Console ID: 40273835
    Boot2 v4
    Found 79 titles.
    Found 38 IOS on this console. 12 of them are stub.

    IOS4 (rev 65280): Stub
    IOS9 (rev 778): No Patches
    IOS10 (rev 768): Stub
    IOS11 (rev 256): Stub
    IOS12 (rev 269): No Patches
    IOS13 (rev 273): No Patches
    IOS14 (rev 520): No Patches
    IOS15 (rev 523): No Patches
    IOS16 (rev 512): Stub
    IOS17 (rev 775): No Patches
    IOS20 (rev 256): Stub
    IOS21 (rev 782): No Patches
    IOS22 (rev 1037): No Patches
    IOS28 (rev 1550): No Patches
    IOS30 (rev 2816): Stub
    IOS31 (rev 3608): No Patches
    IOS33 (rev 3608): No Patches
    IOS34 (rev 3608): No Patches
    IOS35 (rev 3608): No Patches
    IOS36 (rev 3608): No Patches
    IOS37 (rev 3869): No Patches
    IOS38 (rev 3867): No Patches
    IOS50 (rev 5120): Stub
    IOS51 (rev 4864): Stub
    IOS53 (rev 5406): No Patches
    IOS55 (rev 5406): No Patches
    IOS56 (rev 5405): No Patches
    IOS57 (rev 5661): No Patches
    IOS58 (rev 6176): USB 2.0
    IOS60 (rev 6400): Stub
    IOS61 (rev 5405): No Patches
    IOS70 (rev 6687): Trucha Bug
    NAND Access
    IOS202[38] (rev 4
    Info: hermes-v4.0): Trucha Bug
    ES Identify
    NAND Access
    USB 2.0
    IOS222 (rev 65280): Stub
    IOS223 (rev 65280): Stub
    IOS249 (rev 65280): Stub
    IOS250 (rev 65535): Trucha Bug
    ES Identify
    NAND Access
    USB 2.0
    IOS254 (rev 65281): BootMii
    BC v6
    MIOS v10


    I can tell something is probably wrong from all the stubs..
    Please help.
     
  2. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,029
    8,551
    Oct 27, 2002
    France
    Engine room, learning
    you need to install custom IOS to replace the "stub" in slot 249 and 250.
    To install custom IOS, there are two methods :
    - use a cIOS installer (cIOS d2x installer + install guide + help choosing a version)
    or
    - use a Wad manager (use modmii to download the wanted cIOS as wad files, and use a manager to install them on Wii)
     
    LegendaryOutcast likes this.
  3. Europe
    OP

    Europe Newbie

    Newcomer
    2
    0
    Sep 10, 2013
    Canada
    Huge thanks! Got it to work with the installer!
     
  4. MelvinVargas

    MelvinVargas Newbie

    Newcomer
    1
    0
    Apr 23, 2015
    United States
    Fort Myers, Florida
    I am having similar Issues on several games I try to run them using USB Loader GX and all it does is take me back to the main WIi menu Ive Installed the D2X V8 Final thru cIOS d2x installer in homebrew channel followed all base and slots and Im still encountering this is issue any help would he helpful please and thank you in advance


    my system is 4.3U
     
  5. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,029
    8,551
    Oct 27, 2002
    France
    Engine room, learning
    You are launching the loader from HBC or from the channel?
    If you launch from the channel, there are two possibilities :

    1- You installed the Full channel, but you don't have IOS58 (but if you are on 4.3U, you have IOS58 so it's not the issue for you)
    2- You installed the forwarder, but without placing the actual loader's files on your SD card. The forwarder doesn't have the loader's program in it. it only redirects (reloads/forwards) to the actual program located on SD or USB.

    you need to extract the loader's revision release (you can find in my signature) in /apps/usbloader_gx/ folder

    3- You installer the forwarder, but placed the boot.dol on a different path than the expected one.
    You need to be sure the path to the boot.dol is SD:/apps/usbloader_gx/boot.dol or USB:/apps/usbloader_gx/boot.dol

    If you have the forwarder+boot.dol correctly installed, I don't know.
    Try launching from HBC.
    If it reset to system menu when launching from HBC, try downloading/extracting the loader files again.