Hacking Homebrew USB Loader GX Multiple WiiWare Channel Issues in EmuNAND (vWii)


New Member
Jun 27, 2022
EDIT: Blackscreen Issue fixed, now there is only the EmuNAND issue.

So I have a bunch of WiiWare Channels on my vWii that I want to run via an EmuNAND, since the regular NAND does not have enough space for them. I can run some of them via the NAND perfectly fine through USB Loader GX, and when I move them to the EmuNAND they are perfectly fine as well. But once I remove those Channels from the NAND they are no longer runnable from the EmuNAND. Directly putting them onto the EmuNAND also doesnt work. When the channel is directly put onto the EmuNAND, without being on the NAND first and when I put it onto the NAND and directly move it from there to the EmuNAND, its displayed as an empty Channel with the NEW Icon. Running that channel brings me to the HBC. If I have the Channel on the NAND first, run it while its on there, and then move it onto the EmuNAND, it kicks me to the vWii Home Menu. This works this way for some games like Driift Mania. However others like Bonsai Barber dont even run at NAND and its just a blackscreen. None of them work completely as intended.
Both of these issues are common, as I can see, however after scavenging the internet for a solution for either, nothing is working. So i am sorry that there is another one of these, but not a single one of them helped. I would like to have all WiiWare Channels runnable through the EmuNAND, without having them in the NAND so that I dont have to move them around from and to the SD card. That can get pretty annoying with around 70. I could remove the VC titles, however that would not fix the general problem and its still too much for the NAND. If that isnt possible I want them to at least be runnable, which not all of them are.

So since I dont want everything to be repeating from all those other topics that in the end, didnt help me, here is a list of all things I already tried and how things are. Will update it if more things come up:
(Syscheck is mostly in German, but everything should be understandable, I hope.
SysCheck HDE v2.4.0 HacksDen Edition von JoostinOnline, Double_A, R2-D2199, und Nano
...laeuft auf dem vIOS58 (rev 6432).

Region: PAL
Systemmenue 4.3E (v610)

Laufwerksdatum: 12.07.2012
Homebrewkanal 1.1.2 benutzt IOS58

Hollywood v0x21
Konsolen-ID: XXXXX
Konsolentyp: vWii
Shop-Kanal-Land: Germany (78)
Boot2 v0
Es wurden 95 Titel gefunden.
Es wurden 35 IOS gefunden, von denen 0 funktionslos (Stub) sind.

vIOS9 (rev 1290): Keine Patches
vIOS12 (rev 782): Keine Patches
vIOS13 (rev 1288): Keine Patches
vIOS14 (rev 1288): Keine Patches
vIOS15 (rev 1288): Keine Patches
vIOS17 (rev 1288): Keine Patches
vIOS21 (rev 1295): Keine Patches
vIOS22 (rev 1550): Keine Patches
vIOS28 (rev 2063): Keine Patches
vIOS31 (rev 3864): Keine Patches
vIOS33 (rev 3864): Keine Patches
vIOS34 (rev 3864): Keine Patches
vIOS35 (rev 3864): Keine Patches
vIOS36 (rev 3864): Keine Patches
vIOS37 (rev 5919): Keine Patches
vIOS38 (rev 4380): Keine Patches
vIOS41 (rev 3863): Keine Patches
vIOS43 (rev 3863): Keine Patches
vIOS45 (rev 3863): Keine Patches
vIOS46 (rev 3863): Keine Patches
vIOS48 (rev 4380): Keine Patches
vIOS53 (rev 5919): Keine Patches
vIOS55 (rev 5919): Keine Patches
vIOS56 (rev 5918): Keine Patches
vIOS57 (rev 6175): Keine Patches
vIOS58 (rev 6432): USB 2.0
vIOS59 (rev 9249): Keine Patches
vIOS62 (rev 6942): Keine Patches
vIOS80 (rev 7200): Keine Patches
vIOS236 (rev 65535): Trucha Bug, ES Identify, NAND Zugriff
vIOS249[56] (rev 21010, Info: d2x-v10beta52-vWii): Trucha Bug, NAND Zugriff
vIOS250[57] (rev 21010, Info: d2x-v10beta52-vWii): Trucha Bug, NAND Zugriff
vIOS251[58] (rev 21010, Info: d2x-v10beta52-vWii): Trucha Bug, NAND Zugriff
vIOS512 (rev 7): Keine Patches
vIOS513 (rev 1): Keine Patches
Bericht wurde am 27.06.2022 generiert.
  • I have 128GB SD Card and a 2TB HDD (Not a Flash Drive), both formatted in FAT32. The HDD is correctly inserted using a Y-Cable. This is apparent, because plugging it in the other way around makes the HDD undetectable by USB Loader GX. The HDD was specifically formatted with the WiiBackupManager. Both of them are new, freshly bought and I have not detected any issues with them in particular.
  • I have redownloaded all cIOS you can see in the syscheck after the problem occured. Also using a different Slot via Game Load does not fix the issue.
  • The Credits Page of the USB Loader GX gives me the following information:
    • Nintendont v6.498
    • Rev1272
    • IOS249 (Rev21010) + AHB
    • d2x v10beta52.vWii base 56
  • I have checked if the wads are broken or something. They work in Dolphin. Dont know if there is a seperate way to test for vWii.
  • Tried to do EmuNANDs via Neek before trying it with USB Loader GX, but it worked even less.
  • The EmuNAND and its folders are on the USB Drive.
  • When the blackscreen occurs, the WiiMote is turned off, and cannot be turned on again. It will blink when a button is pressed, but does not connect. It is impossible to shutdown the console via the button and I have to unplug the entire console.
  • I have reset the settings of USB Loader GX, nothing changed.
  • I dont see what the games that kinda work and those that dont work at all, have in common with each other. Its definetly not the region thats causing the issues, as Driift Mania and Excitebike are runnable and they are NTSC U, just as the rest. If a complete list of which games work and which dont is helpful, I could do that, but that would take a lot of time, as the NAND doesnt have much space and everytime a game doesnt work, I would have to unplug the console and reboot it over and over again, which cant be healthy for the console.
  • Changing the video mode did not fix it.
  • I am not using UStealth.

Thats It. As you can see, I tried a bunch, and Im just frustrated. Most of these, when searching for these problems seem to fix them, but not for me. I already am searching for solutions for hours.
If someone has any idea what could be the problem, or have a solution or an alternative I would be grateful.
Last edited by Enzo959,


New Member
Jun 27, 2022
Now a few days later, I have managed to fix the Blackscreen Issue. It was due to my European WiiU and the games being NTSC games. I dont know why it didnt have this problem for all games though, as all of them were NTSC. I used the following Settings to fix it:
Video Mode: Force NTSC
DOL Video Patch: Region Patch
480p Pixel Fix Patch: On
VIDTV Patch: On
Game Language: English.
All but 2 games work completely fine now. I think the last 2 were just bad wads or something. It could probably still work if I use less Settings, for example just Force NTSC or Force NTSC and Game Language English. However having them all on these settings worked for me.

Now the Blackscreen issue is fixed, I however still cannot play them from the EmuNAND if they arent on my NAND, which I would still like fixed, if possible.

Popular threads in this forum

General chit-chat
Help Users
    Bunjolio @ Bunjolio: a