Hacking USB Loader GX just does not find my USB stick anymore

Pacheko17

Controversial opinions guy.
OP
Member
Joined
Jan 31, 2015
Messages
1,485
Trophies
1
Location
República Juliana
XP
1,756
Country
Brazil
It just never works with it, I can try unplugging and plugging it back in and just nothing.

It's the same USB stick I've been using for years on USBL GX, I have not changed my IOS's, have not changed anything in the console whatsoever besides updating USBL GX some time ago.

Emulators and other homebrew still detect the stick and it works fine with them, with the exception of Wiiflow, where my games show up but won't start. CFG USB Loader also isn't working, and the error message font is white so I also can't read it.

I'm just simply not able to play my Wii games at the moment, nor my emunand Wii games because no loader is working properly, but I just want to focus on USBL GX since that's the best imo.

I've tried changing the loader's IOS, tried 200, 249, 250, 251 and 252. I tried reinstalling IOS 249 and 250 from Waninkoko's guide as well but nope, nothing, it just tells me there's nothing there.

It's 11:30pm, I'll sleep now, I've been trying to get this working for hours now.
 

DaTank45

Well-Known Member
Member
Joined
Aug 18, 2017
Messages
416
Trophies
0
Age
40
XP
294
Country
United States
Do not use a usb stick. These can cause unforeseen and random issues. They are not recommended ever. Use a hard drive and be done with it.
 

Cyan

GBATemp's lurking knight
Former Staff
Joined
Oct 27, 2002
Messages
23,512
Trophies
2
Age
43
Location
Engine room, learning
XP
14,754
Country
France
You tried every IOS slots, except the correct one, aren't you?
Settings > loader's settings > Loader's IOS : 58



Of course, it will only help while you are inside the loader.
Like Wiiflow, it will list the game, but upon launching one the loader will reload to cIOS and flash drives are not compatible with cIOS, that's why you can't launch games, only "see" them.

At best, your flash can be used with homebrew using IOS58 (emulators, nintendont, media player). But, you just risk losing all your data by using this flash in write mode. (saving savegames on a flash drive is like begging for device corruption! Maybe you love living with risk)
 
Last edited by Cyan,

Pacheko17

Controversial opinions guy.
OP
Member
Joined
Jan 31, 2015
Messages
1,485
Trophies
1
Location
República Juliana
XP
1,756
Country
Brazil
You tried every IOS slots, except the correct one, aren't you?
Settings > loader's settings > Loader's IOS : 58



Of course, it will only help while you are inside the loader.
Like Wiiflow, it will list the game, but upon launching one the loader will reload to cIOS and flash drives are not compatible with cIOS, that's why you can't launch games, only "see" them.

At best, your flash can be used with homebrew using IOS58 (emulators, nintendont, media player). But, you just risk losing all your data by using this flash in write mode. (saving savegames on a flash drive is like begging for device corruption! Maybe you love living with risk)

I tried setting it to 58 but it changes the number back to 200. I can't set it to 58.
I really don't know what the heck is going on because it was working normally just a week ago. I'm not aware of any risks, I've been doing things the same way I've always done them.
 

Pacheko17

Controversial opinions guy.
OP
Member
Joined
Jan 31, 2015
Messages
1,485
Trophies
1
Location
República Juliana
XP
1,756
Country
Brazil
Nevermind, I got it working. Ran ModMii and installed all the wads it suggested. It's working fine now. I guess something must have happened but I have no idea what.

Thanks either way.
 
  • Like
Reactions: Cyan

Cyan

GBATemp's lurking knight
Former Staff
Joined
Oct 27, 2002
Messages
23,512
Trophies
2
Age
43
Location
Engine room, learning
XP
14,754
Country
France
the "game's IOS" can't be lower than 200 (because games can't load from USB using official IOS, it needs custom IOS which are installed above slot 200)
the "Loader's IOS" can be 58, or anything above 200. If it didn't allow you to set 58 for loader's IOS, then it means your loader is outdated. maybe you have a mixed channel, forwarder and dol version?

guide to update and replace the full channel with forwarder channel : https://gbatemp.net/posts/6478222 (just in case)
 
  • Like
Reactions: Pacheko17
General chit-chat
Help Users
    Julie_Pilgrim @ Julie_Pilgrim: like bro do something different, get some men