USB Loader GX freezing for every second EmuNand game.

Discussion in 'Wii - Backup Loaders' started by WeWeeWii, Oct 26, 2014.

  1. WeWeeWii
    OP

    WeWeeWii Newbie

    Newcomer
    4
    0
    Oct 26, 2014
    I'm having an odd problem with USB Loader GX.
    (Credits screen says v3.0 IOS247 rev 21006 d2x v6 base57)
    I have it autobooting into USB Loader GX through priiloader.
    I have WBFS, EmuNand and apps on a powered harddrive, with no SD card inserted.

    Every second time I start any EmuNand game, the screen goes black, but after resetting, the same game works fine without any changes.
    It happens pretty consistently, so it's getting a little annoying to have to hold down the reset button between games.
    I thought I could side-step the problem by simply powering off between each game, but I was quite surprised to find that even disconnecting the power doesn't stop it freezing when starting another EmuNand game.

    Facts I've gathered through attempting to find the cause:
    *After freezing, the next EmuNand game always works fine, once.
    *Only seems to happen with EmuNand games.
    *I just started 10 different WBFS games in a row without a problem, but it may occur with some.
    *Playing a WBFS game, or 3, then starting an EmuNand game works fine, once.
    *Playing an EmuNand game, then a WBFS game, then an EmuNand game doesn't work.
    *Doesn't seem to matter if they've been played before or not.
    *Disconnecting power between EmuNand games doesn't stop it occurring. Neither Soft nor Hard Power off stops the next game freezing.
    *Some EmuNand games aren't effected. (But I didn't note which ones never froze, sorry.)
    *All EmuNand games I have tried have worked fine after a freeze, so this is not an issue with any individual game.

    I've searched, but could not find anyone reporting anything which matches this problem - the only other similar problems I could find either involved specific games never loading, or all games never loading - which does not match what is happening to me.

    My questions:
    *Is this a known problem?
    *Does this happen to everyone?
    *Is there any way to avoid it?
    *Do you need any additional information?

    sysCheck GX
     
  2. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,269
    8,744
    Oct 27, 2002
    France
    Engine room, learning
    Hi,

    This is a very strange problem.
    I don't think I understand what you mean by "it works again after reseting" because you said that even soft or hard power off doesn't help.
    How to you reset a game to make it work again?


    *Is this a known problem? It's the first time I see this report/issue.
    *Is there any way to avoid it? probably, as it works fine for other users.

    When we are confronted with a new issue, we process it by steps to remove and narrow possibilities. (hardware, software, loader version, etc.)

    1- always update to latest revision/version of the loader.
    You are currently using 3.0 (r1180, which is not the latest revision). Update to r1231, you can use the internal update menu or find a boot.dol in my signature.


    - You said the game is good (and I think it is too, as it launches).
    - verify your files are not write protected (it seems to affect game launching with Wii games)
    - try with another Wii (if you can). Use your same device and setup but on another wii. If it's doing it again, the issue is not the wii but the setup.
    - test another EmuNAND dump (one from your wii or a clean one)
    - test another Drive (USB or SD)
    - try to put the EmuNAND in another path (it's on the root or in a subfolder?)
    - try to run the loader from HBC instead of Priiloader autoboot
    - try to install the forwarder.dol instead of the loader's boot.dol in priiloader (you can find forwarder.dol in "all in one" package, in wad/dol/ folder)
    - try to update cIOS d2x to at least v8 (you currently are using v6)
    - if your EmuNAND is on the root of the first partition, you can try to set the cIOS slot to 249 (to use rev17 instead of d2x); but it shouldn't be a problem, d2x v8 or newer is known working.

    that's few thing you can test.
    each test will allow you to see if the issue is the drive or not, if it's the cIOS or not, if it's the EmuNAND path or not, etc.
     
  3. WeWeeWii
    OP

    WeWeeWii Newbie

    Newcomer
    4
    0
    Oct 26, 2014
    Sorry about the confusion: a reset or power off after a game successfully loads doesn't prevent the NEXT game freezing.

    To hopefully make things clearer, here's a step-by-step:

    1. Start any EmuNand game (1) - Works fine.
    2. Go back to menu without power off.
    3. Start any EmuNand game (2) - Black screen/freeze/no response
    4. Hold down power for 10 seconds or disconnect power.
    5. Start any EmuNand game (3) - Works fine.
    6. Go back to menu without power off.
    8. Start any WBFS game - Works fine.
    9. Go back to menu without power off.
    10. Start any EmuNand game (4) - Black screen/freeze/no response
    11. Hold down power for 10 seconds or disconnect power.
    12. Start any EmuNand game (5) - Works fine.
    13. Reset wii, power off wii or disconnect power (with or without exiting the game first)
    14. Start any EmuNand game (6) - Still black screen/freeze/no response

    Step 13 is what I meant, attempting to pre-empt the next game freezing by powering the wii off first doesn't prevent the freeze from happening when the next EmuNand game is started. Playing another WBFS game before step 14 doesn't prevent it and it doesn't matter whether it's the same game or a different game.

    So in other words:
    *odd = fine,
    *even = black freeze
    and absolutely nothing changes that.
    ----
    Thanks, I didn't realise it wasn't the latest version, I'll try each of those steps and get back to you.
     
  4. WeWeeWii
    OP

    WeWeeWii Newbie

    Newcomer
    4
    0
    Oct 26, 2014
    (I set my wii up myself, first in 2010, then updated in 2012, then updated a few months ago - each time, I read a bunch of tutorials repeatedly for a week, downloaded a whole bunch of stuff, worked out what I need to do, step by step, then did it, then promptly forgot everything I learned, so even though I've done all of this three times, I'm still a n00b right now, sorry. I forgot so much that I was unaware I updated in 2012 until I found a second nand backup from 2012 just now.)

    First test: changed Priiloader to load System Menu.
    *Loading USB Loader GX from channel still caused the freeze.
    *Loading USB Loader GX from HBC still caused the freeze.

    Just for kicks, I started a real Nand game from USB Loader GX and it didn't freeze. But that didn't surprise me, and it also didn't surprise me that it didn't prevent the next game from freezing. (Order: EmuNand game Good, RealNand game Good, EmuNand game Fail) What did surprise me was that when I exited a real Nand game, it took me back to USB Loader GX, but exiting a EmuNand game took me back to the System Menu.
    ----
    Downloaded R1231_IOS222-249-250.7z and extracted it, but I have no idea what to do with the files, and googling didn't help me.
    edit: Found instructions

    Downloaded d2x-v8-final.zip and d2x cIOS Installer v3.1.zip, then discovered they were both already on my SD card.
    ReadMe.txt for "cIOS d2x v8 final" says "Launch the Homebrew Channel, start the installer and follow the instructions on the screen"
    The instructions on the screen say "Press A to install", but I'm unsure whether I'm supposed to change anything before I do that.
    I changed it to d2x-v8-final, pressed A, highlighted the flashing 249, pressed A, then it said it failed, so I'm obviously doing something wrong.
    (Edit: Finally found instructions that mentioned changing Base to 56 - did that, and it installed successfully.)

    Other info:
    * I have a single powered USB drive with two partitions: 1: Fat32, 2: WBFS
    * All games I'm testing with launch fine - every second time.
    * Did "attrib -r *.* /s", so no more read only files if there were any - no change.
    * No other wii available.
    * I am using the forwarder.dol in priiloader.
    * Did have EmuNand in usb1:/nand/ - now moved to root... no change.
    * Currently, loading a game with "Boot/Standard" set to "IOS 249" says "only works on d2x cIOS, change game IOS to a d2x cIOS first" - both with the EmuNand in usb1:/nand/ and usb1:/

    I'll make a new Nand dump now.

    edit: The new Nand dump seems to do the same thing. I was really hoping that would fix it.
    BTW, I've found that "And Yet It Moves" never freezes, so i can repeatedly start AYIM over and over, but the next game after AYIM will freeze. Or, I can play another game, then start AYIM successfully.
    Meanwhile, Ant Nation and AquaSpace are consistently reproducing the bug.

    I'll continue testing, to make sure nothing has changed.
    ----
    Edit: After figuring out how to update things, credits screen now says: rev1231 IOS249 (rev 21008) + AHB (d2x v8final base56)

    Result1: old EmuNand, starting AquaSpace twice has triggered the usual black screen freeze.
    Result2: new EmuNand, attempting to return to the menu from the first instance of AquaSpace has frozen on a black screen. (Repeated again after holding down the power button.)
    Result3: new emuNand, changed game IOS to 249, AquaSpace both returns to the menu, and restarts fine! Tested a few games, and they all return and start fine without freezing so far.

    After returning to the menu, Credits screen now says: 3.0c IOS249 (rev 21008) (d2x v8final base56), which I assume is because the old channel is being loaded and isn't a fowarder. I've now changed "Return to" to "off", which returns to the main usb loader gx splash screen instead of the usb loader gx loading screen.

    Is "USB Loader GX-UNEO_Forwarder_3_0_AHBPROT.wad" the appropriate forwarder channel to use? Is there a faster way to return to the usb loader gx menu when exiting a game?
     
  5. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,269
    8,744
    Oct 27, 2002
    France
    Engine room, learning
    Thanks for all the tests you did and information you provided.
    Like you said, it's strange that exiting emuNAND doesn't return to the loader. When I'm launching a channel on emuNAND it correctly exit back to the loader (if you have "return to" setting set to return to loader).

    I see your result3 is good :)
    So it was related to the cIOS (your slot247 had d2x v6 and slot249 had rev17, now if you installed d2x v8 base56, it's all good!)
    Some N64 games will require rev17 or rev19, and it require the path to be on the root of the first partition of the drive. Maybe your drive is WBFS+FAT32 instead of FAT32+WBFS?
    If it's FAT32 first, it should have work with the NAND path on root + rev17. But, it's not important for now. If someday you need more help with N64 games I'll help you again.


    For your questions:
    1- 3.0c (with the letter C) means it's launching the Full channel version. You can uninstall it (use a wad manager, put the wad of the full channel on your SD, select it in the manager and pick "uninstall" instead of install).

    2- install the forwarder channel. the latest version of the forwarder is 5.1
    http://usbloader-gui.googlecode.com/files/USB Loader GX-UNEO_Forwarder_5_1_AHBPROT.wad
    (this is the wii version. don't try it on vWii. I'm putting this warning for other users finding this thread randomly and thinking it's a good idea to test it).

    3- Go back to the loader, and you can select the new channel as "return to".


    I think you can use Priiloader to return to the loader too.
    if you set priiloader to load the installed dol file, it should always launch it when a game or a homebrew try to load the system menu.
    There's an option in USBLoaderGX > parental control, to disable this behavior and be able to load the real system menu even if you set priiloader to load the installed dol.

    if return to the loader doesn't work, try to switch the priiloader option in USBLoaderGX>parental control menu.


    It's better to "return to forwarder" than return to system menu (replaced by priiloader).
    The load time is the same. the forwarder channel has AHB access granted automatically.
     
  6. WeWeeWii
    OP

    WeWeeWii Newbie

    Newcomer
    4
    0
    Oct 26, 2014
    It seems like it was all things together causing it, because even now, switching back to the old EmuNand is rebooting back into USB Loader on every second game. (I currently have them in usb:/nand1/ and usb:/nand2/ - but I'll keep it in mind if I run into problems.)

    I triple checked using acronis disk director, and the fat32 partition is definitely first. (The nand folders are in the fat32 partition, in case that was unclear.)
    But like you said, not important now, since it's working. Anyone else who runs into the same problem should be able to solve it with a cIOS update and a fresh nand dump.

    Thanks for the forwarder channel, installed and all good now. (Had to update to WadManager 1.7 because WadManager 1.5 wasn't working.)

    I've configured Priiloader to load the forwarder5.1.dol, and return to it. Also set "Return to" in "Loader settings", which saves a few extra seconds.
    I found I already had a "249c.dol" in the root of my SD card, I must have installed that instead of the forwarder last time and not realised.

    new sysCheck
    Is there anything else I should update while all of this is still fresh in my mind?

    Now that it's returning from games successfully, I'm going to go through all the games I have and verify they're all working. I'll get that done within the next couple of days - is there any place in particular I should share a list of "These games are confirmed working"?


    Edit: 2014-11-02 - still working on that list.
    * Deep Space Extraction failed to create save, and now freezes when trying to load.
     
  7. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,269
    8,744
    Oct 27, 2002
    France
    Engine room, learning
    I'm glad you got everything fixed now.

    For the cIOS:

    I don't know what is currently installed in your slot 250 (there's no report of its base or version).
    I guess it's a clone of rev17 (that you had on slot249) because the rev17 installer is installing a clone of itself in slot250 with maxed out version.
    Rev17 could be used for some channels, but users noticed that rev19 had better results for N64 games.

    If for the moment you don't need rev17/rev19, you can install this (this is the common bases/slots used by all users):

    d2x v8 base 57 in your slot 250.
    The only "base57" you have is an old cIOS (v6).
    Most games work with base56 (your slot249), but few games require base 57 (call of Duty for example).

    That should be enough for most Wii games and Wiiware.
    only Virtual console could have issues.



    There's currently no place to report working or not working channels.
    A lot of users are asking for such a list, that could be a good idea to note the non working games and the setup you tried to fix them (another/older cIOS version or sneek).

    You can report here, and I'll keep that list somewhere for myself.
    Or you can also report it on a Wiki page.

    for example: http://wiki.gbatemp.net/wiki/Wii_EmuNAND_Channel_Compatibility_List

    name | region | nand loader (used by USBGX/triiforce/mightychannel) | neek (used by sneek/uneek/neek2o) | comment
    Castlevania | PAL | no | yes | require neek
    N64 game | PAL | yes | yes | require rev19 base 38 when launched with NAND loader.


    if you don't want to make a complete list, just tell me which games work/doesn't work with d2x v8 ;)
     
  8. Poglodyte

    Poglodyte Member

    Newcomer
    13
    5
    Jan 3, 2016
    United States
    Ok so I'm finally going to ask for some help here, been trying to get wiiware/vc games to running on hdd forever... I have wii and gc games working (mostly)

    I thought neek2o was the best option since it has the highest compatibility, but I'm about done with trying that. It seemed to work for a second, until I added 700 some wads. I used this mega noob guide https://ccabz.wordpress.com/2013/01/16/neek2o-for-mega-noobs/ with the supplied US region nand. If I do end up trying neek2o again, is there a premade nand out there with the latest neek2o version? or an easy way to update that premade nand?

    For now though, I think I'd be perfectly fine with just the cios nand emulation. I've tried it through wiiflow and now usbloadergx (which I like somewhat better), but neither method will actually launch any of the wiiware/vc games... just hangs and goes back to menu (whatever autoboot is set to in priiloader I think).

    I'm wondering if the issue is cIOS versions? I used the d2x cIOS installer to update the ones on my real nand (per this guide https://sites.google.com/site/completesg/backup-launchers/installation), and made my emunand after that with the extract options in both wiiflow and then usb loader gx.

    Does anyone have suggestions as to what the problem could be? Do you think I just need a different cIOS, or just need to set wiiflow or usbloader gx to use the right one?

    Hopefully I supplied enough info. If not, just let me know what else would be helpful. Thanks for reading!