USB Loader GX freezes reading HDD, but works if HDD is plugged in during countdown

Discussion in 'Wii U - Hacking & Backup Loaders' started by regnad, Jun 25, 2019.

  1. regnad
    OP

    regnad Button Masher

    Member
    8
    May 19, 2008
    Whenever I start up USB Loader GX, it freezes when reading from the HDD. If I start USB Loader GX with the HDD unplugged and plug it in when the countdown begins, it reads the HDD fine and everything is okay.

    The HDD is a 1TB Seagate Expansion, a drive I believe many use, with a Y USB with the main cable plugged into Port 0, and the drive is formatted FAT32.

    Any ideas or suggestions?
     
  2. Shadow#1

    Shadow#1 Wii & 3DS Softmod Expert

    Member
    11
    Nov 21, 2005
    United States
    Use a better USB Loader like CFG USB Loader
     
  3. regnad
    OP

    regnad Button Masher

    Member
    8
    May 19, 2008
    Is it better? I was under the impression USB Loader GX had the best compatibility. The stickied guide here says so.
     
    Last edited by regnad, Jun 25, 2019
  4. Shadow#1

    Shadow#1 Wii & 3DS Softmod Expert

    Member
    11
    Nov 21, 2005
    United States
    Yes it's better LOL
     
  5. xYuunax

    xYuunax GBAtemp Regular

    Member
    4
    Feb 6, 2018
    China
    Hong Kong
    how many HDD are you using on Wii U? Which port are you using?

    also personally I like USB Loader GX, due to emunand.

    There's also WiiFlow, if your looking for alternatives.
     
    Last edited by xYuunax, Jun 25, 2019
  6. regnad
    OP

    regnad Button Masher

    Member
    8
    May 19, 2008
    Just the one.
     
  7. xYuunax

    xYuunax GBAtemp Regular

    Member
    4
    Feb 6, 2018
    China
    Hong Kong
    have you tried other port on the back? i remember i had problems with one of the ports, when switched to other port, it works.
     
  8. regnad
    OP

    regnad Button Masher

    Member
    8
    May 19, 2008
    Will it read from the other port? I thought it had to be in Port 0.

    This thread says Port 1 has compatibility problems and lacks features:

    https://gbatemp.net/threads/port-1-use-usb-loader-gx.530031/

    Did you go through the same process to switch to Port 1?
     
  9. xYuunax

    xYuunax GBAtemp Regular

    Member
    4
    Feb 6, 2018
    China
    Hong Kong
    I use the bottom port on the back for vWii, and top port for Wii U.
     
  10. regnad
    OP

    regnad Button Masher

    Member
    8
    May 19, 2008
    Do you use USB Loader GX for vWii? How did you get it to read? When I try, the settings menu won't allow me to choose anything other than Port 0.
     
  11. xYuunax

    xYuunax GBAtemp Regular

    Member
    4
    Feb 6, 2018
    China
    Hong Kong
    Both ports work for me, and I'm using the CIOS for emunand compatibility.
    Are you using the latest version (1272)?
     
  12. regnad
    OP

    regnad Button Masher

    Member
    8
    May 19, 2008
    Yes, I have the latest version. I just hacked my Wii U about a week ago, so everything is pretty much up to date.

    You didn’t have to adjust the settings to use Port 1? USB Loader GX just reads it for you automatically?

    Which cios are you using? I’m using 58, which is supposed to solve HDD problems but does not for me. Are you using 249?
     
  13. xYuunax

    xYuunax GBAtemp Regular

    Member
    4
    Feb 6, 2018
    China
    Hong Kong
    i've installed d2x-v10-beta52-vWii according to this guide: https://wiiu.hacks.guide/vwii-modding

    I'm actually using usbloadergx for the wiiware games, so I have it set on 58 and 250, but 249 or 250 is the same for me.

    and yes, usb loader gx autoloads the hdd for me, all I need to do is set my paths.

    Also make sure it's formatted to fat32 , 32k Allocation Unit Size?

    and I just re-read your first post, have you tried another power source other than from the usb port 0?
     
    Last edited by xYuunax, Jun 26, 2019
  14. regnad
    OP

    regnad Button Masher

    Member
    8
    May 19, 2008
    I have the main USB plug in 0 (top) and the extra power one in 1 (bottom).

    It works fine if I plug in the HDD after booting the loader. But if the HDD is plugged in and stays plugged in when I boot up the whole console the loader freezes.
     
  15. xYuunax

    xYuunax GBAtemp Regular

    Member
    4
    Feb 6, 2018
    China
    Hong Kong
    try a different power source, might be because during boot, it doesn't provide enough power until you load into the vWii
     
  16. regnad
    OP

    regnad Button Masher

    Member
    8
    May 19, 2008
    Meaning plug the second USB end into like a PC or something?

    edit: Okay, I tried plugging the power end of the Y USB into my PC, so it's definitely getting enough power, and it's doing the same thing.

    In addition to the Seagate, I've tried four different HDDs I have, a Sony and two different Toshiba models, and a LaCie that is self-powered. All the same thing.

    I tried plugging the main USB into port 1 (switching the USBs in ports 0 and 1). It didn't read the HDD.

    I tried CFG Loader, and it behaves exactly the same way as GX.

    Plugging in the HDD after entering vWii mode is enough to make it work correctly. Unplugging it and plugging it back in after entering vWii mode also works.

    I'm at my wit's end.
     
    Last edited by regnad, Jun 26, 2019
Loading...