1. luckypeic

    OP luckypeic Member
    Newcomer

    Joined:
    Sep 11, 2017
    Messages:
    15
    Country:
    Croatia
    Hello, about three months ago i followed definitive vWii hacking guide here on gbatemp and everything worked fine, i used usb loader gx with my 32GB usb flash without any problems and played some games then about a month ago i played how to train your dragon for few hours before i got bored and just exited the game and turned off my wii u and didnt touch vwii since then, then today i wanted to play excite truck so i used backup manager on windows 10 pc to delete how to train your dragon and couple of other games and install excite truck wbfs using same backup manager and now when i open usb loader gx it just freezes at initializing usb device, i have to unplug console to turn it off

    I tought that maybe excite truck is corrupted so i deleted it and tried again and still same problem so i decided to try to open usb loader without usb connected and without usb it works but when i use usb it crashes then i formatted my usb flash thinking it was corrupted and still didnt work.

    After that i even tried to use another usb flash drive, i formatted it and created empty wbfs folder and put it in console without any games on it and it got stuck again so i also formatted sd card and put only usb loader gx on it but same problem no matter what i try, last thing i did is play how to train your dragon and didnt touch vwii since then, also i never changed anything after initialy modding vwii and everything worked.

    How the hell can something stop working all of sudden.


    Here is my syscheck

    SysCheck HDE v2.4.0 HacksDen Edition by JoostinOnline, Double_A, R2-D2199, and Nano
    ...runs on vIOS58 (rev 6432).

    Region: PAL
    System Menu 4.3E (v610)

    Drive date: 08.21.2013
    Homebrew Channel 1.1.2 running on IOS58

    Hollywood v0x21
    Console ID: ********* (removed it from log, let me know if you need it)
    Console Type: vWii
    Shop Channel Country: Croatia (71)
    Boot2 v0
    Found 53 titles.
    Found 35 IOS on this console. 0 of them are stubs.

    vIOS9 (rev 1290): No Patches
    vIOS12 (rev 782): No Patches
    vIOS13 (rev 1288): No Patches
    vIOS14 (rev 1288): No Patches
    vIOS15 (rev 1288): No Patches
    vIOS17 (rev 1288): No Patches
    vIOS21 (rev 1295): No Patches
    vIOS22 (rev 1550): No Patches
    vIOS28 (rev 2063): No Patches
    vIOS31 (rev 3864): No Patches
    vIOS33 (rev 3864): No Patches
    vIOS34 (rev 3864): No Patches
    vIOS35 (rev 3864): No Patches
    vIOS36 (rev 3864): No Patches
    vIOS37 (rev 5919): No Patches
    vIOS38 (rev 4380): No Patches
    vIOS41 (rev 3863): No Patches
    vIOS43 (rev 3863): No Patches
    vIOS45 (rev 3863): No Patches
    vIOS46 (rev 3863): No Patches
    vIOS48 (rev 4380): No Patches
    vIOS53 (rev 5919): No Patches
    vIOS55 (rev 5919): No Patches
    vIOS56 (rev 5918): No Patches
    vIOS57 (rev 6175): No Patches
    vIOS58 (rev 6432): USB 2.0
    vIOS59 (rev 9249): No Patches
    vIOS62 (rev 6942): No Patches
    vIOS80 (rev 7200): No Patches
    vIOS236 (rev 65535): Trucha Bug, ES Identify, NAND Access
    vIOS249[56] (rev 21010, Info: d2x-v10beta52-vWii): Trucha Bug, NAND Access
    vIOS250[57] (rev 21010, Info: d2x-v10beta52-vWii): Trucha Bug, NAND Access
    vIOS251[58] (rev 21010, Info: d2x-v10beta52-vWii): Trucha Bug, NAND Access
    vIOS512 (rev 7): No Patches
    vIOS513 (rev 1): No Patches
    Report generated on 09/11/2017.

    I removed my console id from log but if you need it just let me know

    Please someone help
     
  2. Cyan

    Cyan GBATemp's lurking knight
    Former Staff

    Joined:
    Oct 27, 2002
    Messages:
    23,155
    Country:
    France
    I don't know why it's doing it "all of sudden" or why a setting would have been changed without your input, but try to set the "Loader's IOS" option to value 58 in the loader's settings.

    you might have to re-enable the "wii games" after the USB is detected, as the loader probably removed Wii games because you previously launched without a detected USB drive. (top menu>4th icon)
     
  3. luckypeic

    OP luckypeic Member
    Newcomer

    Joined:
    Sep 11, 2017
    Messages:
    15
    Country:
    Croatia
    I tried changing from IOS249 to IOS58 but now i get "USB Device not initialized. Switching to channel list mod" after re enabling wii games

    I really dont know what happened since i didnt touch loaders settings since day i modded my vWii and installed loader
     
  4. Cyan

    Cyan GBATemp's lurking knight
    Former Staff

    Joined:
    Oct 27, 2002
    Messages:
    23,155
    Country:
    France
    If even IOS58 can't initialize your drive, it's a drive issue.
    do you have another device you can try ? flash or HDD?

    that's strange that the computer can mount it without issue but not the console.
    could you test that drive on other devices ? (media player, other computer, etc.)
    and also, could you test it with other homebrew ? (HBC, nintendont and Wiixplorer, they are all using IOS58).

    also, be sure you connect it to the right USB Port.
    Port0 is the bottom port (near the edge) on Wii, and the back top port (far from the edge) on WiiU
     
    Last edited by Cyan, Sep 11, 2017
  5. luckypeic

    OP luckypeic Member
    Newcomer

    Joined:
    Sep 11, 2017
    Messages:
    15
    Country:
    Croatia
    I made sure it is connected to correct port, nintendont recognises it, works on both of my smart tvs, ps4 and ps3 and every other device, i also tried to full format it on pc
    Also tried to use my ancient 512 mb usb flash (lol i still have that old one) with just empty wbfs folder on it and it also hangs at initilitze usb drive with ios 249 and with ios 58 it opens loader but as soon as i chage show wii games it says not initialized, basicly does the same thing with both usb

    I will try nintendont one more time just to make sure it actually works

    Only thing i did after playing how to train your dragon when it worked was backup whole usb to pc and format it for use with wii u to test something and then i formatted it back to fat32 and restored everything so i tought that caused the issue so i even reformatted it again and tried to reinstall games to usb from stratch using backup manager on pc instade of restoring backup but nothing helps.....

    Edit: i also tried running chkdsk but no problems found.....
     
    Last edited by luckypeic, Sep 11, 2017
  6. Cyan

    Cyan GBATemp's lurking knight
    Former Staff

    Joined:
    Oct 27, 2002
    Messages:
    23,155
    Country:
    France
    you are sure it's formated as FAT32 and not exFAT?
    nintendont works with exFAT, but not the other homebrew.
     
  7. luckypeic

    OP luckypeic Member
    Newcomer

    Joined:
    Sep 11, 2017
    Messages:
    15
    Country:
    Croatia
    100% sure, just checked it in properties on pc
     
  8. Cyan

    Cyan GBATemp's lurking knight
    Former Staff

    Joined:
    Oct 27, 2002
    Messages:
    23,155
    Country:
    France
    I don't know what to suggest.
    working with nintendont means IOS58 can init the drive, so it's not normal you can't get it to init with IOS58 in the loader.

    verify you have the meta.xml in usbloadergx folder, edit it in text editor.
    you should not have any commented lines (if you see "//delete me" etc. then it's commented, delete them)
    then you must have --ios=58
    this way, the IOS58 will be used at launch, no IOS reload will be done when leaving HBC.
     
  9. luckypeic

    OP luckypeic Member
    Newcomer

    Joined:
    Sep 11, 2017
    Messages:
    15
    Country:
    Croatia
    I checked meta.xml everything is fine in that file but i noticed something that might be issue, so i formatted sd card again (i use 2gb non sdhc for wii mode) and put usb loader gx on it and after putting in in wii and testing loader again then taking back to pc i noticed that when i press shift+delete on usb loader gx folder in apps folder on sd card it cannot delete the folder, it removes all files from folder but folder remains no matter what i do so i formatted it again tested put back in pc and got same problem with non deletable folder so now i think it moght be sd since its really old one non sdhc, i will now try sdhc 16gb from my phone and see if that works and i'll let you know if it works, at this point i hope its just sd card and nothing else
     
    Cyan likes this.
  10. luckypeic

    OP luckypeic Member
    Newcomer

    Joined:
    Sep 11, 2017
    Messages:
    15
    Country:
    Croatia
    Ok so i tried few different sd cards and same thing, usb loader gx folder becomes undeletable but only after starting usb loader with usb in wii u

    I really dont know what to do at this point, its just driving me crazy i really want to play some wii games including excite truck and fatal frame 4 (i already played first few chapters when it all worked) so i can finally go to play fatal frame 5 (basicly my main reason for getting wii u is fatal frame 4 and 5 even tough i latley got addicted to some zelda games and splatoon)

    With usb loader not working anymore i feel like i lost one of major functions of this system


    I dont know, maybe i shoul try some other usb loader but i really like gx......
     
  11. luckypeic

    OP luckypeic Member
    Newcomer

    Joined:
    Sep 11, 2017
    Messages:
    15
    Country:
    Croatia
    Just wanted to let you know i finally got it to work, so after everything else failed i put wiiflow and cfg usb loader on my sd card and cfg loader listed all my games but i could not control it with my wiimote (i have latest revision of wiimote and apperetnly it does not work in cfg loader) then i tried wiiflow and it didnt even recognize my usb flash drive so i randomly found on google someone on reddit who had same issue and he recommended to format flash drive using BOOTICE but when formating select USB HDD mode instade of USB FDD mode and i did that but i doubted it would help but omg it worked

    I never used bootice not even the first time when everything worked fine before i always used windows integrated format tool but it seems like windows format somehow messed something up last time i formatted my usb flash drive and with bootice it worked without any problem, tested with both IOS249 and IOS58 with my USB 3.0 flash drive

    And huge thanks to you Cyan for helping with all the troubleshooting and all suggestions :)

    Btw, now that both IOS work with usb loader gx should i better use 58 or 249?

    And thanks :)
     
  12. kwall24

    kwall24 Advanced Member
    Newcomer

    Joined:
    Mar 3, 2016
    Messages:
    77
    Country:
    Canada
    Interesting solution. I have the same problem, though it didn't just randomly start. My hard drive works fine if its off/unplugged when I load GX and turn it on during the 20 second countdown, and I can even back out of GX and go back into it without issue. But if my drive is on and plugged in before I boot GX after rebooting the system, it freezes at initializing the drive on both IOS58 and 249. I've tried with Windows formatting and BOOTICE, and it does the same thing whether the drive is FAT32 format or WBFS (with the help of Wii backup Manager).

    I'll have to try BOOTICE with the USB HDD mode.
     
  13. luckypeic

    OP luckypeic Member
    Newcomer

    Joined:
    Sep 11, 2017
    Messages:
    15
    Country:
    Croatia
    Well, its worth a try, just make sure in bootice you also select "Align to 1MB / Align to Flash blocks"

    here is link to reddit where i found this bootice method

    Also, while looking around for solution to my issue i found few others mention same issue that you have with unplugging hdd and pluging it back in during countdown
     
  14. Cyan

    Cyan GBATemp's lurking knight
    Former Staff

    Joined:
    Oct 27, 2002
    Messages:
    23,155
    Country:
    France
    I don't even know what FDD is :P

    I'm glad you fixed your problem, but it's strange it started without any changes, and that the issue was the partition.
    I don't know if the issue was really the partition format, or maybe the partition table (MBR/GPT?)

    Not sure the alignment is/was an issue. that's just used for 4k drive, to align the start of partition sectors (512byte emulation) to a real 4k sector start. it's useful on computers to speed the drive access. I don't know if it has an effect on Wii homebrew.

    But if it really is the issue, then a lot of people could have their "countdown" issue fixed too, thought it will require a new partition format.
    unless a partition manager could move the data or the start of the partition to align the partition without formatting.

    it could be worth a try, if you are not annoyed with your issue and all the test you already did. seeing if the fix is bootice or the aligment.
    I've read Win7+ were correctly aligning partition to sectors, but maybe it's win10+ only? or maybe all Windows are not correctly aligning partitions to sectors.


    Now that it works with both cIOS and IOS58, I'd suggest using the same cIOS in the loader than the one you use for games. it will prevent reloading the cIOS at game launch, booting game faster.
    For cIOS, I'd recommend using base57 (d2x v8 final base57, or v10 r52 base57, don't use v10 r53 at all). Base57 has better compatibility with games.
     
    Last edited by Cyan, Sep 11, 2017
  15. luckypeic

    OP luckypeic Member
    Newcomer

    Joined:
    Sep 11, 2017
    Messages:
    15
    Country:
    Croatia
    Since bootice offers HDD mode and FDD mode format and HDD usualy means Hard Disk Drive i guess FDD could mean Flash Disk Drive, im not sure what it means but i guess it could be flash disk drive

    Maybe my issue started because i backed up my wii games and then formated it for use with WUP installer to test something and then formated it back to fat32 and restored my backup, i dont remember what version of windows was used to format it first time when it worked but maybe this recent format with win 10 messed it up, who knows

    No problem, i like testing and experimenting with consoles, computer, phones etc. (i even registrired on nintendo dev portal and got whole sdk and unity so i am now learning unity for wii u) so i will try to see what exactly fixed my problem and i'll let you know tomorrow, it would be great if some of those options in bootice could fix countdown problems

    I will try to format it with and without alignment and with and without fdd mode, guy on reddit mentioned that this worked for multiple flash drives that were working and then suddenly stopped so i dont know if bootice is gonna help with hard drive issues, i have couple of hard drives but all of them are literally full and both of my computers hard drives are also full so i dont know where to move data (it so easy to fill up multiple 1 terabyte hard disks these days.....) so i cannot guarantee that i will be able to test with hard drives soon but i will make sure to test all combinations of formatting i can think of to test at least with flash drives until i can get new hard drive and let you know results tomorrow :)
     
    Cyan likes this.
  16. GerbilSoft

    GerbilSoft GBAtemp Addict
    Member

    Joined:
    Mar 8, 2012
    Messages:
    2,336
    Country:
    United States
    It means Floppy Disk Drive. USB-FDD mode is generally only useful for really old systems that support booting from USB floppy disks but not USB hard disks.
     
  17. Cyan

    Cyan GBATemp's lurking knight
    Former Staff

    Joined:
    Oct 27, 2002
    Messages:
    23,155
    Country:
    France
    ah, thanks, I didn't know the usb floppy disk.

    Luckypeic, if you can, report the partition starting sector in your tests, not just the 1M alignment, and if the drive is 512byte/sector or higher, with or without 512byte emulation, etc. just to see if I can make the loader detects the LBA starting sector and warn the user.

    I remember there's someone who posted a guide in USBLoaderGX thread to explain how to switch the 512b emulation mode to fix HDD init/detection.
     
    Last edited by Cyan, Sep 12, 2017
  18. luckypeic

    OP luckypeic Member
    Newcomer

    Joined:
    Sep 11, 2017
    Messages:
    15
    Country:
    Croatia

    Hi, sorry for late reply, i wasn't feeling well lately :(

    What tool do you recommend to check that info (im not sure if bootice maybe displays everything that you mentioned, i have to check)

    By the way, today i reformated my usb with windows format again and this time my wii didnt crash..... strange......
     
  19. Cyan

    Cyan GBATemp's lurking knight
    Former Staff

    Joined:
    Oct 27, 2002
    Messages:
    23,155
    Country:
    France
    maybe the issue wasn't the way it's formatted (with bootice or windows or another tool), but the partition itself (its position, or size).
    I never used bootice so I don't know which option and information it will provide.
    the partition position and size is located in the boot sector (hdd sector 0, but I don't know if you know how to dump this)

    you can use hxd hexeditor and selecting "mount device" (not partition) but you'll have to make a copy, it's not easy if you are not used to hex editors.
    USBLoaderGX could dump these, but I removed the function to do it automatically. I'll have to work on adding a log again.
     
  20. d1ddle

    d1ddle Newbie
    Newcomer

    Joined:
    May 30, 2020
    Messages:
    9
    Country:
    United Kingdom
    I know people are skeptical about this, and I was too when I read it, but literally unplugging my usb drive and waiting until USB Loader GX couldn't read it and then plugging it back in again fixed it.

    I hacked with letterBomb and I'm on 4.3 with USB Loader loading IOS 249. No clue why, maybe hot conditions for the wii or something, I've got it in a hot conservatory.
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - initializing, freezes, loader