USB Loader GX does not work when WiiU HDD plugged in

Nicklander

Member
OP
Newcomer
Joined
Dec 11, 2018
Messages
23
Trophies
0
Age
25
XP
97
Country
Germany
I have 2 HDDs with 2 Y-cables. One for WiiU. One for vWii (with UStealth).

I want a solution so that I can leave both HDDs plugged in at the same time and play WiiU & vWii games. WiiU works perfectly fine, no matter where it's plugged. However there is some weird behaviour with vWii.

Scenario 1 - vWii HDD plugged in back slots (usb0) and WiiU HDD plugged in front slots:
In this case USB Loader GX tells me that the device couldn't be initialized, no games are shown. It only works if I unplug WiiU HDD first and then start USB Loader GX with only vWii HDD plugged in the back slots.

Scenario 2 - vWii HDD plugged in front slots and WiiU HDD plugged in back slots (usb0):
This is even weirder. USB Loader GX successfully initialises and displays all Gamecube & Wii games I have on the vWii HDD. Gamecube games actually play perfectly fine. But when trying to play Wii games I get a blackscreen upon clicking play.

How can I play from vWii HDD with USB Loader GX without disconnecting the WiiU HDD ???

using USB Loader GX v3.0 r1272 mod7

=================================================================

Edit: Found the solution - Scenerio 2 was actually the correct one !

USB Loader GX 3.0 r1272 mod7 (no changes to meta.xml)
also works: USB Loader GX 3.0 r1272

cIOS v10-beta52 vWii set up normally
base 56 => 249
base 57 => 250
base 58 => 251

Loader Settings
Loader IOS: 58
Game IOS: 251

Hard Drive Settings
USB Port: 0

WiiU HDD needs to be in slot 0 (upper back)
vWii HDD can be in any other slot
The way I personally do it is WiiU data in slot0, WiiU power in slot1, vWii data in front left, vWii power in front right
 
Last edited by Nicklander,

Xpl0itU

Well-Known Member
Member
Joined
Jul 8, 2021
Messages
223
Trophies
0
Age
23
XP
654
Country
Spain
I have 2 HDDs with 2 Y-cables. One for WiiU. One for vWii (with UStealth).

I want a solution so that I can leave both HDDs plugged in at the same time and play WiiU & vWii games. WiiU works perfectly fine, no matter where it's plugged. However there is some weird behaviour with vWii.

Scenario 1 - vWii HDD plugged in back slots (usb0) and WiiU HDD plugged in front slots:
In this case USB Loader GX tells me that the device couldn't be initialized, no games are shown. It only works if I unplug WiiU HDD first and then start USB Loader GX with only vWii HDD plugged in the back slots.

Scenario 2 - vWii HDD plugged in front slots and WiiU HDD plugged in back slots (usb0):
This is even weirder. USB Loader GX successfully initialises and displays all Gamecube & Wii games I have on the vWii HDD. Gamecube games actually play perfectly fine. But when trying to play Wii games I get a blackscreen upon clicking play. Turns out Wii games can't load successfully if HDD is plugged in front slots.

How can I play from vWii HDD with USB Loader GX without disconnecting the WiiU HDD ???

using USB Loader GX v3.0 r1272 mod7
Have you tried wiiflow lite?
 
  • Like
Reactions: jeannotte

Sypherone

Well-Known Member
Member
Joined
Apr 28, 2019
Messages
585
Trophies
0
Age
43
XP
959
Country
Germany
Normaly its possible to run both hdd at same time pluged in, both in the back ports. But it needs correct configured.
Primary Depending on:
- installed cios
- used usb loader gx version
- configuration of gx loader
- used hdd

Because this is a reccuring question. There are already plenty threads in our forum about it with near same Question/Problem. Setting up a correct systemconfiguration for your desired case.

So please first look them and check your system. Else if u dont get a finally solution the members will like to support you.
 
  • Like
Reactions: jeannotte

Nicklander

Member
OP
Newcomer
Joined
Dec 11, 2018
Messages
23
Trophies
0
Age
25
XP
97
Country
Germany
Normaly its possible to run both hdd at same time pluged in, both in the back ports. But it needs correct configured.
Primary Depending on:
- installed cios
- used usb loader gx version
- configuration of gx loader
- used hdd

Because this is a reccuring question. There are already plenty threads in our forum about it with near same Question/Problem. Setting up a correct systemconfiguration for your desired case.

So please first look them and check your system. Else if u dont get a finally solution the members will like to support you.
Already searched a whole dozen of posts on this forum with this issue, but not a single one has been useful so far...
This issue is stupid, I just need USB Loader GX to ignore the WiiU HDD plugged in the front ports.
 

Sypherone

Well-Known Member
Member
Joined
Apr 28, 2019
Messages
585
Trophies
0
Age
43
XP
959
Country
Germany
Sorry, for sure not.
USB Loader GX is designed to use backports only. The cios give only the Backports full access for homebrew. If this would be correct configured, the WiiU would not even been interested in the WiiU HDD and plugrd in fron or bsck ports. So something on your system is misconfigured. If u set it up like for sure descripted in other threads, there will be no problem.
 

Nicklander

Member
OP
Newcomer
Joined
Dec 11, 2018
Messages
23
Trophies
0
Age
25
XP
97
Country
Germany
If this would be correct configured, the WiiU would not even been interested in the WiiU HDD and plugrd in fron or bsck ports.
This is not true. Numerous posts even now in 2022 say that if WiiU HDD is connected, they can't make it work. I searched for hours already and didn't find a single post with a solution to the problem. Please just link me one of those threads with the correct configuration.
 

Sypherone

Well-Known Member
Member
Joined
Apr 28, 2019
Messages
585
Trophies
0
Age
43
XP
959
Country
Germany
First Question of all, how i already mentioned 2 times. Is your system correct set up? Can u check different things and proof that vWii and gx loader is correct setup? There are main failer, wich are already discused many times in different threads. Like used cios, port cofiguration, Config of gx loader, hdd format/gamespath, maby also if used CBHC or Tiramisu.
And then, if everything is alright for setting up the vWii with gxloader. And the Problem still persists, we can search for another solution.

Btw, how already mentioned, u can try different loader and check how it performs.
 

Nicklander

Member
OP
Newcomer
Joined
Dec 11, 2018
Messages
23
Trophies
0
Age
25
XP
97
Country
Germany
First Question of all, how i already mentioned 2 times. Is your system correct set up? Can u check different things and proof that vWii and gx loader is correct setup? There are main failer, wich are already discused many times in different threads. Like used cios, port cofiguration, Config of gx loader, hdd format/gamespath, maby also if used CBHC or Tiramisu.
And then, if everything is alright for setting up the vWii with gxloader. And the Problem still persists, we can search for another solution.

- WiiU hacked with Tiramisu
- 2x WD Elements Portable 2TB with 2x Y-Cable
- d2x-v10-beta52-vWii (base57 => slot249, base56 => slot250, base58 => slot251)
- USB Loader GX v3.0 r1272 mod7 (from wiidatabase) running Loader IOS58 & Game IOS249 (default settings)
- Nintendont v6.498 (from wiidatabase)

If just vWii HDD connected => Works perfectly fine.
If WiiU HDD connected as well ==> No longer works.

It seems to me that it is just impossible to run USB Loader GX properly if WiiU HDD is not disconnected manually.
 
Last edited by Nicklander,

Sypherone

Well-Known Member
Member
Joined
Apr 28, 2019
Messages
585
Trophies
0
Age
43
XP
959
Country
Germany
I am myself and many others running vWii HDD and WiiU HDD at the same time. Its a main setup we use. But There is a lot of failer potential. Iam using CBHC. I dont know if Tiramisu could disturb it in some way atm.

- The gx version is good, it has better recognizen for HDD. Did u deleted the loader and redownloaded him? Did u tryed starting gx loader over homebrew launcher?
Try different loader cios (58/250/251)
Also different Game cios (250/251)
U can also manually edit the XML File to set cios 58 as primary loader. GX Loader then changes automatic to your set loader cios 249/250/251

- Did u tryed vWii HDD in upper back port (port 0) and WiiU in lower port (port 1). Or other way arround? And powering them with Y-Cable extern? Be sure to choose the right port in gx loader. And choose one not both ports or it can stuck!
Alternative a long cable with Splitter pluged in in the front works, too.

- The dx2 v10beta52 version is Ok. But u can also try the v8 final (its only Wii!!), its the same but prefered by some mates.
You are using a modified configuration of the cios. Did u tryed the standart one?
base 56 => 249
base 57 => 250
base 58 => 251

- Alternativ to verify the Problem try Wiiflow or CFG Loader. If they work flawless with recognizing and launching the game, it points that there is a problem with gx loader.

- Be sure gx loader likes the vWii HDD. Not every hdd runs well with it. Maybe u have another to try. Check if its correct formated, best fat32 and use MBR, not GPT Table. It has best homebrew support. Maybe also make a s.m.a.r.t test for excluding failer potential. Or make a read/write test wich also restores bad blocks.

- Forum thread with near same Problem, search " GX Loader HDD". For example https://gbatemp.net/threads/2-hdd-at-the-same-time-again.612013/
 
Last edited by Sypherone,

Nicklander

Member
OP
Newcomer
Joined
Dec 11, 2018
Messages
23
Trophies
0
Age
25
XP
97
Country
Germany
I use this cios configuration now (instead of the one on wiidatabase.de)
base 56 => 249
base 57 => 250
base 58 => 251

As suggested in the thread you linked above I set both Loader's IOS & Game's IOS to 249.

It still doesn't work. Now USB Loader GX freezes on startup at "Reinitializing devices".
 

Sypherone

Well-Known Member
Member
Joined
Apr 28, 2019
Messages
585
Trophies
0
Age
43
XP
959
Country
Germany
As i mentioned already multiple times, there is something missconfigured. Because normaly it works flawless using both HDD at same time at backports. So everything needs to verify its correct and working. And in Addition a lot of threads with none working gxloader using hdd can help find the issue.

Did u tryed also one of the other mentioned tips? if no, there is no need to search a solution.
 
Last edited by Sypherone,

Nicklander

Member
OP
Newcomer
Joined
Dec 11, 2018
Messages
23
Trophies
0
Age
25
XP
97
Country
Germany
As i mentioned already multiple times, there is something missconfigured. Because normaly it works flawless using both HDD at same time at backports. So everything needs to verify its correct and working. And in Addition a lot of threads with none working gxloader using hdd can help find the issue.

Did u tryed also one of the other mentioned tips? if no, there is no need to search a solution.
Yes I did all of the above. It either tells the „fail to initialize“ error OR entirely freezes when starting the loader, depending on which LoaderIOS I set in the settings. I also tried to set bootIOS to 58 by editing meta.xml manually.

I tried launching WiiFlow but it shows nothing… apparently doesn’t recognize my HDD, just tells me there are no games on my SD.

Again, it all works perfectly fine if I just disconnect WiiU HDD before launching the loader. I can even disconnect WiiU HDD and reconnect it, then it also works. But it needs to be disconnected at least once for a little moment for it to work.
 
Last edited by Nicklander,

Cyan

GBATemp's lurking knight
Former Staff
Joined
Oct 27, 2002
Messages
23,658
Trophies
2
Age
44
Location
Engine room, learning
XP
15,222
Country
France
But u can also try the v8 final,
please, don't try this on a vWii.
v8 final is for Wii
v10 r52 is v8 final for vWii (and Wii, it's a copy of v8 renamed v10)

v9 is beta for Wii (not recommended)
v10 r53 is v9 for vWii (not recommended) (and Wii, it's a copy of v9 renamed... v10 too)


the other help you provided is good :grog:

2x WD Elements Portable 2TB with 2x Y-Cable
2 Y cable... and the other side of these Y cable are plugged where ????
HOW do you plug the Y cable DATA cable into the console ? which port ?
do you use HUB ? DON'T !

You didn't provide enough information.

Did you read the thread Sypherone linked ? https://gbatemp.net/threads/2-hdd-at-the-same-time-again.612013/#post-9821498
I provided the proper setup.


I recommend you use the vWii HDD without enclosure (these can have detection/initialization issues with cIOSes).
so :
vWii Ustealth, Y-cable Data to USB Port 0 (back-top)
vWii Ustealth, Y-cable Power to any other USB port, or powered Hub, or USB plug adapter/charger.
WiiU in the enclosure, to any other USB port. (if you don't have enclosure, DATA plug CAN use HUB and be plugged on any USB port)
USBGX game's IOS : 249 (d2x v10 r52)
USBGX loader's IOS : 249 (if this setup doesn't work, try loader's IOS 58)
 
Last edited by Cyan,

Sypherone

Well-Known Member
Member
Joined
Apr 28, 2019
Messages
585
Trophies
0
Age
43
XP
959
Country
Germany
Ok, thats bad. It says GX Loader would be OK, but something on the vWii seams missconfigured. I dont know if it has something todo with Tiramisu. Maybe verify the vwii jailbreak with it.
If everything is tryed and dubblechecked, i think more it may be something with the hdd, but its a WD elements portable and i use the same because of high compatibility. Try a different Y- Cable. Maybe u have a usb stick for trying, but they are not very liked from gx loader.
Its then and now just a try and error finding the issue and verifying that everything is correct. Normaly this is a working setup.

This tutorial is outdated, but i think u can find there some usefull information.
https://gbatemp.net/threads/usb-loader-gx-multiple-usb-drives.466416/#post-7216091
 
Last edited by Sypherone,

Cyan

GBATemp's lurking knight
Former Staff
Joined
Oct 27, 2002
Messages
23,658
Trophies
2
Age
44
Location
Engine room, learning
XP
15,222
Country
France
The hack used WiiU side shouldn't affect vWii.
You can hack vWii without hacking WiiU mode. all you need is install a cIOS on vWii mode and you are done "hacking" it. it's not really hacked, it's just an additional IOS added to the system used by the loader (edit: oh, and, HBC installed as a channel too). there's no real "hack of vWii mode" involved.
 

Sypherone

Well-Known Member
Member
Joined
Apr 28, 2019
Messages
585
Trophies
0
Age
43
XP
959
Country
Germany
The last thing i have is that ios58 is mounting all UBS ports at the same time and then checking in descending order from usb port 3 to 0 for known file formats and is jumping unknown filesystem formats. But the WiiU HDD has his own filesystem, so why would the vWii stuck there?

This implements, if u try your previous cios setup (base57 in cios 249,...) wich worked with gx loader and u insert vWii HDD in port 1 (lower back port) and WiiU HDD in port 0 (upper back port), this setup should work.
 
Last edited by Sypherone,

Cyan

GBATemp's lurking knight
Former Staff
Joined
Oct 27, 2002
Messages
23,658
Trophies
2
Age
44
Location
Engine room, learning
XP
15,222
Country
France
or you could try another version of the loader.
you said you are using 1272 mod7
try mod6 ? mod5 ?
or 1272 not modded (though you won't have access to cheat, network, ssl, etc.) but just to try if it's a version issue, in that case if it works on mod6 and not mod7, then you should report the issue to Blackb0x. (or whoever dev created the mod you are using)
 
General chit-chat
Help Users
  • No one is chatting at the moment.
  • Skelletonike @ Skelletonike:
    You can get some pretty good combo washing and drying machines for like 350€ nowadays.
    Gift
  • Veho @ Veho:
    They are never as good and thorough as getting them separate but they beat the clothesline so yeah.
    Gift
  • Skelletonike @ Skelletonike:
    got an LG one last month and it was pretty good, was on sale so got it for 400€ (normal price was usually 650). Can't complain
    bout it so far.
    Gift
  • Dark_Phoras @ Dark_Phoras:
    I prefer the clothesline in summer
    Gift
  • Dark_Phoras @ Dark_Phoras:
    Good morning
    Gift
  • Veho @ Veho:
    Good morning.
    Gift
  • Dark_Phoras @ Dark_Phoras:
    Has Childish Gambino become more mature?
    Gift
  • Veho @ Veho:
    No.
    Gift
  • Veho @ Veho:
    He will never become mature, he will go straight to Senile Gambino.
    Gift
  • Dark_Phoras @ Dark_Phoras:
    It sounds good, we might get good music from Senile Gambino that we wouldn't from Straight Gambino
    Gift
  • Veho @ Veho:
    Bought a used Nerf Mega blaster yesterday, good condition, but only got one single foam dart for it. And it was so chewed up, when I tried to fire it today it ripped the tip clean off and spat the thing out in two pieces.
    Gift
  • Veho @ Veho:
    Radical.
    Gift
  • Veho @ Veho:
    I need some mega darts now.
    Gift
  • Dark_Phoras @ Dark_Phoras:
    Don't forget cqc is still valid in gun combat
    Gift
  • FAST6191 @ FAST6191:
    Trying to get americans to use a clothes line there Veho?
    Gift
  • FAST6191 @ FAST6191:
    Always seems to be a bizarre and quaint concept whenever I speak to them
    Gift
  • FAST6191 @ FAST6191:
    or they come visit
    Gift
  • FAST6191 @ FAST6191:
    and this is not the northern snow in May types either. Desert living types as well.
    Gift
  • Dark_Phoras @ Dark_Phoras:
    I've seen so many american movies with clotheslines
    Gift
  • FAST6191 @ FAST6191:
    any set past about 1986?
    Gift
  • Dark_Phoras @ Dark_Phoras:
    That I don't know
    Gift
  • Dark_Phoras @ Dark_Phoras:
    Here it's common to see drying racks in balconies, even of two modern newly built buildings nearby
    Gift
  • Dark_Phoras @ Dark_Phoras:
    I have a drying machine at home and we seldom use it, even in winter
    Gift
  • Dark_Phoras @ Dark_Phoras:
    So, maybe it's a different habit from the usual american's, as you say
    Gift
  • Dark_Phoras @ Dark_Phoras:
    The cold weather is slowly creeping back, how nice
    Gift
    Dark_Phoras @ Dark_Phoras: The cold weather is slowly creeping back, how nice