USB Loader GX 2TB WD Elements HDD starting games exits to Wii Menu

Discussion in 'Wii U - Hacking & Backup Loaders' started by p00hba, Jan 15, 2017.

  1. p00hba
    OP

    p00hba Newbie

    Newcomer
    4
    1
    Jan 14, 2017
    United States
    Greetings!

    First off, much thanks to all who have paved the way for this amazing work.

    So I recently got a Wii-U and soft modded it and put on the HomeBrew Channel and also got USB Loader GX (Rev1262). I have a 250GB Samsung SSD which I was able to backup with CleanRip and run a bunch of games nicely, but the same games on a 2TB WD Elements 25A2 HDD formatted Fat 32, with a Y-Power USB cable, load up in the menu and show the animated banners, then on trying to actually start, initially looks like it begins to load, goes black, lights flash on the drive, but then eventually exits back to the Wii menu.

    It's similar behavior in wiiflow.

    I checked the https://wiki.gbatemp.net/wiki/USB_Devices_Compatibility_List and don't specifically see the drive, but do see some similar reports on WD Western Digital My Passport Ultra 1 TB. I was going to give the low level formatting a try, followed up a system format then finally with Wii backup manager format. But, I was curious, how do folks actually trouble shoot this stuff? Is there a way with that Bash shell I found to look at some crash logs of why usb loader gx and others exit when the game is starting? Where does this output go?

    It may just be that this 2TB WD Elements HDD is not compatible, but I was curious since I've come this far as to try and dig deeper to the root cause. If it does end up being incompatible, I would like to add a note to the wiki page. Any light shared on any of this would be much appreciated!

    And again, much thanks to all folks who have contributed to this effort.

    Thanks!

    Here is a copy of my sysCheck:

    SysCheck HDE v2.4.0 HacksDen Edition by JoostinOnline, Double_A, R2-D2199, and Nano
    ...runs on vIOS58 (rev 6432).

    Region: NTSC-U
    System Menu 4.3U (v609)

    Drive date: 07.12.2012
    Homebrew Channel 1.1.2 running on IOS58

    Hollywood v0x21
    Console ID: 619745436
    Console Type: vWii
    Shop Channel Country: United States (49)
    Boot2 v0
    Found 76 titles.
    Found 34 IOS on this console. 0 of them are stubs.

    vIOS9 (rev 1290): No Patches
    vIOS12 (rev 782): No Patches
    vIOS13 (rev 1288): No Patches
    vIOS14 (rev 1288): No Patches
    vIOS15 (rev 1288): No Patches
    vIOS17 (rev 1288): No Patches
    vIOS21 (rev 1295): No Patches
    vIOS22 (rev 1550): No Patches
    vIOS28 (rev 2063): No Patches
    vIOS31 (rev 3864): No Patches
    vIOS33 (rev 3864): No Patches
    vIOS34 (rev 3864): No Patches
    vIOS35 (rev 3864): No Patches
    vIOS36 (rev 3864): No Patches
    vIOS37 (rev 5919): No Patches
    vIOS38 (rev 4380): No Patches
    vIOS41 (rev 3863): No Patches
    vIOS43 (rev 3863): No Patches
    vIOS45 (rev 3863): No Patches
    vIOS46 (rev 3863): No Patches
    vIOS48 (rev 4380): No Patches
    vIOS53 (rev 5919): No Patches
    vIOS55 (rev 5919): No Patches
    vIOS56 (rev 5918): No Patches
    vIOS57 (rev 6175): No Patches
    vIOS58 (rev 6432): USB 2.0
    vIOS59 (rev 9249): No Patches
    vIOS62 (rev 6942): No Patches
    vIOS80 (rev 7200): No Patches
    vIOS249[56] (rev 21010, Info: d2x-v10beta52-vWii): NAND Access, USB 2.0
    vIOS250[57] (rev 21010, Info: d2x-v10beta52-vWii): NAND Access, USB 2.0
    vIOS251[58] (rev 21010, Info: d2x-v10beta52-vWii): NAND Access, USB 2.0
    vIOS512 (rev 7): No Patches
    vIOS513 (rev 1): No Patches
    Report generated on 01/15/2017.
     
    Last edited by p00hba, Jan 15, 2017
  2. p00hba
    OP

    p00hba Newbie

    Newcomer
    4
    1
    Jan 14, 2017
    United States
    Am I hitting a size limit? Is it actually possible to have a 2TB partition? Do I need to break this into a few partitions? <1.5TB? or like 900MB?
     
  3. retrofan_k

    retrofan_k GBAtemp Advanced Maniac

    Member
    1,818
    1,114
    May 31, 2013
    Belarus
    Caves
    Do you have a standard Wii to hand? Over the years, some HDD's that worked fine on a Wii, did not on a WiiU for me, even with separate power supplies and Y cables. You're syscheck looks fine to me, so no issue with installed Vios's. So this sounds to me like a compatibility issue with the HDD, if you say the same clean rips work on other HDD you have.


    Could try a low level format and then partition it to NTFS.
     
    Last edited by retrofan_k, Jan 15, 2017
  4. p00hba
    OP

    p00hba Newbie

    Newcomer
    4
    1
    Jan 14, 2017
    United States
    Thanks I'll give that a try!

    Sorry, no regular wii, just this bad boy wii-u.

    I just split it into two 900GB parittions, one FAT32 the other NTFS, going to load games on NTFS one now and see if those work. Just changing the size to 900MB didn't change any symptoms, so we'll see if the NTFS one works.
     
  5. p00hba
    OP

    p00hba Newbie

    Newcomer
    4
    1
    Jan 14, 2017
    United States
    Wow, the same game on the NTFS partition worked! Crazy. Guess I try and migrate all of the wii games to NTFS on this drive then.
     
    retrofan_k likes this.