USB devices stay powered on after Wii power off

Discussion in 'Wii - Hacking' started by ZombiePosessor, Jun 3, 2009.

  1. ZombiePosessor
    OP

    Member ZombiePosessor GBAtemp Fan

    Joined:
    May 1, 2008
    Messages:
    445
    Location:
    West Virginia
    Country:
    United States
    Ok, whenever I turn my Wii off, my USB drives' "power" LEDs stay on, and I noticed that the Wii gets hot as fuck also, I'm assuming because there's no ventilation because no power supply to the fan. I've turned off Standby connection, WiiConnect24, everything I could think of that would keep power flowing, and it still happens. It seems to be a recent thing too, I'm thinking sometime after installing rev10, but I could be totally wrong. I just unplug the Wii from the wall after I turn it off, so its not a serious problem, just an annoyance. Anyone have a solution? I tried searching, but came up short. TIA
     
  2. hartleyshc

    Member hartleyshc GBAtemp Regular

    Joined:
    Oct 2, 2008
    Messages:
    184
    Location:
    Gainesville, FL
    Country:
    United States
    I use a drive that is usb powered from the wii. So when the Wii is on, the hdd is on.

    Turn off Standby mode in the WiiConnect24 options. This will turn the system off when you hold down the power button on the wiimote instead of keeping it in standby mode, which keeps power to the hdd. The little green light should turn red instead of orange.

    If the hdd has a separate power cable, you will have to find a power switch on the enclosure. If there isn't one, then you will need to unplug the cable every time, or create a power switch by adding one onto the ground wire powering the enclosure.
     
  3. ZombiePosessor
    OP

    Member ZombiePosessor GBAtemp Fan

    Joined:
    May 1, 2008
    Messages:
    445
    Location:
    West Virginia
    Country:
    United States
    Ive already turned the standby mode off, the USB sticks are still getting power to them.

    And this is something else too, my Wii power LED is only ever two colors, red and none. When the Wii is powered on, there is no light from the power button, but when its off (or in standby, it doesn't matter) its red, never orange. Is this normal with launch-era Wiis?
     
  4. hartleyshc

    Member hartleyshc GBAtemp Regular

    Joined:
    Oct 2, 2008
    Messages:
    184
    Location:
    Gainesville, FL
    Country:
    United States
    I've always seen a green light on any wii when its on. Maybe a physical power problem with the wii?
     
  5. 0M39A

    Member 0M39A GBAtemp Fan

    Joined:
    Apr 24, 2009
    Messages:
    374
    Country:
    Australia
    all i did was turn off wii connect 24, which turns off standby and now my wii is either on (green light) or off (red light). while in off, it cuts the power to the usb devices which is good in that it turns off my external hdd, but bad as it also turns off my wiimote charging station. wish there was a compromise, ie. just cut the power to one usb port, but its a pretty easy thing to get over.
     
  6. Sir VG

    Member Sir VG GBAtemp Advanced Fan

    Joined:
    Jun 26, 2004
    Messages:
    847
    Country:
    United States
    There's a simple way around it - get a USB HDD that you can turn off on its own. Problem solved.
     
  7. doesenbrot

    Newcomer doesenbrot Member

    Joined:
    Apr 16, 2009
    Messages:
    11
    Country:
    Austria
    there are three Lights: green(working), orange(Standby,Internet is working and some other) and red(ALL IS OFF,ALSO USB)
    When I start my Wii, my Hdd is starting,too and when I hold my On/Off Button 5 Seconds, my Wii is OFF(red) and my HDd, too
     
  8. ZombiePosessor
    OP

    Member ZombiePosessor GBAtemp Fan

    Joined:
    May 1, 2008
    Messages:
    445
    Location:
    West Virginia
    Country:
    United States
    I figured everything out, thanks tho guys.

    On the other thing, do I have a freak Wii or something? I've never, ever, EVER seen a green/orange light on my Wii, its either off (red) or on (nothing).
     
  9. techboy

    Member techboy GBAtemp Advanced Maniac

    Joined:
    Mar 15, 2009
    Messages:
    1,720
    Location:
    Pennsylvania
    Country:
    United States
    Yeah, somethings is wrong with your wii. Mine has the green light when on as well. The reason you don't see orange is because the orange color is produced by mixing the red and green. Your green LED in the power switch is bad, so your orange is red and the green appears as nothing.

    Also, as above, it is not normal for the USB ports to be powered when completely powered down. Hold down power for 5 or 6 sec. to turn off and see if it makes a difference (not likely though, seeing WC24 is turned off)
     
  10. BlackEnigma

    Member BlackEnigma GBAtemp Fan

    Joined:
    Mar 1, 2009
    Messages:
    342
    Country:
    United States
    Yeah green orange and red for me as well.
    I also have a launch Wii.

    Sometimes I use USB Loader GX to power all the way down to red.
    Sometimes I hold the power button until it goes to red.
    Sometimes I turn of Wii connect and when I power off with the remote it goes to red.
    And sometimes if I turn it off and it's orange and I want it to be red I unplug it and plug it back in and then it's red.
     

Share This Page