Upgrading to 4.0 from "October 23rd" Wii Fix

Discussion in 'Wii - Hacking' started by Reiniku, Jul 3, 2009.

Jul 3, 2009
  1. Reiniku
    OP

    Newcomer Reiniku Member

    Joined:
    Aug 21, 2006
    Messages:
    20
    Country:
    United States
    I recently got back to using my Wii after a long span of tme where I simply wasn't playing games and feel severely out of the loop. It seems there's been a lot of really cool progress made and now you can even go as far as loading Wii games from an external HD.

    A long time ago I downgraded from 3.4 (I think) using the "October 23rd Fix" posted here a while back to what my wii is claiming to be 3.3U. I loadedseveral VC and VC-injected titles and was a pretty happy camper for a long time.

    Now I'd also like to take advantage of the USB Loading functionality the new firmware has to offer, without losing the ability to install VC Wads. Or more specifically, what's the ideal upgrade path I should take to not lose any of my current functionality and gain some of the new features?

    If there's a way to find out exactly what firmware and cios and things like that I have installed, could someone point me in the right direction to find all this information out? I almost feel like I'd have an easier time upgrading from a blank Wii.

    With that said, I do have quite a few questions about all this. I honestly do own every single Wii game I want. I also own most of the VC titles I inject but in their original SNES cartridges, I just didn't want to pay for them again. But what I was wondering is if there is a benefit to ripping my own Wii games to load onto the HD over downloading them from torrents/MU/RS. Are there any other essential programs or applications I should look into?

    As it stands I'd be perfectly happy with being able to use some form of USB Loading and retain VC Wad installation functionality. Also, with the new update am I able to install WADS onto the SD card instead of the Wii's severely lacking memory?
     
  2. nabster92

    Member nabster92 GBAtemp Advanced Maniac

    Joined:
    Apr 16, 2009
    Messages:
    1,631
    Country:
    United States
    All you need for usb loading is cIOS rev9 or higher. The firmware doesn't matter. That being said upgrading to 4.0 doesn't make you lose anything either if you use Waninkoko's updater and already have cIOS installed beforehand.

    Btw what was the point of downgrading from 3.4 to 3.3? Normally if one would want to downgrade you would do it to 3.2. So anyways as long as you have SOMETHING installed to IOS249 you can just run the cIOS rev 13a installer (or anything above rev9 depending on preference) and you will be able to run any usb loaders.

    The benefit of using discs over downloading is that...you don't have to take the time to download them. You can install them directly from the disc in no more than about 30 minutes (save for brawl maybe).

    And if you download them you have to use the WBFS manager to transfer the .iso to your external HD anyways which IS faster assuming you already have the .iso at hand. (About 3-5 minutes to transfer.)

    If you update to 4.0 you can transfer games to your SD card through Nintendo's new SD card menu which adds an extra 20 pages of channels from your sd card. You can't do wad installations directly to it though. You have to install to the system then "move" it through the Wii's data management to your sd card. Note that IOS60 must be patched to play pirated/wad's of VC/Wiiware off the sd card menu.

    What cIOS you are currently on doesn't really matter as you most likely aren't on rev9 or higher, but if you have an older one you just have to run a newer rev cIOS installer to install over it.

    http://gbatemp.net/index.php?showtopic=144835

    Since you have cIOS previously installed you can just follow the online guide there to be fully up to date with anything you need (well it has you install cIOS rev10 which doesn't have usb support for anything other than the external hard drive you use to load games, but you can replace that with rev13a if you want)

    Also note that if you don't have any IOS's to downgrade or install then IOS downgrader will just restart, so it wouldn't be not working if it does that.
     
  3. Reiniku
    OP

    Newcomer Reiniku Member

    Joined:
    Aug 21, 2006
    Messages:
    20
    Country:
    United States
    Thanks for the very informative post.

    The main reason I want to upgrade to 4.0 is for the ability to use SDHC cards. I have a nice 8gb just lying around that I could put to very good use.

    I'm pretty sure I upgraded from 3.4 to 3.3 so I could load a VC-Inject Chrono Trigger WAD when I had a real hankering to play it but not pull out my SNES. I had upgraded to whatever the October 23rd update was just the night before and then the "fix" was posted and used that to get WAD Installer working. For all I know I was never at 3.4, just whatever firmware was released on October 23rd.

    And... wow. I'm actually pretty amazed that I can just directly rip my games straight to the hd on the Wii. If that's the case then I won't have to spend hours on end downloading the games I already have.

    Is there any way to check what cIOS I'm currently on? I'd like to be able to just quickly find out so I make sure not to make any stupid mistakes.
     

Share This Page