Upgrading the firmware of R4i Gold

Discussion in 'R4 DS' started by markini6, Aug 5, 2011.

Aug 5, 2011
  1. markini6
    OP

    Newcomer markini6 Newbie

    Joined:
    Aug 5, 2011
    Messages:
    3
    Country:
    United Kingdom
    Hi, my brother has an R4i Gold flashcart, but foolishly updated his Dsi XL to version 1.4.1 a while ago, and hasn't been able to use the cart since. The website on the card is www.r4ids.com, which lists the downloads available for the cart. It's the one at the bottom, with red on the back, NOT R4i ver 2.0. Basically, I know I'd need to use a normal ds, but I can't find anywhere something to upgrade the cart's firmware, which would then alow it to be used again with the DSI XL. I presume the link at the top of the site is for the Version 2.0 cart, not the one that he has. So will it be possible to ever use the cart again?

    Cheers in advance for any replies
     
  2. Rydian

    Member Rydian Resident Furvertâ„¢

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    Seems not. Many clone carts like that stop support after releasing new hardware either to make you buy the new one, or (as it seems in this case) because they cheaped out too much on the old hardware and it can't be updated as far as the new one.
     
  3. tranfeer

    Member tranfeer GBAtemp Advanced Fan

    Joined:
    May 23, 2010
    Messages:
    772
    Country:
    Austria

    Just take it easy.
    As the known reason, r4i gold's official website has been changed to r4ids.cn.
    You can access www.r4ids.cn to download V1.43 patch for r4i gold non-3ds card.
    Please read readme.txt attached and do as the procedures listed in it.
    If you have any other questions, please send mails to r4idsn@163.com
     
  4. markini6
    OP

    Newcomer markini6 Newbie

    Joined:
    Aug 5, 2011
    Messages:
    3
    Country:
    United Kingdom
    Thanks so much for the help, I'll see if it works.
     
  5. indask8

    Member indask8 New Member Forever

    Joined:
    Apr 19, 2007
    Messages:
    987
    Location:
    Look at the Flag...
    Country:
    France
    Beware, old 1.4 R4iGold seem to be non updatable, they released later a 1.4.1 and updatable R4iGold...

    I say this because I bricked my R4iGold 1.4 with latest update, using another flashcart to run once again the updater does not change anything, update goes 100% successful but then the flashcart does not start (freeze on DSLite, no cart inserted on DSi), and Yes it's a genuine one from r4ids.cn but an old one pre-1.4.1.
     
  6. markini6
    OP

    Newcomer markini6 Newbie

    Joined:
    Aug 5, 2011
    Messages:
    3
    Country:
    United Kingdom
    It doesn't say in the readme whether or not I should just have the update file on the cart, or whether I should have that and the normal WOOD files that you'd have on the cart normally, when using it.
     
  7. Buleste

    Member Buleste Old Fart

    Joined:
    Dec 19, 2010
    Messages:
    852
    Country:
    United Kingdom
    You need the firmware update and the wood files. However to runthe firmware update you will need either a DS/DSl or a DSi
     
  8. tranfeer

    Member tranfeer GBAtemp Advanced Fan

    Joined:
    May 23, 2010
    Messages:
    772
    Country:
    Austria

    You should use The DSi V1.43 Patch for R4i Gold Non-3DS to update your r4i gold.
    After updating with success, your r4i gold can support NDSi V1.4.3.
     

Share This Page