Upgrading the 4.5 internet browser via cia on sysnand

Discussion in '3DS - Flashcards & Custom Firmwares' started by MattKimura, May 3, 2015.

  1. MattKimura
    OP

    MattKimura 3DS & WiiU Enthusiast

    Member
    1,776
    923
    Jun 30, 2014
    United States
    What I'm trying right now is completely experimental and I want to ask you users of GBATemp before I carry on, to see if anyone has some experience with this.

    So I've downloaded the 7.x internet browser cia from 3DNUS, the last one before the 9.5 browser update. I want to get this installed on 4.5 sysnand, so that I can have access to the browser exploits for specific games like ACNL. If there is a way to upgrade sysnand to 9.2.0-20 up to 9.5.0-22, that would also be great.

    I fully understand how to install a cia to sysnand, especially now that Gateway made it ten times easier with the new 3.2.1 update. I just don't know WHAT will happen after installing this cia.
    I just finished installing the 4.5 mset on my N3DS, so installing this browser cia on my O3DS should be a similar process. This will update the browser itself, similar to "downgrading" the settings(mset).

    I'm still pretty skeptical about installing this, since this will be done on my friends 3DS. It'd be terrible if this bricked. I feel like even if you have a NAND backup, it's still pretty hopeless.

    Any input would be appreciated, hopefully someone's tried something like this before. Really looking forward to getting this done.
     
  2. cearp

    cearp the ticket master

    Member
    7,473
    4,710
    May 26, 2008
    Tuvalu
    first of all, it's just the internet browser. it's not like you are installing home menu or something else system critical... :)
    you can even delete the browser, your 3ds will still work.

    and second, the only problem that could arise is that 4.5 does not have the right keys etc, to 'read' the newer internet browser.
    install it and see. it's not as crazy as you think, it would probably work
     
    Margen67 and MattKimura like this.
  3. LameNobody

    LameNobody Weighted Companion Cube Enthusiast

    Member
    455
    232
    Jan 23, 2015
    Canada
    127.0.0.1
    That guy that released the PBT CFW said:
    if the 7.1.0 browser didn't have an issue, I doubt the 9.4.0 one will
     
    Margen67 and MattKimura like this.
  4. cearp

    cearp the ticket master

    Member
    7,473
    4,710
    May 26, 2008
    Tuvalu
    well no that's not for certain, as fws get higher new sdks and keys are used. testing with gw wouldn't always help because gw will use some of the keys built in, so it can be decieving to see if it would work on sysnand without any hacks
     
    LameNobody likes this.
  5. LameNobody

    LameNobody Weighted Companion Cube Enthusiast

    Member
    455
    232
    Jan 23, 2015
    Canada
    127.0.0.1
    As it turns out, It works.

    Just installed the browser from 9.4.0-22 on my 4.5 system nand, and it runs fine.
     
    MattKimura likes this.
  6. MattKimura
    OP

    MattKimura 3DS & WiiU Enthusiast

    Member
    1,776
    923
    Jun 30, 2014
    United States
    I really appreciate the input Cearp and LameNobody. I'll get this going on my friend's 3DS, should work. Since this was all just an idea from a user I've bumped into, I didn't think this would be safe to do. I never installed anything to sysnand, not until I installed 4.5 mset on my N3DS.

    I entered the browser title ID in 3DNUS, and entered v4096. (there's one version higher, and that's 5121)
    Should I just download 9.2.0-20 USA on 3DNUS instead, and get the browser cia from the output folder? Is this an updated version of internet browser v4096?
     
  7. cearp

    cearp the ticket master

    Member
    7,473
    4,710
    May 26, 2008
    Tuvalu
    if you download the whole fw 'pack' of 9.2, there is no point. the v4096 browser would be included in that, so why not just download the one title that you want specifically :)
    (which is exactly what you were about to do by entering the title id) so yeah, you are ok
     
    MattKimura likes this.
  8. Asia81

    Asia81 In my Ecchi World <3

    Member
    4,955
    2,447
    Nov 15, 2014
    France
    Albi
    It's possible to install the old browser on my 4.5 sysnand EUR for have internet exploits ?
    Without any bricks ?
     
  9. LameNobody

    LameNobody Weighted Companion Cube Enthusiast

    Member
    455
    232
    Jan 23, 2015
    Canada
    127.0.0.1
    Yes, you are able to install any browser between 4.0.0 to 9.4.0-22 and have the exploit function properly.
     
    MattKimura likes this.
  10. MattKimura
    OP

    MattKimura 3DS & WiiU Enthusiast

    Member
    1,776
    923
    Jun 30, 2014
    United States
    Thanks for the encouragement, you're right about the safety of it. It installed successfully to sysnand and no side effects.
    But then after installing it, I updated sysnand from 4.2 to 4.5 using a game. Not sure if this overwrites the browser. So I tried the browser exploit for Animal Crossing, and it failed so I tried reinstalling the v4096 browser. I still can't get the RAM editor to work.

    I guess there's just no hope for it then, unless maybe I have to enter Gateway mode on sysnand while doing the browser exploit?

    Edit: Game won't read while on Gateway sysnand mode. Makes sense though lol
     
  11. verdin551

    verdin551 Member

    Newcomer
    18
    1
    Apr 1, 2015
    Argentina
    ---

    Thank you all!
     
  12. t4z3r

    t4z3r Newbie

    Newcomer
    1
    0
    Dec 4, 2013
    Guys need some help trying to do the same...

    I'm on 4.5e tried this method to install CFW which works

    http://gbatemp.net/threads/tutorial-4-5-sysnand-4-5-cfw-9-4-emunand-without-gateway.378721/

    and then this to install 0004003000009D02.cia

    https://gbatemp.net/threads/release-pbt-cfw-import-cias-on-your-sysnand.383242/

    any help much appreciated...
     
  13. mid-kid

    mid-kid GBAtemp spamBOT

    Member
    879
    962
    Aug 2, 2012
    I've just done this today, together with formatting my sysNAND because I got fed up with the update nag.
    I grabbed FBI, changed to uninstall title from NAND, searched "0004003000009D02", uninstalled, and installed the browser CIA.
    No problems, whatsoever (I checked the version in the browser's settings with 3dbrew, and it checked out). I haven't tried to use any exploits with it yet, because I have no need to, currently.

    Instead of using 3DNUS, I used UpdateCDN with this .csv file:
    Code:
    TitleID,Region,Title versions,Update versions
    0004003000009D02,EUR,v6 v1024 v2050 v3074 v3088 v4096,2.0.0-2 Initial scan 2.1.0-4 4.0.0-7 5.0.0-11 7.0.0-13 7.1.0-16
    
    That is all.
     
  14. sj33

    sj33 GBAtemp Addict

    Member
    2,704
    1,710
    Oct 22, 2013
    Japan
    I did this today too - upgraded the browser on my 4.1 SysNAND to the one on 3DSNUS (presumably the latest) and it works fine.

    I'm not sure which version of the Ninjhax QR code I'm supposed to use though because the version number doesn't get updated with it. Ninjhax still works in my EmuNAND so it's not a problem but my motivation for upgrading the browser was to get Ninjhax working on my SysNAND.
     
  15. futaris

    futaris Member

    Newcomer
    40
    9
    May 25, 2006
    Brisbane
  16. EmanueleBGN

    EmanueleBGN GBAtemp Advanced Fan

    Member
    716
    352
    Jul 22, 2015
    Italy
    Worked on 4.1.0-0E: I installed the versione with the Spider Exploit in sysNAND, just restart my 3DS to apply the changes