Hacking Updating XCI/NSPs with Switch on lower firmware?

XpertXP1

Well-Known Member
OP
Member
Joined
Dec 13, 2013
Messages
150
Trophies
0
Age
41
XP
862
Country
United States
Switch is on 4.1.0. I want to update some of my games but doing so tells me I need to update the FW of my Switch. Can these update files be adjusted to work on lower firmware?
Thanks
 

XpertXP1

Well-Known Member
OP
Member
Joined
Dec 13, 2013
Messages
150
Trophies
0
Age
41
XP
862
Country
United States
For instance, I want to install the latest mario kart update, when I do this, after I launch the game it tells me my system needs to be updated. Any way around that from happening?
 

Draxzelex

Well-Known Member
Member
Joined
Aug 6, 2017
Messages
16,219
Trophies
1
Age
27
Location
New York City
XP
11,074
Country
United States
For technical reasons, this is currently impossible due to the new masterkey used for certain games and updates on 5.X. However, you can easily update without burning fuses so you can retain your 4.1 firmware while being able to install and play the update with this homebrew.
 

XpertXP1

Well-Known Member
OP
Member
Joined
Dec 13, 2013
Messages
150
Trophies
0
Age
41
XP
862
Country
United States
What about being on a lower firmware but have an XCI that requires a higher firmware, is there a tool that will adjust the firmware requirement on the XCI to enable it to play on a lower firmware switch? For instance, Octopath requires 5.0, im on 4.1.0.

Thanks!
 

naddel81

Well-Known Member
Member
Joined
Dec 14, 2009
Messages
2,425
Trophies
0
XP
2,435
Country
United States
What about being on a lower firmware but have an XCI that requires a higher firmware, is there a tool that will adjust the firmware requirement on the XCI to enable it to play on a lower firmware switch? For instance, Octopath requires 5.0, im on 4.1.0.

Thanks!
there is on 3DS, not on Switch.
 

Draxzelex

Well-Known Member
Member
Joined
Aug 6, 2017
Messages
16,219
Trophies
1
Age
27
Location
New York City
XP
11,074
Country
United States
Yes, its called ChoiDujourNX ;)

No, the tool that bypasses the firmware requirement for NSPs just resets the required firmware version of the XML file in the NSP which corresponds to the latest firmware at the time the game was put on the eShop. Both .XCI and .NSP are encrypted with masterkeys that are unlocked on certain firmwares dictated by Ninty so the only way to reduce those required firmware versions is either by theoretically decrypting and then reencrypting the game files or somehow giving those keys artificially to the console.
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    KennieDaMeanie @ KennieDaMeanie: I couldn't really get into moon it's too different for my likes